Announcement

Collapse
No announcement yet.

Smartthings Outlet Problem with JowiHue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Smartthings Outlet Problem with JowiHue

    Wim,

    firstly let me say great work on the plugin so far, i am working to use Jowihue to bring across my 20 or so Zigbee devices. i have been using separate platforms like Hubitat etc.. but i want to have this working all in one box and minimise hubs etc.., so with that in mind i have installed deCONZ onto the same Windows machine as Homeseer, and have paired my devices.

    so my Lightify bulbs work pretty well with the plugin, far more reliable than the Homeseer Zigbee plugin with the Lightify gateway.

    but i have 4 Smartthings plug outlets. these also have current monitoring, however i am accepting that i will lose that functionality.

    the device that Jowihue creates is a dimmable device, but the device itself cannot dim, and is reported by the API as an On/Off Light as you can see below.



    that isn't the biggest issue however, the on/off status never updates it is always registering as off, but the on & off controls do actually turn on and off the outlet.

    when the outlet is turned on the object returned is:

    Code:
    {
    "etag": "d434bc806b5c1340d63782c481c30c46",
    "hascolor": false,
    "type": "On/Off light",
    "name": "Flowers",
    "modelid": "3200-Sgb",
    "swversion": "30065310",
    "uniqueid": "00:0d:6f:00:05:90:f6:e3-01",
    "manufacturername": "CentraLite",
    "ref": 0,
    "RefBri": 0,
    "RefHue": 0,
    "RefSat": 0,
    "RefCT": 0,
    "RecoverUnreachable": false,
    "SuspectAfterDeRegistration": false,
    "state": {
    "on": true,
    "alert": "none",
    "reachable": true
    }
    }
    and when it is off it returns:

    Code:
    {
    "etag": "2d766f91afc15fa05fcc2eb9c9c24e60",
    "hascolor": false,
    "type": "On/Off light",
    "name": "Flowers",
    "modelid": "3200-Sgb",
    "swversion": "30065310",
    "uniqueid": "00:0d:6f:00:05:90:f6:e3-01",
    "manufacturername": "CentraLite",
    "ref": 0,
    "RefBri": 0,
    "RefHue": 0,
    "RefSat": 0,
    "RefCT": 0,
    "RecoverUnreachable": false,
    "SuspectAfterDeRegistration": false,
    "state": {
    "on": false,
    "alert": "none",
    "reachable": true
    }
    }
    can you please assist and provide an update for jowihue to correctly handle this.

    whilst here i have also paired smartthings door sensors and motion sensors, but other than a single temperature device these never update their values to deConz, has anyone else seen that behaviour and know how to resolve?
    Attached Files

  • #2
    Can you download this file and place it in the HS3 Config folder? After more or less 20 minutes you should see readings in the log that the file is being read (importing sensortypes). If I am right, the device should be updated and on of should be honoured.

    It should also read the power results, but I need to update the plugin itself for it... Will be in the next release

    Wim
    Attached Files
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      Awesome. This works now. Thanks.

      Looking forward to the energy readings when you get these up and running

      Sent from my SM-G950F using Tapatalk

      Comment


      • #4
        Today I will be publishing a new version of the plugin, which should also show the power device for your outlets. Let me know if it works?

        Thanks,

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • #5
          will do thanks

          Comment


          • #6
            I have installed the update, but i think that all-though the smartthings outlets support the power metering, im not 100% sure that deConz does or i'm missing something. which doesn't surprise me, its taken me a week to realise how to enroll and bind a contact sensor to actually display the open/close status

            Comment


            • #7
              The way deCONZ implemented this is adding a power sensor to the REST API. It is possible that this does not work (yet) for the smartthings outlet. Maybe a call on github is needed with images of the details in deCONZ is needed to add the support.
              I have checked this thread on github, but indeed no mention yet of the Smarthings outlets....

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #8
                ok thanks for the info. i am liking being able to again host both my Zwave and Zigbee networks all from the same machine. so again thanks for your work in this arena its much appreciated. now what i want to find out if i'm able to migrate all my 46 Hue bulbs from my hue hub to the Conbee as easily as i migrated from v1 to v2 hub think that might be wishful thinking but i have quite a few touchlink devices that are a PIA to move to the conbee. because i saw that if i move an item from the hub to the conbee and keep the name the same that jowiehue will use the existing devices and so dont need to recreate and edit events etc...

                Comment


                • #9
                  Fuzzysb,

                  In principle, devices that are moved from gateway A to B will hold the events and devices the same. Also even JowiHue scenes, although that can be a bit of hit and miss. Don't do them all at the same time, just one by one (two works fine too in my experience).

                  As for the Hue bulbs, be aware that Philips changed the Touchlink process. You need to power cycle the bulb before you can start a Touchlink process. Best way to have the reset done is using the deCONZ webapp (settings/Reset devices), as you can identify the bulb you are moving. Challenge is a bit how to move the ConBee or RaspBee around.

                  Wim
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment

                  Working...
                  X