Announcement

Collapse
No announcement yet.

Hue/Sat/CT settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hue/Sat/CT settings

    I'm having issues with subject settions.. notably, they are not correct values for current state of the bulb when set from the Hue bridge/app.

    If i change the values from JowiHue HS3 (HUE with color picker) device page, the device page appears to display the correct values until JowiHue updates from the hub, then they are wrong again!

    I need to be able to save the current, correct, state of the device, change it, then change it back. But if JowiHue isn't getting the correct HUE value.

    ideas?

    Marc

  • #2
    marcusone,

    I checked them today with my lights, but they are correct. Maybe I need more on detail what you are seeing? This is on a Philips Hue bridge right? Is it a Gen1 or Gen2 bridge? Are you controlling the Philips White and Color bulbs, or another type of light?


    After how much time does the device change to wrong values after setting it with the color picker? Using the color picker will set the light to the values picked in the colorpicker, but the detailed value can be changed by the bridge, based on gamut calculations, so it is possible it will change a bit, should not be large differences though.

    How do you compare with the Hue app? I do not know of the Hue app actually showing the value of the Hue setting?

    Thanks,
    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      You can check what the plugin gets from the Philips Hue bridge by going to the on/off device of the bulb. Look at the properties of the device and select the JowiHue tab. Het you will see json formatted text on the bottom, showing you the Hue value send by the bridge. This should match the value of the Hue device.

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        Thanks, I'll try to get around to taking screen captures of my phone and the HS3 page showing the issue and post...maybe awhile

        Gen2 bridge as far as i know. Firmware was just updated.
        Model: BSB002
        SW: 1806051111

        Comment


        • #5
          Got to it now..

          Here I set the color via Hue App.


          Shows in HS3 as:


          Set to Red in HS3:


          Hue shows this (close enough):


          HS3 Poles Hue bridge and changes HS3 to this (bulb still red in hue app)

          Comment


          • #6
            I think I now understand what you might be looking at? You are comparing the color of the colorpicker to the app, not the values?!!

            There is nothing trustworthy on the color of the colorpicker. The value is the correct value. HST enabled the colorpicker to show a color and they made it match the ZWAVE devices as those are using a hexa decimal value in the devices. For the Philips Hue devices the RGB is split in Hue, Saturation and brightness. But now HS3 is trying to convert the Hue value only to an color for the color picker.

            I wrote an email on this issue quite some time ago to Rich, with the question to let the plugin set the colorpickers value, so the plugin could present the value to use. Helas, so far no reponse back.

            For now, do not compare the color of the colorpicker with the color of the bulbs or the app!

            Wim
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment

            Working...
            X