Announcement

Collapse
No announcement yet.

Specify tcp port for deconz

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Specify tcp port for deconz

    Somehow jowiehue insists on connecting to my deconz bridge at port 80. This happenes after a long power outage today, and when the system bootet up, deconz started first and claimed port 80, which normally HS3 uses. I stopped deconz, restarted HS3, started deconz, and now it says my bridge is unreachable.

    Is it possible to somehow manually tell Jowiehue to look for deconz at port 8080 instead?

    Aug-11 00:16:22 JowiHue * Bridge T45CONBEE at 10.0.10.10:80 not connected (not reachable)
    Aug-11 00:16:22 JowiHue Warning: Bridge T45CONBEE not reachable on 10.0.10.10 is bridge powered on or IP/Port address has changed?
    Aug-11 00:16:22 JowiHue Cannot find bridge T45CONBEE on ip adress 10.0.10.10:80 marking unreachable

    edit:

    Oh well, I guess it just needed a few tries before it worked.. Would be nice to know how to force this in config though.

    Aug-11 00:19:02 JowiHue Warning: Bridge T45CONBEE changed IP from 10.0.10.10:80 to 10.0.10.10:8080 - Restarting processes for this bridge
    Aug-11 00:19:02 JowiHue Correcting port for bridge T45CONBEE
    Aug-11 00:18:32 JowiHue Pressed button for immediate scan for bridges - scanning started

  • #2
    Originally posted by gjelsvik View Post
    Somehow jowiehue insists on connecting to my deconz bridge at port 80. This happenes after a long power outage today, and when the system bootet up, deconz started first and claimed port 80, which normally HS3 uses. I stopped deconz, restarted HS3, started deconz, and now it says my bridge is unreachable.

    Is it possible to somehow manually tell Jowiehue to look for deconz at port 8080 instead?




    edit:

    Oh well, I guess it just needed a few tries before it worked.. Would be nice to know how to force this in config though.
    This is a deconz issue and is on their github issues list. The problem is deconz tries to use port 80 if available and if not then falls back to 8080 and then the next free port after that. Currently the only way to prevent deconz from taking port 80 is to have something else using it....

    Comment


    • #3
      I am not at home now, but there are config parameters (also for startup) that will start deconz on othere then default ports.... will look for it later

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        I have specified http port 8080 for deconz, so its just the lack of option to specify it in jowie hue im looking for.

        Comment

        Working...
        X