Announcement

Collapse
No announcement yet.

Xiaomi vibration sensor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tinge76
    replied
    Originally posted by Tinge76 View Post

    ZHAVibration

    **************************** Object info *****************************
    {
    "state": {
    "lastupdated": "2020-07-01T17:12:13.370",
    "vibration": false,
    "orientation": [
    2,
    1,
    88
    ],
    "tiltangle": 54,
    "vibrationstrength": 50
    },
    "config": {
    "on": true,
    "battery": 100,
    "pending": [],
    "reachable": true,
    "sensitivity": 11,
    "sensitivitymax": 21
    },
    "name": "Vibration Sensor",
    "type": "ZHAVibration",
    "modelid": "lumi.vibration.aq1",
    "manufacturername": "LUMI",
    "swversion": "20180130",
    "uniqueid": "00:15:8d:00:02:a5:1d:ee-01-0101",
    "ep": 1,
    "etag": "37e0e45c54a322a6dee6fda5ae850ce3"
    }
    ************************* End Object info ***************************
    did what you sugested.
    Now it is working perfect!
    Thank you for the help :-)

    Click image for larger version

Name:	Xiaomi Vibration info 2.jpg
Views:	28
Size:	41.4 KB
ID:	1399083

    Leave a comment:


  • w.vuyk
    replied
    The last update of the vibration sensor is from a few days back (2020-07-01) you did not move the sensor since then, or was it not seen by deCONZ anymore since then?
    Did you try resetting the device like Bill was suggesting to you? Start a search for devices in the JowiHue configuration and press the small button on the vibration sensor until the blue light blinks? Can you confirm this?

    Did you try and disable the plugin and delete the vibration device from the HS3 devicelist like Bill asked? What happens if you then restart the plugin?

    Leave a comment:


  • Tinge76
    replied
    Originally posted by bdickhaus View Post

    Phoscon does not display all of that info that I am aware of, at least it doesn't for me. There are two possibilities, both are fixable. One is that deCONZ did not fully discover the device, or it was discovered before deCONZ was aware of all of the capabilities. Or, the same for JowiHue, the device was added before JowiHue was aware of how to define it. Or both.

    In the JowiHue tab for the vibration device, what is in the JSON? Scroll down to see it. Copy and paste that in a message and we can look at it. If it does not have all of the information, then you will need to rediscover the device in deCONZ. Don't delete it in deCONZ or Phoscon, just search for a new sensor in Phoscon and push the button on the sensor until it blinks. Wait a minute or so.

    Either way, disable JowiHue, delete the two HS devices, and enable JowiHue and all the correct devices should be created. I had to do both of these things because I added it before it was fully supported.

    Bill
    ZHAVibration

    **************************** Object info *****************************
    {
    "state": {
    "lastupdated": "2020-07-01T17:12:13.370",
    "vibration": false,
    "orientation": [
    2,
    1,
    88
    ],
    "tiltangle": 54,
    "vibrationstrength": 50
    },
    "config": {
    "on": true,
    "battery": 100,
    "pending": [],
    "reachable": true,
    "sensitivity": 11,
    "sensitivitymax": 21
    },
    "name": "Vibration Sensor",
    "type": "ZHAVibration",
    "modelid": "lumi.vibration.aq1",
    "manufacturername": "LUMI",
    "swversion": "20180130",
    "uniqueid": "00:15:8d:00:02:a5:1d:ee-01-0101",
    "ep": 1,
    "etag": "37e0e45c54a322a6dee6fda5ae850ce3"
    }
    ************************* End Object info ***************************

    Leave a comment:


  • bdickhaus
    replied
    Originally posted by Tinge76 View Post

    Phoscon version 2.05.77 FW:26350500
    jowihue version 2.1.1.0
    Phoscon does not display all of that info that I am aware of, at least it doesn't for me. There are two possibilities, both are fixable. One is that deCONZ did not fully discover the device, or it was discovered before deCONZ was aware of all of the capabilities. Or, the same for JowiHue, the device was added before JowiHue was aware of how to define it. Or both.

    In the JowiHue tab for the vibration device, what is in the JSON? Scroll down to see it. Copy and paste that in a message and we can look at it. If it does not have all of the information, then you will need to rediscover the device in deCONZ. Don't delete it in deCONZ or Phoscon, just search for a new sensor in Phoscon and push the button on the sensor until it blinks. Wait a minute or so.

    Either way, disable JowiHue, delete the two HS devices, and enable JowiHue and all the correct devices should be created. I had to do both of these things because I added it before it was fully supported.

    Bill

    Leave a comment:


  • Tinge76
    replied
    Originally posted by ZoRaC View Post

    What version of deCONZ and JowiHue?
    Do you see the values in Phoscon (I think they ahould be visible there?)?
    Phoscon version 2.05.77 FW:26350500
    jowihue version 2.1.1.0

    Leave a comment:


  • ZoRaC
    replied
    Originally posted by Tinge76 View Post

    How do you get to see all these values in HS3 lke tilt angle and stuf? I get only this:
    What version of deCONZ and JowiHue?
    Do you see the values in Phoscon (I think they ahould be visible there?)?

    Leave a comment:


  • Tinge76
    replied
    Originally posted by racerfern View Post
    Voila! 66 seconds after movement, it said no movement! I have mine positioned upside down attached to the washing machine body so I'm not expecting Orientation to change,
    Click image for larger version

Name:	Screen Shot 04-11-19 at 06.13 PM.PNG
Views:	158
Size:	59.8 KB
ID:	1298534
    How do you get to see all these values in HS3 lke tilt angle and stuf? I get only this:

    Leave a comment:


  • w.vuyk
    replied
    On github this issue was reported also few days ago. I believe they will change this behaviour by resetting the vibration strength. Not sure if this is already done in the latest version.

    Wim

    Leave a comment:


  • MattL0
    replied
    is movement based on the other metrics? ex: if oldvalue != newvalue. If this is the case, that would be a mislabel.

    Leave a comment:


  • racerfern
    replied
    So my question now is, after the sensor reverts to no movement, why doesn't the vibration strength return to 0?

    Leave a comment:


  • racerfern
    replied
    Voila! 66 seconds after movement, it said no movement! I have mine positioned upside down attached to the washing machine body so I'm not expecting Orientation to change,
    Click image for larger version

Name:	Screen Shot 04-11-19 at 06.13 PM.PNG
Views:	158
Size:	59.8 KB
ID:	1298534

    Leave a comment:


  • w.vuyk
    replied
    We just have to wait I suppose....

    Leave a comment:


  • ZoRaC
    replied
    How long does HST need to put the new version in the updater? Taking forever...

    Leave a comment:


  • w.vuyk
    replied
    I have submitted 2.0.3.2 just now to HST. This version is supporting the new implementation of the vibration sensor. The old version will no longer work, you can remove the devices on the manage devices page.
    To enable the new vibration sensor implementation you have to use at least version 2.05.60 of the deCONZ. To find the latest version, go to https://www.dresden-elektronik.de/deconz

    If you had a vibration sensor joined on an older version of deCONZ, go to the configuration page of deCONZ and start a new scan for devices. Then press the small button on the vibration sensor for 5 seconds (until the blue light starts blinking). This should add the new implementation in deCONZ as weel as the plugin.

    You'll find lots of new details in the new devicegroup!

    Wim

    Leave a comment:


  • w.vuyk
    replied
    The vibration stength will be available in the new device group. But do not keep your hopes up high on this one. In my test I dropped the device from high and strength changed to 65 after few seconds (longer then expected). After this test I twisted the sensor, laying on the desk. Strength changed to 135.... I do not see the logic there yet.

    But while typing here on my desk, the movement stays true which is good, so I am guessing movement, tiltangle and position (battery up/reset button up/etc,etc ) will be my favorites.

    Leave a comment:

Working...
X