Announcement

Collapse
No announcement yet.

JowiHue Beta december

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JowiHue Beta december


    This beta is adressing mainly the issues we see now and then on double devices, lights and/or sensors.These changes are mainly under the hood, so you migh not see much changes happening in this version. There are other changes as well, which are visible, these will be addressed at the end as a list of changes.

    If you want to join the beta, as always, but this beta in particular, make sure you have a trustworthy back-up of homeseer as well as the JowiHue files under the data directory and the production version of the plugin (which you always can download with the updater).

    JowiHue beta 2.0.2.15
    • Changed scriptingfunctions "SetLightsRGB", SetLightsKelvin" and "SetLightsHueSat" to accept a bright value of 0 for Philips bridges, which will switch the light off.
    • Major changes on the Bridge maintenance page regarding sensors. You can now remove devices from HS3 and/or remove sensors or switches from the gateways. Make sure to read the updated documentation about this feature!
    • Removed a chance of creating double battery devices for sensors that are (yet) of unknown type.
    • Changed the response for orphaned devices as it is possible that the sensor was removed before to be re-added later
    • Changed the plugin's behaviour on xy results from lights. Those are now enforced on the Dim/Sat and Hue values of a device.
    • removed a test for future change of accessing a Philips Hue bridge. This caused the bridge being unreachable for some users.
    If everything goes well, this beta will be the release version

    JowiHue beta 2.0.2.14
    • Solved an issue creating and/or editing groups on the Bridge maintenance page. When hiding sensor groups was selected in the configuration page of the plugin, the Bridge maintenace page would hide all groups, making it impossible to edit or add groups.
    • Solved a second issue with editing groups when trying to add groups to the deCONZ bridge.

    JowiHue beta 2.0.2.13
    • Solved the concurrent database error! That must have been the most stubborn bug in the lifetime of this plugin.. Lamptypes are now normally updated again. This will also solve the issues with dimming of certain lights and lost CT devices.
    • Added the possibility to refresh all lights device values or all sensor devicevalues. This can be done on the configuration screen on the miscellaneous tab
    • Added a "blink" option to all lights on the manage devices page of Homeseer. This can now also be selected as device action in events. To enable this option, you need to refresh the device values, either through properties of a device, or using the new refresh all light devices button in the configuration screen.
    • On rare occasions an internal database can be corrupted. The plugin will then restart itself. One table was missed. This is corrected.

    JowiHue beta 2.0.2.12
    • Solved an issue when a decimal point was used in the rules of the bridge
    • Did more rework on the updateusage constraint error, this is really a stubborn issue!
    • Tuned the animations a bit more as now the animation would not stop if a light touched by the animation is send another command
    • Added sensitivty to the vibration sensor (deCONZ needs to be on version 2.05.52 for this!)
    • re-enabled setting the duration for motion sensors on the JowiHue tab
    • Added reporting of Energy usage to the HS3 energy database for plugs supporting energyconsumption reporting. To enable this, you need to enable energy reporting on the configuration/miscelennious tab.
    • Removed the deletion of "orphaned"sensordevices when starting the plugin. It can happen that devices appear orphaned when the bridge is starting up at the same time as the plugin. The plugin will now advice to remove it only. Double devices are still removed!

    JowiHue beta 2.0.2.11
    • infinite animations did stop at any command send, not only commands to lights used in the animation. Solved
    • Changed behaviour of the DimAnimation scriptcommand. If the animation is not running and the animations is not a stretched animation, the animation will be started with the dimmed parameter.
    • Using an underscore ("_") in scenenames could cause the webpage to not show the scene anymore. because this caused display issues The underscore is now replaced by a space for scenes to prevent this.
    • Changed the timeout for getting information from the bridge

    JowiHue beta 2.0.2.10
    • Animations addressing scenes that use groups were not working. This was an old issue that never surfaced before. These are working now
    • Updating the LampTypes table for systems that are using a "." as decimal seperator was still not working, causing some lights not to go off, or scenes to trip. This is solved
    • Using the new scriptcommand "DimAnimation" has changed so that instead of using one animation name, you can also use "all". The plugin will then dim all running animations.
    • The start animation action in an event can now also set the relative dim value from the first start.
    • The scene action now also have the possibility to set a relative dim.

    JowiHue beta 2.0.2.9

    In this first beta, the plugin has two major changes under the hood. First off all, it will hold back creating devices until the plugin is fully started. This might cause a bit of a delay during startup, but I expect it will prevent creating al those doubles some of you have seen.

    Secondly, in this stage, the plugin will evaluate each sensor device and check if the internal information is correct. Especially deCONZ devices from the past (one year ago) can hold old information or even wrong information due to the many beta stages we went through with both the plugin and deCONZ. The plugin will - if it finds errors - try to correct this information, by updating the devices and maybe even the bridge information. Those changes will be logged in the HS3 log at the first run. A second run should show no more lines as all issues should have been resolved.

    There might be a few sensordevices that are really orphans. The plugin will proceed here and remove the orphaned devices. I have this tested with a few others, and so far the plugin did the right step. But this is for sure the reason you need that back-up! If you do join this beta and wrong devices are changed or even removed,, send me the log and explain why this should not have been done. If a sensor gets damaged, consider removing the device and joining the sensor back in deCONZ.

    In the next beta phase, the same check will be done for Lights and plugs. I do not expect many issues with that, but cannot tell for sure yet.

    Other changes are:
    • Restyled the processes handling sensors and lights. Difficultt to measure, but especially sensor actions are handled much faster now.
    • Certain sensors would not update for a few users. Cause found and solved
    • Battery devices would not update for some users. Cause found and solved. When you have doubts, check the properties of the sensordevice, JowiHue tab. On the bottom you will find the information coming from the bridge, check the battery value here to the battery device value.
    • Added the possiblilty to relatively dim a running animation or scene with JowiHue actions. (Not yet regression tested)
    • Also added two sript commands with the plugin to activate the relative dim for scenes or animations:
    Code:
      
      Dim test As Boolean = hs.PluginFunction("JowiHue", "", "DimScene", {"MyScene", 60})
    Or
    Code:
     Dim test As Boolean = hs.PluginFunction("JowiHue", "", "DimAnimation", {"MyAnimation", 60})
    Where the parameter behind "myAnimation" is the dimming percentage, relative to the full setting of the used scenes. A value of 0 will thus bring back the lights to 100% of the used brightness value of the scenes.
    • Solved an issue where a animation could abort when the option "Return to orginal settings after animation ends" has been set.
    • Adjusted the maximum saturation level in creating scenes and using the colorpicker. This could return an unaccepted error.
    • Added basic sensorinformation on the Bridge Maintenance page. For now this only shows the currently known sensors. In a next Phase the ability will be added to remove the sensor from the bridge.
    • Re-enabled editing lights on the Bridge Maintanance page
    • Finetuned the power consumption capabilities when a plug is used that supports the reporting of power usage. In the next phase energy reporting to the HS3 energy database will be added.
    • Several users saw this errorline when starting the plugin with the JowiHueImports.xml lfile in the config directory:
    Code:
      
    Error: (UpdateLampTypes)::Concurrency violation: the UpdateCommand affected 0 of the expected 1 records. 
    As I have not been able to copy this issue I hope I found the cause behind this issue. Please confirm if this line is gone now?

    Please post issues with the beta plugin to this thread. Also I would like to hear if you experienced issues that should be solved with this beta if those are solved or still present.

    I will update this first post when new updates come available

    Thanks!

    Wim



    Last edited by w.vuyk; January 16th, 2019, 06:54 AM. Reason: Added new beta 2.0.2.15
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

  • #2
    Just to be clear does the 2.0.2.9 only have the first phase changes?
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

    Comment


    • #3
      Randy

      And all the bullet points, so also your reuqests for the animations and the error solved
      But no lights check yet....
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        Then the newer animations still will not start with "Return to original settings after animation ends" enabled. I will send you another detailed log in a few minutes.

        EDIT: Actually I was too impatient. They seem to be working . There was a slight delay and it is daytime, making them difficult to see. I will check later tonight and post back.

        I will also play with the brightness setting for scenes. Will that work on a running animation, or will it have to be restarted?
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


        • #5
          Lots of errors while running an animation. I will email you the log.

          I will also note that the errors on s1-s6 and n1-n6 are the 12 driveway path bulbs I just added. The sconce bulbs also generate errors, but they have been installed for months.

          Code:
          Dec-06 12:22:35 PM         JowiHue    Light Driveway S1 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway S2 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway S3 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway S4 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway S5 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway S6 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway N1 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway N2 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway N4 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway N5 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Light Driveway N6 seems to have an unknown type
          Dec-06 12:22:35 PM         JowiHue    Animation Driveway RG Bottom Up Finished
          Dec-06 12:22:34 PM         JowiHue    Light Driveway S1 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway S2 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway S3 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway S4 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway S5 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway S6 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway N1 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway N2 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway N4 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway N5 seems to have an unknown type
          Dec-06 12:22:34 PM         JowiHue    Light Driveway N6 seems to have an unknown type
          Dec-06 12:22:33 PM         JowiHue    Light Driveway Sconce S top seems to have an unknown type
          Dec-06 12:22:33 PM         JowiHue    Light Driveway Sconce N top seems to have an unknown type
          Dec-06 12:22:33 PM         JowiHue    Light Driveway Sconce S bot seems to have an unknown type
          Dec-06 12:22:33 PM         JowiHue    Light Driveway Sconce N bot seems to have an unknown type

          Randy Prade
          Aurora, CO
          Prades.net

          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

          Comment


          • #6
            Randy,

            The errors you are seeing here, should be no problem really. I added this specific loggin to prepare for the lights check. Forgot to remove those. No conection to the animation issue. That is something we need to resolve.
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #7
              ​I updated to .29 and the hue light that should shut off at 22:00 is unresponsive. Went back to .28 and still no control over the light. Suggestion?

              As I dig deeper it seems lights are missing from the lights section.
              Dec-07 07:47:09 JowiHue Error: (SetDeviceByUserRequest)::SDBUR colorpicker -----Object reference not set to an instance of an object.
              Dec-07 07:47:01 JowiHue Error: (SetDeviceByUserRequest)::SDBUR colorpicker -----Object reference not set to an instance of an object.
              Dec-07 07:46:43 JowiHue Light Red North seems to have an unknown type Color dimmable light
              Dec-07 07:46:43 JowiHue Error: (SetDeviceByUserRequest)::SDBUR setstate off start-----Object reference not set to an instance of an object.
              Dec-07 07:46:32 JowiHue Error: (SetDeviceByUserRequest)::SDBUR setstate dim start-----Object reference not set to an instance of an object.
              Dec-07 07:43:08 JowiHue Error: (RecoverUnreachable):Updating light:Object reference not set to an instance of an object.
              Dec-07 07:43:08 JowiHue Error: (RecoverUnreachable):Updating light:Object reference not set to an instance of an object.
              Dec-07 07:24:36 JowiHue Removing user 1C126B29ED from Bridge deCONZ-GW-RPi3 on 192.168.1.73
              Dec-07 07:24:36 JowiHue user 1C126B29ED from Bridge deCONZ-GW-RPi3 is removed
              Dec-07 07:16:54 JowiHue Scanning New lights started. If New lights are found the plugin will add them automatically
              Dec-07 07:16:48 JowiHue Scanning New sensors started. If New lights are found the plugin will add them automatically
              Dec-07 07:16:27 JowiHue Error: (SetDeviceByUserRequest)::SDBUR setstate dim start-----Object reference not set to an instance of an object.
              Dec-07 07:16:13 JowiHue Light JH Corner Lamp seems to have an unknown type Extended color light
              Dec-07 07:16:13 JowiHue Error: (SetDeviceByUserRequest)::SDBUR setstate off start-----Object reference not set to an instance of an object.
              Dec-07 05:10:05 JowiHue Light JH Corner Lamp seems to have an unknown type Extended color light
              Dec-07 05:10:05 JowiHue Error: (SetDeviceByUserRequest)::SDBUR setstate off start-----Object reference not set to an instance of an object.
              Dec-07 05:10:05 JowiHue Light JH Corner Lamp seems to have an unknown type Extended color light
              Dec-07 05:10:05 JowiHue Error: (SetDeviceByUserRequest)::SDBUR setstate off start-----Object reference not set to an instance of an object.
              Dec-07 05:09:34 JowiHue Light Red North seems to have an unknown type Color dimmable light
              Dec-07 05:09:34 JowiHue Light Green South seems to have an unknown type Color dimmable light

              Comment


              • #8
                I’m having the same problem with a single bulb. I’ll dig into the problem in an hour or so I will post back here when I find something. When I looked at the Hue app, the bridge had an update waiting. After updating the bridge, every bulb needs an update. Doing that now. I last looked at the app last week and there were only updates on the 12 bulbs I installed, so this is new.
                Randy Prade
                Aurora, CO
                Prades.net

                PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                Comment


                • #9
                  My bridge is on .49 IIRC, it was current as of yesterday. I think. Keep me posted.

                  Comment


                  • #10
                    Every standard bulb on my house bridge and both bridges need software updates. The garage bridge needed an update as well. My strips and GU10 bulbs do not need updates. This will take a while.

                    the bulbs were all 1.29 and are going to 1.46. The 12 bulbs I added and the four that were on the garage bridge updated to 1.46 last week. It is clear I never checked the house bridge. I’m still not ready to enable automatic updates.
                    Randy Prade
                    Aurora, CO
                    Prades.net

                    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                    Comment


                    • #11
                      rprade, this will be the update Philips has been promising. But it should not hold the plugin from putting the lights off.

                      I am pretty sure this is an issue that has to do with the lamptypes table. racerfern is this ight the GLEDOPTO device that is not responding? I still see the recoverunreachable issue. Did you change anything to have this lamp closer to another bulb or plug?

                      Randy will perform a test soon where I have made some corrections for the lamptypes table. If this works for him, I will release a new beta and hope you can test this one to see if the light becomes controllable again. After that, I think I will want a log from you regarding the errors on the GEDOPTO to see if I can change something there.

                      Wim
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                      • #12
                        It will still be about an hour. I want to let the Hue updates finish, test everything, then I will try the new plug-in. I will send you a log and notes after all is done.
                        Randy Prade
                        Aurora, CO
                        Prades.net

                        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                        Comment


                        • #13
                          Originally posted by w.vuyk View Post
                          rprade, this will be the update Philips has been promising. But it should not hold the plugin from putting the lights off.
                          I’m certain you are correct. Otherwise it would be more than a single bulb. I just want to do all of this carefully so I can see what changes at every step.


                          Randy Prade
                          Aurora, CO
                          Prades.net

                          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                          Comment


                          • #14
                            After all of the updates I can confirm these odd behaviors on the single bulb. The rest of them in my living room work properly. This one bulb does not respond to direct control by the HomeSeer device. It will not dim or turn off. It does respond to dim levels set by event. It does not respond to being turned off by event. It does not respond to color change by the HS device, but it does by event. Any changes made by event are reflected in the HS device. It is very odd. From the Hue app I was able to turn the entire group off, but the HomeSeer device will not turn the lamp off. The HomeSeer Hue Group will turn it off. It seems like a disconnect between the HomeSeer device and the physical light.

                            Can I delete the HomeSeer device and let the plug-in create it again?

                            i am going to stop for now. I will leave this light alone and move on to the plug-in update in about 30 minutes.
                            Randy Prade
                            Aurora, CO
                            Prades.net

                            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                            Comment


                            • #15
                              I restarted HomeSeer and the unresponsive bulb remains so. I will now do the update Wim sent me this morning.
                              Randy Prade
                              Aurora, CO
                              Prades.net

                              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                              Comment

                              Working...
                              X