Announcement

Collapse
No announcement yet.

Need to specify port on deConz questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need to specify port on deConz questions

    So today I perform my monthly W2k16 windows update which naturally created the need to reboot my system. I have not rebooted since adding the deConz….
    When the Fire Daemon services started both deConz and HS3, upon going to the HS3 webpage, I noticed that deConz stole the port number - as I had configured HS3 with a delayed start. This presents a problem naturally. Saying that, I'd like to start the deConz on an alternate port within my service. From what I see, I can invoke deConz with as:

    deCONZ --auto-connect=1 --dbg-error=1 --http-port=8090 --ws-port=20877 --upnp=0

    When I start the deconz after HS3 starts it appears the webserver port is 8090 - perhaps it decides on the next available port. In the example above that I found on the web, I can only assume you can also specify the web server port - which in my case I wouldn't need if the port of 8090 is both the application/web server port. Assuming I don't need --ws if I specify 8090, do I need the other flags?

    Robert
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

  • #2
    I can see one thing that is required to do. It is best if you start deconz first and HS second. I use startup delayer to do this. I set the times to start manually at 5s for deconz and 40s for HS in startup delayer. This seems to time out pretty well. In startup delayer you can add the --http-port= and --ws-port= at the end of the exe you add to startup delayer for deconz. I use http port at 93 and ws port at 97. Others use similar methods and maybe they can chime in on theirs.

    Comment


    • #3
      Yeah.. I don't need startup delayer as my HS3 is configured as a delayed service in FD. The issue I was having was starting deConz as a service first which grabs port 8080. I've configure the deConz parameters as:

      deCONZ --auto-connect=1 --dbg-error=1 --http-port=8090 --ws-port=8088 --upnp=0

      Note for others, --ws is not webserver port but rather websockets port.

      Robert
      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

      Comment


      • #4
        I had this issue when I first installed deConz, except it kept stealing port 80 from Homeseer, especially when I would launch Phoscon. I ended up simply changing HS to port 85 in the network settings tab of HS to avoid the conflict. However when I upgraded deCONZ to 2.05.50 recently I noticed that deCONZ and Phoscon now default to port 8090. Latest version of deCONZ can be found here: https://www.dresden-elektronik.de/deconz/win/

        --Barry

        Comment


        • #5
          logman If deConz keeps stealing port 80, how do you get to HS to change the port in the Network Settings tab? I just installed deConz and HS3 with an Aeotec Z-stick on a RPi3B+. I can't get to HS3 to make the change unless I have to disable Phoscon first?? I'm confused to say the least.

          Comment


          • #6
            Originally posted by racerfern View Post
            logman If deConz keeps stealing port 80, how do you get to HS to change the port in the Network Settings tab? I just installed deConz and HS3 with an Aeotec Z-stick on a RPi3B+. I can't get to HS3 to make the change unless I have to disable Phoscon first?? I'm confused to say the least.
            What version of deCONZ did you install? This issue was solved a few months ago I thought. Try to close deDONZ and then logging into Homeseer.

            --Barry

            Comment


            • #7
              OK, I shutdown deConz and Phoscon then was able to get to HS3. I changed the port and now I can access either one.

              However... I'm stuck at the deConz Connect to Device screen and clicking on Connect yields nothing. And if I shutdown deConz, it will not run again. Not good.

              Comment


              • #8
                Originally posted by racerfern View Post
                OK, I shutdown deConz and Phoscon then was able to get to HS3. I changed the port and now I can access either one.

                However... I'm stuck at the deConz Connect to Device screen and clicking on Connect yields nothing. And if I shutdown deConz, it will not run again. Not good.
                Screenshots of what you are seeing would be helpful. Several of us here have quite a bit of experience with deCONZ and can probably help get you going, but I'm more of a visual troubleshooter.

                Have you read through the deCONZ help file? Here is a copy in case you need it:

                deCONZ-BHB-en.pdf

                --Barry

                Comment

                Working...
                X