Announcement

Collapse
No announcement yet.

new alarm device on xiaomi aquara motion sensor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    yes that's weird.

    i checked my locale on my server , it is good . Same thing in phoscon.

    Code:
    locale
    LANG=en_CA.UTF-8
    LANGUAGE=
    LC_CTYPE="en_CA.UTF-8"
    LC_NUMERIC="en_CA.UTF-8"
    LC_TIME="en_CA.UTF-8"
    LC_COLLATE="en_CA.UTF-8"
    LC_MONETARY="en_CA.UTF-8"
    LC_MESSAGES="en_CA.UTF-8"
    LC_PAPER="en_CA.UTF-8"
    LC_NAME="en_CA.UTF-8"
    LC_ADDRESS="en_CA.UTF-8"
    LC_TELEPHONE="en_CA.UTF-8"
    LC_MEASUREMENT="en_CA.UTF-8"
    LC_IDENTIFICATION="en_CA.UTF-8"
    LC_ALL=
    Code:
    xxxx@Automation:~# cat /etc/timezone
    America/Toronto
    Attached Files

    Comment


    • #17
      So...since phoscon is just a getting data from deconz.

      This is a deconz or a jowihue plugin issue.

      Comment


      • #18
        The json that the JowiHue plugin displays is the raw data from the deCONZ REST api, that is where the date/time come from. I looked at mine and the time is GMT.

        I have two of the motion sensors without the aq2, and one with. None of them have an alarm device defined.

        So I played around in the deCONZ gui with reading the individual items in the Basic cluster for the aq2 sensor. And I think it was software build that triggered a change, and the alarm device got added. So it looks like deCONZ is not always discovering all of the Basic cluster information, but when it does, it creates an alarm device.

        Comment


        • #19
          ok was able to change the locale time to

          {
          "timezone": "America/Montreal"
          }

          with this via postman

          http://dresden-elektronik.github.io/...configuration/

          I do not know if it will change something

          Comment


          • #20
            here is what the deconz rest api return now, after rebooting my server( I removed useless data) :

            Code:
            {
                "UTC": "2019-03-06T08:30:35",
            
            
            
                },
            
                "linkbutton": false,
                "localtime": "2019-03-06T03:30:35",
            
            
            
            
            
                },
                "timeformat": "24h",
                "timezone": "America/Montreal",
            
            }

            And here is what i get from a jowi sensor that the status has been updated:

            Code:
            **************************** Object info *****************************
            {
            "state": {
            "presence": false,
            "lastupdated": "2019-03-06T08:25:30"
            },
            "config": {
            "on": true,
            "battery": 100,
            "duration": 115,
            "reachable": true
            },
            "name": "Bedroom poll xiaomi wall motion",
            "type": "ZHAPresence",
            "modelid": "lumi.sensor_motion.aq2",
            "manufacturername": "LUMI",
            "swversion": "20170627",
            "uniqueid": "00:15:8d:00:02:f8:d8:16-01-0406",
            "ep": 1,
            "etag": "94739329b4361bf8d144e58727a5a0a4"
            }
            ************************* End Object info ***************************
            Even if deconz had the wrong timezone ( now it is the good one), jowihue still has the wrong time for the ''lastupdated' ( the same time as the UTC variable in the json response from deconz api ).

            I do not know why ''localtime'' is not used

            Comment


            • #21
              I tried a get request to : MY_IP/api/my_app_KEY/sensors with postman.

              the response still has the wrong time. So this is not a jowihue issue :

              "name": "hue bedroom motion",
              "state": {
              "dark": true,
              "daylight": false,
              "lastupdated": "2019-03-06T08:46:04",
              "lightlevel": 0,
              "lux": 0
              },
              "swversion": "6.1.0.18912",
              "type": "ZHALightLevel",


              I submitted a question to deconz github : https://github.com/dresden-elektroni...in/issues/1327


              edit :

              from this http://dresden-elektronik.github.io/...doc/schedules/

              it seems that the schedule function of deconz use the UTC time format. So I do not know why jowihue get the "lastupdated" from the sensors...?Maybe it is just useful for the author of this plugin , but meaningless for the user?

              Comment


              • #22
                The alarm sensors issue should be fixed in DeCONZ v.61
                Attached Files

                Comment


                • #23
                  Don't worry about the lastupdated field, it is only used by the plugin to check if there has been a change. The last change time of the HS3 device is what you should check and this works fine. the plugin thakes care of that.

                  I am hoping the extra alarm device will disappear, it has been there for quite some time already (4 months here I believe, and lastupdated stays at 'none' for that is there are no updates.
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment


                  • #24
                    Good news!!! First time i like errors logs

                    Apr-14 17:32:15 JowiHue Warning: Or remove the devices belonging to this sensor
                    Apr-14 17:32:15 JowiHue Warning: Did you remove a sensor from the bridge but left the HomeSeer devices? Re-add the sensor to the bridge and your events are save
                    Apr-14 17:32:15 JowiHue Warning: Orphaned Sensor Bathroom shelve motion (526) found, not found on any connected bridge
                    Apr-14 17:32:15 JowiHue Warning: Or remove the devices belonging to this sensor
                    Apr-14 17:32:15 JowiHue Warning: Did you remove a sensor from the bridge but left the HomeSeer devices? Re-add the sensor to the bridge and your events are save
                    Apr-14 17:32:15 JowiHue Warning: Orphaned Sensor Xiaomi motion bedroom closet (516) found, not found on any connected bridge
                    Apr-14 17:32:15 JowiHue Warning: Or remove the devices belonging to this sensor
                    Apr-14 17:32:15 JowiHue Warning: Did you remove a sensor from the bridge but left the HomeSeer devices? Re-add the sensor to the bridge and your events are save
                    Apr-14 17:32:15 JowiHue Warning: Orphaned Sensor Bedroom xiaomi wall motion (515) found, not found on any connected bridge
                    Apr-14 17:32:15 JowiHue Warning: Or remove the devices belonging to this sensor
                    This mean, no more alarm sensor Devices



                    *****Just updated deconz to V63*****

                    Comment

                    Working...
                    X