Announcement

Collapse
No announcement yet.

Some newbie questions/issues on the JowieHue plug-in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Some newbie questions/issues on the JowieHue plug-in

    Just started using the JowieHue plug-in. Nice plug-in! I have some questions/issues:

    1. All my lights and Philips Hue groups were added with the default Floor (Location 1) and Room (Location 2) named "JowieHue". Is it okay to change the Floor and Room, or is the plug-in dependent on the Floor and Room being "JowieHue"? Will renaming Floor and/or Room cause any potential problems when JowieHue syncs with the Philips Hue Bridge in the future (for example, if I remove or rename devices in the Hue app but those devices' Floor and/or Room were renamed in HomeSeer)?

    2. My lights' naming convention is prefaced with room name. For example: "Dining Room Lamp", "Living Room Ceiling Lights". Including room name allows me to easily tell what a light is for when importing the Hue configuration into HomeKit, Alexa, and HomeSeer/JowieHue. I suppose changing the lights' names to remove the room prefix (since HomeSeer has a separate Room location field) would cause havoc since HomeSeer/JowieHue would sync the name back to the bridge, and then the bridge would want to sync to HomeKit and Alexa.... what naming convention do folks like to use?

    2. When I added lights/rooms using the Philips Hue app, I selected all 11 predefined scenes (e.g. Savanna Sunset, Energize, Concentrate, etc.). This adds up to 95 scenes (since each predefined scene is repeated for each Philips Hue group). In HomeSeer, the JowieHue->Bridge Maintenance page says: "Scenes: 95(105)". What does this mean? Does it mean only a maximum of 105 scenes are supported? I can delete some predefined scenes that I don't need like "Spring Blossom" and "Tropical Twilight", but a number of them I'd like to keep.

    3. Minor issue I ran into: - In the JowiHue Light details page, I entered, for my lights, "Purchase date:" and "Hours of usage before using plugin", followed by "Done". The values that I enter are not saved. When I go back to the Light details page, the Purchase date reverts back to the day I installed the JowieHue plugin and the Light usage does not account for the hours that I entered. Then, I turned on and off the light from HomeSeer, and I reentered the Purchase date and Hours of usage, and the values were saved properly. Same behavior for all my other Hue lights. It seems that if a light has not yet been changed (via on/off) using the JowieHue plug-in, the Hours of usage and Purchase date are no saved. Once I turn on and off a light (using JowieHue plugin), then I can enter the values for those 2 fields and they are correlty saved. Maybe an initialization problem somewhere that is resolved once a light is controlled by the plugin?

    4. - All the predefined Hue scenes (Relax, Read, Concentrate, etc.) were imported into HomeSeer. When defining an event with "JowiHue: JowiHue Actions" and "Set Scene", the Select Scene popup list has all the predefined Hue scenes. Unfortunately, the Philips predefined scenes all have the same name, and each predefined name shows up multiple times (for example, "Arctic Aurora" shows up 9 times since I have 9 Philips groups in the Philips Hue app that use "Arctic Aurora". I can't distinguish which scene applies to what group of lights. The Select Scene popup is also very long (95 scenes total). Any suggestions? I can sort of guess what scene applies to what lights by checking the order of the scenes in the
    Bridge maintenance->Scenes on Bridge page. Any suggestions?


    Thanks.






  • #2
    I can answer #1
    yes, you can change those names I do. I use the location and device. I had longer ones but I went back through and shortened them to make it easier in drop down boxes.

    Click image for larger version  Name:	hue.png Views:	1 Size:	82.9 KB ID:	1293907

    HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
    Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
    Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

    Comment


    • #3
      Originally posted by drparker151 View Post
      I can answer #1
      yes, you can change those names I do. I use the location and device. I had longer ones but I went back through and shortened them to make it easier in drop down boxes.

      Click image for larger version Name:	hue.png Views:	1 Size:	82.9 KB ID:	1293907
      haha... was afraid of doing this too. Thanks! You never know on what plugins depends on !

      Comment


      • #4
        Originally posted by drparker151 View Post
        I can answer #1
        yes, you can change those names I do. I use the location and device. I had longer ones but I went back through and shortened them to make it easier in drop down boxes.
        Thanks! I have other plug-ins that also create their own devices and it always makes me nervous if a plug-in might have trouble if I were to change the Floor/Room. Good to know this won’t case the JowieHue plug-in any problems!

        Comment


        • #5
          Originally posted by randman View Post
          Just started using the JowieHue plug-in. Nice plug-in! I have some questions/issues:
          4. - All the predefined Hue scenes (Relax, Read, Concentrate, etc.) were imported into HomeSeer. When defining an event with "JowiHue: JowiHue Actions" and "Set Scene", the Select Scene popup list has all the predefined Hue scenes. Unfortunately, the Philips predefined scenes all have the same name, and each predefined name shows up multiple times (for example, "Arctic Aurora" shows up 9 times since I have 9 Philips groups in the Philips Hue app that use "Arctic Aurora". I can't distinguish which scene applies to what group of lights. The Select Scene popup is also very long (95 scenes total). Any suggestions? I can sort of guess what scene applies to what lights by checking the order of the scenes in the
          Bridge maintenance->Scenes on Bridge page. Any suggestions?
          I see (from https://forums.homeseer.com/forum/li...56#post1275856) that one solution is to rename all the predefined scenes created by the Philips Hue app to change the name of each scene so that it includes the name of the group. For example, instead of "Tropical twilight", name the scene to "Dining Room - Tropical Twilight". Kind of painful to do with so many to rename (# of predefined scenes * number of Hue groups). It would be a nice enhancement to the JowiHue plugin if the "Set Scene" popup includes the name of the Philips Hue group that the scene is for. I named my Philips groups "<room name> Hue". For example, "Dining Room Hue". (Aside; My groups end with "Hue" to distinguish them from Alexa groups (whose names are just <room name>") so things don't get confusing between Philips group names and Alexa group names). So, in the JowieHue "Set Scene" popup, instead of displaying just "Tropical Twilight", display "Dining Room Hue - Tropical Twilight".

          Below is from the Alexa Smart Homes Scenes web page. Note that it shows what Philips group each scene is for (see attachment).


          Comment


          • #6
            Originally posted by randman View Post

            1. All my lights and Philips Hue groups were added with the default Floor (Location 1) and Room (Location 2) named "JowieHue". Is it okay to change the Floor and Room, or is the plug-in dependent on the Floor and Room being "JowieHue"? Will renaming Floor and/or Room cause any potential problems when JowieHue syncs with the Philips Hue Bridge in the future (for example, if I remove or rename devices in the Hue app but those devices' Floor and/or Room were renamed in HomeSeer)?
            As drparker151 already confirmed, the plugin is not depending on the location fields. So you can go ahead and change them. I noticed though that HS Mobile is not liking it when you change locationsfieldes in grouped devices. I have all the battery devices on a location2 field value of "Battery", so I could change the selection to all battery. HS Mobile will not show these if I try to select it. But in the device utility page is works fine...

            Originally posted by randman View Post
            2. My lights' naming convention is prefaced with room name. For example: "Dining Room Lamp", "Living Room Ceiling Lights". Including room name allows me to easily tell what a light is for when importing the Hue configuration into HomeKit, Alexa, and HomeSeer/JowieHue. I suppose changing the lights' names to remove the room prefix (since HomeSeer has a separate Room location field) would cause havoc since HomeSeer/JowieHue would sync the name back to the bridge, and then the bridge would want to sync to HomeKit and Alexa.... what naming convention do folks like to use?
            Yes, this could create confusion inside the other apps. I follow mosty the habit of naming the lights as I like to see them in HS3 as I am not using other apps a lot. But for the few I control with another app, I use a easy to find name, not including the room name.

            Originally posted by randman View Post
            2. When I added lights/rooms using the Philips Hue app, I selected all 11 predefined scenes (e.g. Savanna Sunset, Energize, Concentrate, etc.). This adds up to 95 scenes (since each predefined scene is repeated for each Philips Hue group). In HomeSeer, the JowieHue->Bridge Maintenance page says: "Scenes: 95(105)". What does this mean? Does it mean only a maximum of 105 scenes are supported? I can delete some predefined scenes that I don't need like "Spring Blossom" and "Tropical Twilight", but a number of them I'd like to keep.
            Yes, the scenes on the Hue bridge are limited to 105 scenes. This is not the limit for scenes created with JowiHue. You could consider copying the scenes from the bridge to the plugin (at least those that you want to use in events). You can do this easy: Go to the creativity page in the plugin and choose the scenes tab. Activate a scene with the app holding the scene you want to copy. Select the group where you want to add a new scene to and take an snapshot (the camera icon next to the group name). The plugin will then create a copy of all settings for the lights that are on. Next you can remove the lights from the scene that ore not needed.
            This way you have a (local) JowiHue scene you can use. Next you could remove the same scene from the bridge.

            You can do the same for presets, by copying the settings of one light. Scenes are a combiniation of assigned ights with the possiblitiy of different settings per light or group, preset is sending one setting for one or more lights (or a group of lights)


            Originally posted by randman View Post
            3. Minor issue I ran into: - In the JowiHue Light details page, I entered, for my lights, "Purchase date:" and "Hours of usage before using plugin", followed by "Done". The values that I enter are not saved. When I go back to the Light details page, the Purchase date reverts back to the day I installed the JowieHue plugin and the Light usage does not account for the hours that I entered. Then, I turned on and off the light from HomeSeer, and I reentered the Purchase date and Hours of usage, and the values were saved properly. Same behavior for all my other Hue lights. It seems that if a light has not yet been changed (via on/off) using the JowieHue plug-in, the Hours of usage and Purchase date are no saved. Once I turn on and off a light (using JowieHue plugin), then I can enter the values for those 2 fields and they are correlty saved. Maybe an initialization problem somewhere that is resolved once a light is controlled by the plugin?
            Will check on why this is happening.

            Wim

            Originally posted by randman View Post
            4. - All the predefined Hue scenes (Relax, Read, Concentrate, etc.) were imported into HomeSeer. When defining an event with "JowiHue: JowiHue Actions" and "Set Scene", the Select Scene popup list has all the predefined Hue scenes. Unfortunately, the Philips predefined scenes all have the same name, and each predefined name shows up multiple times (for example, "Arctic Aurora" shows up 9 times since I have 9 Philips groups in the Philips Hue app that use "Arctic Aurora". I can't distinguish which scene applies to what group of lights. The Select Scene popup is also very long (95 scenes total). Any suggestions? I can sort of guess what scene applies to what lights by checking the order of the scenes in the
            Bridge maintenance->Scenes on Bridge page. Any suggestions?
            Another reason why I copied these scenes in JowiHue. Philips is using an awfull naming scheme to be used outside the app. I think using JowiHue scenes will make that part easier.
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #7
              Thanks, Wim.

              Originally posted by w.vuyk View Post
              As drparker151 already confirmed, the plugin is not depending on the location fields. So you can go ahead and change them. I noticed though that HS Mobile is not liking it when you change locationsfieldes in grouped devices. I have all the battery devices on a location2 field value of "Battery", so I could change the selection to all battery. HS Mobile will not show these if I try to select it. But in the device utility page is works fine...
              Yes, I'm not a fan of this particular behavior of HomeSeer Mobile. I had posted about this issue here (item #2): https://forums.homeseer.com/forum/ho...ts#post1283516 . I think this is a problem only if a child device is in a different location than the root device.

              Fortunately, if all child devices have the same room as their parent/root, HomeSeer Mobile will show the whole group properly in the specified room. So, for example, I change the Room of a Hue light (as well as its Hue, CT, and Sat child devices) to "Office", the whole group will show up properly when I select "Office" in HomeSeer Mobile (as desired). I kept the Floor as "JowiHue" for all the devices created by the JowiHue plug-in so that I can easily see just the JowiHue devices if I need to. This works in HomeSeer Mobile too.


              One more thing. I noticed that my A19 bulbs have CT child devices but the Blooms (Model LLC011) have no CT child devices?

              Thanks.

              Comment


              • #8
                I'm having trouble with "Return to original settings after animation ends"...

                From the JowiHue Creativity page, I clicked on "Create demo set". I ran the "Demo Color Roll" animation. This animation has checked the option "Return to original settings after animation ends". However, after the animation ends, the light(s) don't return to the state that they were in prior to running the animation. Am I interpreting this option correctly?

                If the lights were off, then after the animation they should go back to off? And if the lights were on with a particular setting, the light(s) would go back to that setting?

                I tried "Create demo set followed by running "Demo Color Roll" with different number of lights. Once with 1 light (Hue Go), another time with 1 light (a Hue color A19), a second time with 2 lights (two Hue color A19s), and a 3rd time with 4 lights (Hue Go and 3 color A19s). Each time, the lights wouldn't go back to the original settings after the animation ends.

                I'm using version 2.0.3.1 of the plug-in.

                Comment


                • #9
                  Originally posted by randman View Post
                  I'm having trouble with "Return to original settings after animation ends"...

                  From the JowiHue Creativity page, I clicked on "Create demo set". I ran the "Demo Color Roll" animation. This animation has checked the option "Return to original settings after animation ends". However, after the animation ends, the light(s) don't return to the state that they were in prior to running the animation. Am I interpreting this option correctly?

                  If the lights were off, then after the animation they should go back to off? And if the lights were on with a particular setting, the light(s) would go back to that setting?

                  I tried "Create demo set followed by running "Demo Color Roll" with different number of lights. Once with 1 light (Hue Go), another time with 1 light (a Hue color A19), a second time with 2 lights (two Hue color A19s), and a 3rd time with 4 lights (Hue Go and 3 color A19s). Each time, the lights wouldn't go back to the original settings after the animation ends.

                  I'm using version 2.0.3.1 of the plug-in.
                  I tried this again. I clicked on "Create demo set" with 4 Hue lights selected. When I run the "Demo Alert" animation, all 4 lights return to their original settings after animation ends (as desired). But if I run the "Demo Color Roll" animation, the lights do NOT return to their original settings, even though "Return to original settings..." is checked. In fact any animation I create that includes one of the "Demo Roll Scene x" scenes results in the lights not returning to their original settings. I can't see any difference in the way the scenes that explains why animations that use the Demo Roll Scene scenes don't return lights to their original settings...

                  Comment


                  • #10
                    That is weird. Have just tested the same animation Demo Color Roll here (lights originaly off) and it ended with (Philips Hue) lights off again. Will try again later with lights on, to see is something is changing then. But so far cannot copy this issue.
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • #11
                      Originally posted by w.vuyk View Post
                      That is weird. Have just tested the same animation Demo Color Roll here (lights originaly off) and it ended with (Philips Hue) lights off again. Will try again later with lights on, to see is something is changing then. But so far cannot copy this issue.

                      I tried the demos again. I selected 4 lights and created the demo set. I turned off all the lights. Like before, after "Demo Alert" finishes, the lights go back to their original settings (off). I did this half a dozen times, and the light always turn off after "Demo Alert" finishes

                      I did similar test for the other animation. I turned off all the lights, and then ran "Demo Color Roll". The lights don't go back off after the animation finishes. It's pretty consistent too.

                      Below is screen shot of the animations just in case it's any different than what you expect.

                      Click image for larger version

Name:	Demo.png
Views:	29
Size:	123.3 KB
ID:	1294911

                      Regards.

                      Comment


                      • #12
                        I have been chacking this again yesterday evening, but I just cannot copy it here. Is it only the demo color roll, and not with other (newly created) animations? If it is, I suggest we leave it as it is for now? I think this is a local issue that is not common for others?
                        -- Wim

                        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                        650 devices ---- 336 events ----- 40 scripts

                        Comment


                        • #13
                          Originally posted by w.vuyk View Post
                          I have been chacking this again yesterday evening, but I just cannot copy it here. Is it only the demo color roll, and not with other (newly created) animations? If it is, I suggest we leave it as it is for now? I think this is a local issue that is not common for others?
                          Yes, it’s weird. Only the Demo Color Roll has this problem.
                          I’ve recreated it from1 to 4 lights. Same problem. But the other demo animation as well as all the animations I’ve created don’t have the problem. So, yeah, no problem, don’t worry about it. It’s just that it happened to be the very first animation that I ran that caused me to wonder if I was doing something wrong. Thanks.

                          Comment

                          Working...
                          X