Announcement

Collapse
No announcement yet.

Need Help Getting Started with ConBee

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need Help Getting Started with ConBee

    I'm trying to get Keen Vents integrated into HS using the JowiHue plugin. Win10. I purchased the ConBee and installed the USB drivers and deCONZ, I think successfully.

    When I start DeCONZ it finds the ConBee and I appear to be able to communicate with it as the several config dialogs have Read buttons that appear to work.

    So, I understand that the first step would be to create a ZigBee network with the ConBee as the coordinator, and then begin adding Zigbee devices to that network. Per my understanding of the documentation I've been able to find, I first need to click on the Join button to create the network, but after a few seconds, it comes back as Not In Network.

    Attached are screenshots of my network configuration panel and the ConBees config panel.

    Any help would be appreciated.Click image for larger version

Name:	ConBee.png
Views:	226
Size:	141.1 KB
ID:	1299744
    Attached Files
    tenholde

  • #2
    Devices are added via the Phoscon app (upper right hand corner of the deConz GUI). Once added via Phoscon, they are brought into HomeSeer via JowiHue.

    Comment


    • #3
      Normally after installation of the ConBee and the deCONZ software everything should be set. Did you change any settings on the deCONZ network settings? As I see you have multiple channels selected, which normally be only one. Never tested with mutiple channels here, do doubt if that can work?

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        Do not believe I changed anything. I tried eliminating all but one channels, and it does not stick, returns to four channels selected. I wonder if I am really communicating with the ConBee? Perhaps a WIN10 driver issue?
        tenholde

        Comment


        • #5
          Do you have a ConBee USB stick or a ConBee II stick? Check the post here for an image on the differences.
          Changing the channels is a bit off on normal behaviour. You have to change the channle settings, then press "Save" and then "Done". Normally (at least for me) you would expect pressing "Done" would do the trick.Here you have to first press "save"

          Wim
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • #6
            *ps* Win10 should have the drivers available, Win7 need drivers to function.
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #7
              I have the original ConBee. When I insert it, deCONZ cannot find it and Device Manager shows it has no driver. I found the driver following directions from ConBee site, and device looks good and now deCONZ finds it but does not appear to talk to it. So, I tried this all over again on my laptop, and again had to install driver (WIN10), but now things look better. I could join the network successfully, but have not been able to find any of my devices yet.
              tenholde

              Comment


              • #8
                Did you connect the gateway to the plugin already? You need to open phoscon (in the deconz interface, press the Phoscon button on the top right. Then go to the gateway (advanced) and choose to authenticate app.
                JowiHue should already be logging messages that it found a new bridge. Go to the configuration page of JowiHue and click on register bridge. Now plugin and bridge should connect.

                Then refresh the configuration page and choose to scan for devices and reset the device you want to add. If the device is found, you will see it appear in deConz. First it will have a hex name like 0xFFFF. Once it has been scanned and the REST API recognises the device, it will change to a more logical name. Once this is done, the devices should also appear in JowiHue.

                Wim
                Attached Files
                -- Wim

                Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                650 devices ---- 336 events ----- 40 scripts

                Comment


                • #9
                  I had successfully connected the ConBee, deCONZ, and the plugin on my HS computer, but could get nothing to work as ConBee did not appear to be communicating properly. It did not join the network when I plugged it in, although deCONZ could see it.

                  I reinstalled onto my laptop, and the ConBee immediately connected to the network, and after some experimenting, I was able to get both deCONZ and PhoScan to control one of my Keen Vents. I have not tried to connect the plugin to the laptop yet.

                  The next step is to figure out what is going on on my HS computer. I am wondering if it has to do with also having drivers installed for other USB to serial devices?

                  tenholde

                  Comment


                  • #10
                    I now have the ConBee joined to the network and communicating with the plugin. I added one Keen Vent, and it does appear in the plugin, however it only has devices for the sensors and I expected that it would create a Light device for vent control. When I stop and start the plugin, I do get some errors in the log:

                    Code:
                     
                    Apr-21 11:30:26 AM JowiHue socket opened for tenConBee on 192.168.1.170:443
                    Apr-21 11:30:23 AM JowiHue ==============================================================================================
                    Apr-21 11:30:23 AM JowiHue 0 Animations available for use in this plugin
                    Apr-21 11:30:23 AM JowiHue 0 Local scenes available for use in the JowiHue plugin
                    Apr-21 11:30:23 AM JowiHue 22 Presets available for use in the JowiHue plugin
                    Apr-21 11:30:23 AM JowiHue -------------------------------------Plugin info ---------------------------------------------
                    Apr-21 11:30:23 AM JowiHue 1 Pressure sensor(s) found on bridge 'tenConBee' with 1 supporting HS device(s)
                    Apr-21 11:30:23 AM JowiHue 1 Daylight sensor found on bridge 'tenConBee'
                    Apr-21 11:30:23 AM JowiHue 1 Temperature sensor(s) found on bridge 'tenConBee' with 1 supporting HS device(s)
                    Apr-21 11:30:23 AM JowiHue Bridge tenConBee is at version 2.5.63 of type deCONZ on a ConBee
                    Apr-21 11:30:23 AM JowiHue 1 Groups available on bridge 'tenConBee'
                    Apr-21 11:30:23 AM JowiHue 0 lights and/or plugs connected to bridge 'tenConBee'
                    Apr-21 11:30:23 AM JowiHue -------------------------------------Bridge info ---------------------------------------------
                    Apr-21 11:30:23 AM JowiHue ==============================================================================================
                    Apr-21 11:30:22 AM JowiHue Error: (AddOrUpdatebridgeuser)::SQL logic error or missing database no such column: False
                    Apr-21 11:30:22 AM JowiHue * Connected to bridge tenConBee at 192.168.1.170:8080
                    Apr-21 11:30:22 AM Plug-In Finished initializing plug-in JowiHue
                    Apr-21 11:30:22 AM Starting Plug-In JowiHue loaded in 418 milliseconds
                    Apr-21 11:30:21 AM Starting Plug-In Plugin JowiHue started successfully in 186 milliseconds
                    Apr-21 11:30:21 AM JowiHue InitIO:Plugin basic initialisation done
                    Apr-21 11:30:21 AM JowiHue Starting plugin JowiHue 2.0.3.2 on Windows
                    Apr-21 11:30:21 AM Starting Plug-In Initializing plugin JowiHue ...
                    Apr-21 11:30:21 AM Info Plugin JowiHue has connected. IP:127.0.0.1:51500
                    Apr-21 11:30:21 AM Plug-In Interface JowiHue is running as a trial, 28 days remaining.
                    Apr-21 11:29:38 AM Info Plugin JowiHue with instance: has disconnected
                    Apr-21 11:29:38 AM JowiHue JowiHue Plugin is stopped. Thanks for using it :-)
                    Apr-21 11:29:38 AM JowiHue disconnecting bridge tenConBee
                    Apr-21 11:29:38 AM Plug-In Shutting down Plug-In: JowiHue
                    Apr-21 11:27:55 AM JowiHue added new correction row for 00:22:a3:00:00:10:02:38-01-0402
                    Apr-21 11:27:18 AM Warning File does not exist: C:\Program Files (x86)\HomeSeer HS3\html\images\JowiHue\SV01-410-MP-1.0_large_small.png
                    Apr-21 11:25:02 AM Device Control Device: Office Desk to On (100)
                    tenholde

                    Comment


                    • #11
                      Also, I have several questions. It is hard to get this up and running because I don't have a very good understanding how the pieces fit together. I've read everything that I could find about ZigBee, the ConBee, deCONZ, the the JowiHue plugin.

                      There appears to be three ways to add devices to the network: (1) deCONZ has an Edit/Permit Join menu item (2) PhoScan has a device scan function, and (3) the plugin config screens has a button for searching for devices. What is the correct way to add new devices such as my Keen vents?

                      I have two keen hubs, that when not connected to the network, they work as repeaters. Any thoughts on how to add them to the network as repeaters?

                      I thank everyone that has responded for the assistance, I am making progress.
                      tenholde

                      Comment


                      • #12
                        Since the vent was added without a light device for control, I would like to delete it, reset the vent, and rescan. What is the best way to totally delete a connected device? (deCONZ?)
                        tenholde

                        Comment


                        • #13
                          Originally posted by tenholde View Post
                          There appears to be three ways to add devices to the network: (1) deCONZ has an Edit/Permit Join menu item (2) PhoScan has a device scan function, and (3) the plugin config screens has a button for searching for devices. What is the correct way to add new devices such as my Keen vents?
                          Adding a device through PhosCon and JowiHue do the same thing, they issue a request through the REST api for deCONZ to open the network. The deCONZ option is not recommended by the deCONZ developers, but I'm not clear on why.

                          Bill

                          Comment


                          • #14
                            If I check the github, the vent should just show up. Maybe it is a good idea to create a dump of the info sent by the Conbee.
                            To do this create a file called JowiHue.ini in the Config directory with this content:

                            Code:
                            [Setting]
                            DumpEnabled=True
                            Once you have placed this file the plugin will read it within 20 minutes. After this is read, it will enable the dump button in the configuration page, next to the bridge info/ Pressing the button will creat a dump file in the Logs directory called "JowiHueBridge-XXXXXXXXXX.log" it will contain all information the plugin receives from the bridge. Can you send me a copy of this file?

                            Send the file to w dot vuyk at upcmail dot nl?

                            Also, I have several questions. It is hard to get this up and running because I don't have a very good understanding how the pieces fit together. I've read everything that I could find about ZigBee, the ConBee, deCONZ, the the JowiHue plugin.

                            There appears to be three ways to add devices to the network: (1) deCONZ has an Edit/Permit Join menu item (2) PhoScan has a device scan function, and (3) the plugin config screens has a button for searching for devices. What is the correct way to add new devices such as my Keen vents?

                            I have two keen hubs, that when not connected to the network, they work as repeaters. Any thoughts on how to add them to the network as repeaters?

                            I thank everyone that has responded for the assistance, I am making progress.
                            You will not need the permit Join button normally from deCONZ, you might need that one only for allowing the other hubes to join as routers/repeaters. Normally adding devices can be done with the plugin, configuration page. You can also use the Phocon webapp for this, but it is not needed after joining the plugin to the gateway. But as Bill already said, both Phoscon and the plugin are doing the same here.

                            Since the vent was added without a light device for control, I would like to delete it, reset the vent, and rescan. What is the best way to totally delete a connected device? (deCONZ?)
                            it is possible that deCONZ did not finish scanning all of the Keen Vent so far. Easiest solution for that is to start a new scan for devices (configuration page of the plugin) and then reset the Keen Vent - no need to delete the device from deCONZ or HS3. This should normally make sure the discovery complets, especialy when snesors are involved.

                            Wim
                            -- Wim

                            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                            650 devices ---- 336 events ----- 40 scripts

                            Comment


                            • #15
                              I've emailed the dump and several deCONZ screen shots. Thanks for your assistance.
                              tenholde

                              Comment

                              Working...
                              X