Announcement

Collapse
No announcement yet.

New deconz firmware orphaned devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New deconz firmware orphaned devices

    One of the recent deconz updates seems to have left the devices in a weird state. The bridge lost all of devices, so I had to add them again to the bridge. However, where it gets strange is that the plugin seems to thing they were orphaned:
    Code:
     
    May-05 9:24:44 PM JowiHue ResetSuspectedLights:Column 'BridgeSerial, ID' is constrained to be unique. Value '00212EFFFF017201, 5' is already present.
    May-05 9:24:44 PM JowiHue Warning: ResetSuspectedLights: Suspected light found. Probably due to bridge reset? (Christmas Lights) Correcting connection info
    May-05 9:23:30 PM JowiHue Warning: Or remove the devices belonging to this sensor
    May-05 9:23:30 PM JowiHue Warning: Did you remove a sensor from the bridge but left the HomeSeer devices? Re-add the sensor to the bridge and your events are save
    May-05 9:23:30 PM JowiHue Warning: Orphaned Sensor Ant Cabinet Humidity (1681) found, not found on any connected bridge
    May-05 9:23:30 PM JowiHue Device Humidity 16 ref:1678 looks like a double device for Filament Box. Please check on the bridge maintenance page?
    May-05 9:23:30 PM JowiHue Device Temperature 15 ref:1676 looks like a double device for Filament Box. Please check on the bridge maintenance page?
    May-05 9:23:30 PM JowiHue Cannot find key for light Switch 02 (id=7) was it removed from the bridge?
    May-05 9:23:30 PM JowiHue Cannot find key for light Corner Fan (id=6) was it removed from the bridge?
    May-05 9:23:30 PM JowiHue Cannot find key for light Christmas Lights (id=5) was it removed from the bridge?
    I see this for a bunch of devices unfortunately. I removed one device from the plugin and readded it, and it fixed it. However was hoping not to do that for all the devices. Is that my only recourse at this point?

    Thanks!

  • #2
    The plugin should have recognised the uniqueid and used the old devices, but it seems in this case it created a new device. When you re-add the lost device to the bridge, it will assign a new id to the device. It appears the plugin is getting confused in this state:

    May-05 9:23:30 PM JowiHueDevice Humidity 16 ref:1678 looks like a double device for Filament Box. Please check on the bridge maintenance page?

    And indeed the old devices with old id's are left orphaned.
    May-05 9:23:30 PM JowiHue Cannot find key for light Switch 02 (id=7) was it removed from the bridge?
    I am afraid removing ad adding them might be the only solution for now. Will check here how this can be prevented for the future.

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      Thanks for the reply, guess here goes the pain

      Comment


      • #4
        I get the same thing with the newest version but on a Philips Hue Hub.....do i really have to readd hem?
        Thanks,
        Frank

        Comment


        • #5
          Originally posted by sirmeili View Post
          I get the same thing with the newest version but on a Philips Hue Hub.....do i really have to readd hem?
          a restart of the plugin fixed my issue with the phlips hue hub.
          Thanks,
          Frank

          Comment


          • #6
            What did you do that might have caused this for you?
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment

            Working...
            X