Announcement

Collapse
No announcement yet.

JowiHue keep crashing right after Bridge 'Phoscon-GW' is disconnected message

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JowiHue keep crashing right after Bridge 'Phoscon-GW' is disconnected message

    My plugin stops working while DeCONZ on the same machine is running. Last message in console reads: Warning: + Bridge 'Phoscon-GW' is disconnected ...
    Please let me know if i should post the logs. thanks

  • #2
    below red line, this is what shows up right after crash. any help here?

    Click image for larger version

Name:	jowihue crash debug after crash.jpg
Views:	67
Size:	350.1 KB
ID:	1310885

    Comment


    • #3
      Is it possible that deCONZ was restarted on the machine? As this message normally comes when deCONZ is stopped. And then with the restart, it seems the plugin did not recognise the deCONZ comming back, handling it as a new bridge. Did a port change maybe?
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        no, deCONZ was running all the time and the Phoscon App good too. i can control light in there with no issue.
        there might be an issue with ports, as there is IIS server running that could conflict with REST API... maybe port 443 is conflicting? is there a way to change Phoscon port on windows? i found this https://dresden-elektronik.github.io...doc/websocket/ but that doesn't explain how. If I could change that port, that would probably resolve the issue ...

        Comment


        • #5
          You can try to change the start of deconz, with adding a parameter -ws-port=8087 to the command (or any port you like, this changes the websocket port)
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • #6
            tried different ports ... it may show some improvements (did not crash) but still not getting any control over devices in deCONZ. please review log below


            Jun-17 23:02:57 JowiHue Dim command send to Vent 1 - BLUE
            Jun-17 23:02:57 JowiHue Error: (SetLights)::The given key was not present in the dictionary.
            Jun-17 23:02:43 JowiHue Error: (SetLights)::The given key was not present in the dictionary.
            Jun-17 23:02:43 JowiHue Dim command send to Vent 1 - BLUE
            Jun-17 23:02:17 JowiHue Error: (BuildBridgeTab)::web Maintenance:Object reference not set to an instance of an object.
            Jun-17 22:59:56 JowiHue Error: (BuildBridgeTab)::web Maintenance:Object reference not set to an instance of an object.
            Jun-17 22:58:23 JowiHue Error: (BridgeFound)::Object reference not set to an instance of an object.
            Jun-17 22:58:23 JowiHue Warning: Bridge Phoscon-GW changed IP from 192.168.168.252:8090 to 192.168.168.252:9042 - Restarting processes for this bridge
            Jun-17 22:58:23 JowiHue Correcting port for bridge Phoscon-GW from 8090 to 9042
            Jun-17 22:57:53 JowiHue Pressed button for immediate scan for bridges - scanning started
            Jun-17 22:56:17 JowiHue 1 Animations available for use in this plugin
            Jun-17 22:56:17 JowiHue ============================================================ ==================================
            Jun-17 22:56:17 JowiHue 22 Presets available for use in the JowiHue plugin
            Jun-17 22:56:17 JowiHue 3 Local scenes available for use in the JowiHue plugin
            Jun-17 22:56:17 JowiHue -------------------------------------Plugin info ---------------------------------------------
            Jun-17 22:56:17 JowiHue 1 Vibration sensor(s) found on bridge 'Phoscon-GW' with 1 supporting HS device(s)
            Jun-17 22:56:17 JowiHue 6 Pressure sensor(s) found on bridge 'Phoscon-GW' with 6 supporting HS device(s)
            Jun-17 22:56:17 JowiHue 6 Humidity sensor(s) found on bridge 'Phoscon-GW' with 6 supporting HS device(s)
            Jun-17 22:56:17 JowiHue 6 Temperature sensor(s) found on bridge 'Phoscon-GW' with 6 supporting HS device(s)
            Jun-17 22:56:17 JowiHue Bridge Phoscon-GW is at version of type on a
            Jun-17 22:56:17 JowiHue 4 lights and/or plugs connected to bridge 'Phoscon-GW'
            Jun-17 22:56:17 JowiHue 2 Groups available on bridge 'Phoscon-GW'

            Comment


            • #7
              This log is showing the change of ports. Did you try to restart without a new change of ports? After a change it might correct things if a restart of the plugin is done. It should work immediately after the change but sometimes misses out. What I am suprised about is that the plugin is reporting the change for the REST-API (http) port?

              Are you sure you changed the port for websocket (-ws-port)?


              here is a sample of the command parameters changing both ports:

              deCONZ --auto-connect=1 --dbg-error=1 --http-port=8090 --ws-port=8088
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #8
                UPDATE: i left it for the night and it corrected itself. now everything works great! not sure exactly what went wrong but i am happy. thanks for all your help!!

                last question: does the plugin read from vent temp, pressure or battery level?

                Comment


                • #9
                  krufka,

                  not sure it will find the devices, did you check if the plugin maybe made a ungrouped device for the temperature and pressure readings? As the vent is not yet added to the database of the plugin, it will not group all devices. The next version of th eplugi should group the devices, even when unknown yet to thte plugin.

                  Glad the plugin started working normally again, not sure what did it of course... one of those miracles....

                  Wim
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment

                  Working...
                  X