Announcement

Collapse
No announcement yet.

JowiHue Beta 2.0.4.8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • nunoary
    replied
    Originally posted by w.vuyk View Post
    Yeah, just learned the real update is not yet in 2.05.67 implemented. They are now rolling out the 2.05.69, which might hold the update.... if it does, you will see an attribute 'buttonevent' popup in the json of the remote (the missing device). If you see it, you will need to stop the plugin, delete devices of the remote and restart the plugin. It should then create the correct remote devices.
    Ok, thanks again for the attention Wim. I will wait for the update and then follow the steps indicated by you. Nuno

    Leave a comment:


  • w.vuyk
    replied
    I guess the plugin is routed to the 1st network and cannot reach the bridge through that path? I have no experience with a device on two networks?

    Leave a comment:


  • Smartdave
    replied
    I did some research on how to manually add a bridge to the INI file:
    Troubleshooting a bridge that cannot be found by the plugin


    When a bridge is not found by the plugin, you should check a few things first:
    • Can you ping the bridge from the HS3 machine?
    • Make sure the bridge is not on a different subnet or VLAN from the HS3 server.
    • Is the plugin allowed access through the windows firewall, if the plugin is installed on windows? Easiest way to check this is temporarily disabling the windows firewall and restarting the plugin. If the plugin starts working now, make sure to enable the HSPI_JowiHue.exe file for access through the firewall. Normally this is asked with a windows popup at the first start of the plugin.
    • Is UNPNP allowed in your router? Most modern routers allow UPNP by default, but it is alway good to check.
    • For deCONZ gateways it is known that performing a gateway reset can help out to make it visible to the plugin
    • If all of the above are good, but the bridge is still not visible for the plugin then follow the next steps:

    To do this you should let the plugin run and create an INI file in the <HS install directory>\config and name it JowiHue.ini. In this file add the following lines:
    [Bridge] Ipaddress=<ip of bridge>


    I even tried setting the INI file to 777 permissions


    ______________________________________



    I added a the INI file {JowiHue.ini} to my ..\Homeseer\Config directory then I restarted the plugin and get the following.

    Sep-06 8:09:29 PM JowiHue No bridges found
    Sep-06 8:09:29 PM JowiHue Initialisation bridgedevices completed correctly
    Sep-06 8:09:28 PM Plug-In Finished initializing plug-in JowiHue
    Sep-06 8:09:28 PM Starting Plug-In JowiHue loaded in 703 milliseconds
    Sep-06 8:09:28 PM Starting Plug-In Plugin JowiHue started successfully in 235 milliseconds
    Sep-06 8:09:28 PM JowiHue InitIO:Plugin basic initialisation done
    Sep-06 8:09:28 PM JowiHue Starting plugin JowiHue 2.1.0.0 on Linux
    Sep-06 8:09:28 PM Starting Plug-In Initializing plugin JowiHue ...
    Sep-06 8:09:28 PM Info Plugin JowiHue has connected. IP:127.0.0.1:44626
    It never finds the bridge.

    Thoughts?

    Leave a comment:


  • w.vuyk
    replied
    Yeah, just learned the real update is not yet in 2.05.67 implemented. They are now rolling out the 2.05.69, which might hold the update.... if it does, you will see an attribute 'buttonevent' popup in the json of the remote (the missing device). If you see it, you will need to stop the plugin, delete devices of the remote and restart the plugin. It should then create the correct remote devices.

    Leave a comment:


  • nunoary
    replied
    Originally posted by w.vuyk View Post

    nunoary What is your current version of deCONZ? As 2.05.67 is holding a few specific changes regarding the IKEA blinds and remotes....

    Wim

    My current version of deCONZ is 2.05.67

    Leave a comment:


  • w.vuyk
    replied
    Please check the documentation for that, it is in there. Sorry forgot to mention that. Search for jowihue.ini

    Leave a comment:


  • Smartdave
    replied
    Can you give me some details on how to build this file?


    Originally posted by w.vuyk View Post
    I am not at home right now, but you can specify an IP address for the bridge in the JowiHue.ini file (wich has to be created). the plugin will read this and try to access the bridge then to initialise it. But am unsure if it will find it if you are on two networks on the same machine. Never tested it so far - doubt if UPNP will work for that configuration.

    Wim

    Leave a comment:


  • w.vuyk
    replied
    Originally posted by nunoary View Post
    I don't understand the issue but surely you're right
    Just in case I paired the command with deCONZ using the phoscon app in "Switch" mode. Should use "light" or "sensor"?
    nunoary What is your current version of deCONZ? As 2.05.67 is holding a few specific changes regarding the IKEA blinds and remotes....

    Wim

    Leave a comment:


  • w.vuyk
    replied
    I am not at home right now, but you can specify an IP address for the bridge in the JowiHue.ini file (wich has to be created). the plugin will read this and try to access the bridge then to initialise it. But am unsure if it will find it if you are on two networks on the same machine. Never tested it so far - doubt if UPNP will work for that configuration.

    Wim

    Leave a comment:


  • Smartdave
    replied
    My HS3 Linux box has two network cards in it. With both networks active I can not scan for bridges, it never finds any of them. I need to disable to interface/network that does not have the bridges.

    Is it possible to specify which network should be scanned? Secondly when might it be possible to specify a static address instead of a scan?

    Thanks

    Dave

    Leave a comment:


  • w.vuyk
    replied
    It should not really matter. Also using the plugins configuration age, scan for devices does the same. Probably with the same result - the plugin does not exect a on/off sensor as switch, And I think it should be different, ut let the developers decide. Itmight take a while.

    Leave a comment:


  • nunoary
    replied
    I don't understand the issue but surely you're right
    Just in case I paired the command with deCONZ using the phoscon app in "Switch" mode. Should use "light" or "sensor"?

    Leave a comment:


  • w.vuyk
    replied
    Oh boy.... An open/Close remote, given a type of ZHASwitch.... that is not going to work.... I now realise it. Will take this to the github, seems a lot of confusion is going on here

    Leave a comment:


  • nunoary
    replied
    Originally posted by w.vuyk View Post
    For sure one device is missing for the remote.... Can you check on the properties of the root device of the remote, JowiHue tab if you see anything like a JSON info?

    The JSON info


    ZHASwitch

    **************************** Object info *****************************
    {
    "state": {
    "lastupdated": "none"
    },
    "config": {
    "on": true,
    "alert": "none",
    "battery": 74,
    "reachable": true
    },
    "name": "TRADFRI open/close remote ",
    "type": "ZHASwitch",
    "modelid": "TRADFRI open/close remote",
    "manufacturername": "IKEA of Sweden",
    "swversion": "2.2.008",
    "uniqueid": "00:0d:6f:ff:fe:d0:9b:30-01-1000",
    "ep": 1,
    "etag": "fcb71d42840a13abfba82f6836ca0b88",
    "mode": 1
    }
    ************************* End Object info ***************************


    thanks

    Leave a comment:


  • w.vuyk
    replied
    For sure one device is missing for the remote.... Can you check on the properties of the root device of the remote, JowiHue tab if you see anything like a JSON info?

    Leave a comment:

Working...
X