Announcement

Collapse
No announcement yet.

Double device and problem on maintenance page.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Double device and problem on maintenance page.

    Hi,

    Using version 2.0.3.3.

    I recently moved my server to a new physical location and have been strugling with a lot of lights loosing connection which I don't believe is this plugins fault at all, but in my investigations I found this in my log:
    jul-19 08:45:33 JowiHue Refresh bridge delight set to 30 seconds after establishing direct connection
    jul-19 08:45:32 JowiHue socket opened for delight on 192.168.1.136:8080
    jul-19 08:45:29 JowiHue Device Motion Sensor ref:191 looks like a double device for Dimmer Switch. Please check on the bridge maintenance page?
    jul-19 08:45:29 JowiHue ============================================================ ==================================
    jul-19 08:45:29 JowiHue 1 Animations available for use in this plugin
    jul-19 08:45:29 JowiHue 13 Local scenes available for use in the JowiHue plugin
    jul-19 08:45:29 JowiHue 18 Presets available for use in the JowiHue plugin
    jul-19 08:45:29 JowiHue -------------------------------------Plugin info ---------------------------------------------
    jul-19 08:45:29 JowiHue 1 Daylight sensor found on bridge 'Philips hue'
    jul-19 08:45:29 JowiHue Bridge Philips hue is at version 1932126170 of type BSB002
    jul-19 08:45:29 JowiHue 3 Groups available on bridge 'Philips hue'
    jul-19 08:45:29 JowiHue 2 lights and/or plugs connected to bridge 'Philips hue'
    jul-19 08:45:29 JowiHue -------------------------------------Bridge info ---------------------------------------------
    jul-19 08:45:29 JowiHue ============================================================ ==================================
    jul-19 08:45:29 JowiHue 1 Pressure sensor(s) found on bridge 'delight' with 1 supporting HS device(s)
    jul-19 08:45:29 JowiHue 2 Humidity sensor(s) found on bridge 'delight' with 2 supporting HS device(s)
    jul-19 08:45:29 JowiHue 1 Generic status sensor found on bridge 'delight'
    jul-19 08:45:29 JowiHue 1 Daylight sensor found on bridge 'delight'
    jul-19 08:45:29 JowiHue 1 Lightlevel sensor(s) found on bridge 'delight' with 1 supporting HS device(s)
    jul-19 08:45:29 JowiHue 2 Temperature sensor(s) found on bridge 'delight' with 2 supporting HS device(s)
    jul-19 08:45:29 JowiHue 1 Motion sensor(s) found on bridge 'delight' with 1 supporting HS device(s)
    jul-19 08:45:29 JowiHue 8 Remote switch(s) found on bridge 'delight' with 8 supporting HS device(s)
    jul-19 08:45:29 JowiHue Bridge delight is at version 2.5.65 of type deCONZ on a ConBee
    jul-19 08:45:29 JowiHue 12 Groups available on bridge 'delight'
    jul-19 08:45:29 JowiHue 31 lights and/or plugs connected to bridge 'delight'
    jul-19 08:45:29 JowiHue -------------------------------------Bridge info ---------------------------------------------
    jul-19 08:45:29 JowiHue ============================================================ ==================================
    jul-19 08:45:29 JowiHue renaming Dimmer Switch to Motion Sensor
    jul-19 08:45:28 JowiHue Check devices on refererence 313 and 191It looks like sensor device has doubled
    jul-19 08:45:28 JowiHue Check devices on refererence 313 and 191It looks like sensor device has doubled
    jul-19 08:45:27 JowiHue * Connected to bridge Philips hue at 192.168.1.199:80
    jul-19 08:45:27 JowiHue * Connected to bridge delight at 192.168.1.136:80
    jul-19 08:45:27 Plug-In Finished initializing plug-in JowiHue
    jul-19 08:45:27 Starting Plug-In JowiHue loaded in 706 milliseconds
    jul-19 08:45:27 Starting Plug-In Plugin JowiHue started successfully in 251 milliseconds
    jul-19 08:45:27 JowiHue InitIO:Plugin basic initialisation done
    jul-19 08:45:27 JowiHue Starting plugin JowiHue 2.0.3.3 on Windows
    jul-19 08:45:27 Starting Plug-In Initializing plugin JowiHue ...


    And when I try to open "Bridge maintenance"
    Click image for larger version

Name:	Capture.PNG
Views:	70
Size:	21.8 KB
ID:	1316520

    And this in the log:
    jul-19 08:50:47 JowiHue Error: (BuildSliderSensors)::web Maintenance:The given key was not present in the dictionary.

  • #2
    Did you check the reference id's for "Motion Sensor" on the device management page? You might have to enable showing the refernce id; in the setup of HomeSeer (Setup, tab Custom). I think this device has doubled, where one is "active" and the other one orphaned... try to remove the orphaned one (which should be the one with the oldest change time on the manage devices page.
    The orphaned one is causing the issue on the bridge management page. I will try and check if I can catch this error in the future...

    Thanks,

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      Thanks there was indeed an orphaned device on of them, I deleted it and restarted the plugin and now no errors.

      I do still get this error when opening --> Bridge maintenance and trying to list "Sensors on bridge"
      jul-19 14:05:37 JowiHue Error: (BuildSliderSensors)::web Maintenance:The given key was not present in the dictionary.
      But everything seems to work, so might not be so important :-)

      Comment


      • #4
        It is not importand inthow the plugin functions controlling the devices and receiving sensor updates, but will get important once you want to be able to remove sensors through the bridge maintenance page...
        If you have time, it could help me if you could do a detailed trace. Probably best to do once the beta comes into production, which could still take some weeks though....

        Once it is out, do the following steps with the new plugin:

        1. Enable detailed trace and log to file in the configuration page of the plugin
        2. restart the plugin
        3. Once started, go to the bridge maintenance page and try to open the senors part
        4. also open the lights part.
        5. Disable the detailed logging and trace to file options
        6. send me the JowiHue.log file that is located in the logs subdirectory of the Homesser installation directory?

        Send the file to JowiHue at ziggo dot nl

        Thanks,

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment

        Working...
        X