Announcement

Collapse
No announcement yet.

Beta major Keen Vent problems: 342 Duplicate root devices created for Keen Vents!?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Beta major Keen Vent problems: 342 Duplicate root devices created for Keen Vents!?

    w.vuyk

    Using the released version, 5 days ago, I added 6 Keen Vents. All fine; added proper and worked great.

    Then about 2 days ago I installed the .3 beta and it looked fine at first glance. Today I see major issues...

    A. Vent 3 (only 1 of the 6) shows over 340 duplicate root devices: device #s 1242 to 1583 (see screen shot)

    Click image for larger version

Name:	Capture.JPG
Views:	124
Size:	256.3 KB
ID:	1318176

    B. Some Vents show proper with Child Devices, others the child devices show separate, not 'under' the root in the UI. Some looks like they have both (see screenshot with Vent 2 having both)

    C. The child devices (sensors) numbers are not consistent... note that Vent 2 has child devices with different Labels, not using 2 but using 5 or 6, etc. This makes it difficult to track/use

    Click image for larger version

Name:	Capture2.JPG
Views:	90
Size:	224.6 KB
ID:	1318177

  • #2
    Yuch, this does not look good at all here! As far I can see also Vent 5 is also having more then one root device? And there is no battery device still (was hoping for this with the beta).
    Could you post the images of the Jowihue tabs for the (not single) root device and the vent devices itself? Please make sure the Json is included? Also the advanced tab on both devices (holding the device type information) so I can check the flow in the plugin for this?

    Do you have any floating battery devices pointing to the vents in the device list?

    Thanks,

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      I just got hit with this last night (and today) after creating a new light group. It might not be the same thing but I now have 79 root devices for the sample group with no child devices. It looks like I got the following errors when I first created the group:
      Jul-29 7:38:54 PM JowiHue Error: (CreateNewDevice)::Column 'uniqueid' is constrained to be unique. Value '001788FFFE2549B6_new-G' is already present.
      Jul-29 7:33:40 PM JowiHue Group 4 renamed to Downstairs Floor Lamp
      Jul-29 7:28:54 PM JowiHue Error: (CreateNewDevice)::Column 'uniqueid' is constrained to be unique. Value '001788FFFE2549B6_new-G' is already present.
      Jul-29 7:26:24 PM JowiHue Error: (SetLights)::The given key was not present in the dictionary.
      Jul-29 7:25:58 PM JowiHue Error: (SetLights)::The given key was not present in the dictionary.
      Jul-29 7:21:57 PM JowiHue Group 4 renamed to Downstairs Floor Lamp
      Jul-29 7:21:30 PM JowiHue Error: (CreateNewDevice)::Column 'uniqueid' is constrained to be unique. Value '001788FFFE2549B6_new-G' is already present.
      Jul-29 7:21:29 PM JowiHue New group Floor Lamp successfully created on the bridge


      The "CreateNewDevice" Error has occurred in the log every 10 minutes after that and each time it occurred a new HS root device was created. I can correlate the "last changed" for each new device with the HS log timestamp. This morning I tried disabling and re-enabling the plugin but that only caused a huge stream of errors to be logged as the plugin tried to status each of the root devices it had been creating. I found a group on the bridge (using iconnecthue) called "Floor Lamp" which was the original name before I renamed it. I manually deleted that group from the bridge using the iconnecthue app and the plugin has since stopped creating new root devices.

      I've been running with detailed tracing enabled so I'll email you the log file.

      Ken

      Comment


      • #4
        Ken,

        Where did you create the new group? thought the Philips Hue app, or with the Brige Maintenance page?

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • #5
          The Bridge Maintenance page. I'm not using the Philips Hue app at all since it doesn't seem to see groups other than of type "room" so I started using the iconnecthue app.

          Edit: logs emailed to you.

          Comment


          • #6
            Originally posted by w.vuyk View Post
            Yuch, this does not look good at all here! As far I can see also Vent 5 is also having more then one root device? And there is no battery device still (was hoping for this with the beta).
            Could you post the images of the Jowihue tabs for the (not single) root device and the vent devices itself? Please make sure the Json is included? Also the advanced tab on both devices (holding the device type information) so I can check the flow in the plugin for this?

            Do you have any floating battery devices pointing to the vents in the device list?

            Thanks,

            Wim
            here's how all the vents show after I deleted the large # of duplicates
            Attached Files

            Comment


            • #7
              I was asking for the properties of the vent devices, at least the light devices and appeearantly the vent device is holding more information, like temperature and pressure? Could you please post the properties (advanced tab as well as JowiHue tab for at least the JSON part) on one of each of those devices? I really need this info to try catch this?

              Could you post the images of the Jowihue tabs for the (not single) root device and the vent devices itself? Please make sure the Json is included? Also the advanced tab on both devices (holding the device type information) so I can check the flow in the plugin for this?

              Do you have any floating battery devices pointing to the vents in the device list?
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #8
                I do not think my issue is the same as this issue so I'm going to create a new post for it.

                Ken

                Comment


                • #9
                  w.vuyk it happened again and I have not added any vents to HS3. For 'Vent 3' your plugin created 1709 root devices. Yes, 1709. Screen shot of the 1st dupe and the last dupe. and the tabs you asked for. It seems to have abandoned the first root device it created on 7/27

                  NONE of the roots have anything in the JowiHue tab... dupes & non-dupes, etc. Not one. All vents have dupes but the others are not replicating like Vent 3.

                  Looks like every day its creating new root devices, several... they all have dates from 7/28, 7/30, 7/31, 8/1, 8/2, 8/3 ... many within the same date have the same one or two last modified times. for instance, on 8/1 there were two times, ten minutes apart where all of the dups were created. Your plugin literally created 2 Vent 3 dups as I was watching it writing this post.


                  Attached Files

                  Comment


                  • #10
                    Ltek I am still missing the advanced and JowiHue tabs on the temperature, light and pressure devices? I really need this information, especially the JSON parts so it will help me to correct the issue? Your images of the parent devices do show a possible issue, the plugin seems to think it is a plug device, but I need to have the JSON to make sure I am correct here.

                    Also, it would helpfull if you can start a detailed trace, so I can try to see where the plugin devices to create a new parent? Follow these steps for the detailed trace:
                    • Set the detailed trace and log to file options to on in the Configuration page of the plugin.
                    • Restart the plugin and let it run untill at least one extra device has been created
                    • Disable the detailed trace and the log to file options in the configuration page of the plugin
                    • You will find the log file in the Logs subdirectory of the HomeSeer installation directory - JowiHue.log
                    Please send this log to jowihue at ziggo dot nl?

                    Thanks,

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • #11
                      w.vuyk I've been out of town. I attached the screenshots. Sending you the trace - its big, been on for the whole time and didnt know it.
                      Attached Files

                      Comment

                      Working...
                      X