Announcement

Collapse
No announcement yet.

20/8 Philips update broke the plugin?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 20/8 Philips update broke the plugin?

    Wim

    My Philips hub auto updated today, and now the bridge is unreachable.

    i have tried disabling the plugin, deleting the hub device and rescanning but the same problem arises.

    The log log is awash with errors from the plugin but of course the hue app works just fine....!

    Jon

  • #2
    Same here - plug in not working and I am getting these errors

    Error: (BuildBridgeTab)::web Maintenance:Object reference not set to an instance of an object.

    I removed the hub on the bridge and lights page of the plug in and tried re=adding but same error

    Alan

    Comment


    • #3
      Originally posted by B50int View Post
      Wim

      My Philips hub auto updated today, and now the bridge is unreachable.

      i have tried disabling the plugin, deleting the hub device and rescanning but the same problem arises.

      The log log is awash with errors from the plugin but of course the hue app works just fine....!

      Jon
      Yuch, they did this bridge update sooner then I expected. Was hoping they would do the production update a few weeks later - or are you in the beta program of Philips Hue too?

      You are a victim of the Philips name change to Signify. This is already solved in the latest beta. But be aware, make a backup before you install the beta. I think most issues are solved in the beta, but just be sure, have that backup in place. Be sure to read the notes here as it is a one way update, going back is including a HS database restore.

      Let me know if this works out?

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        Originally posted by shadowshaker View Post
        Same here - plug in not working and I am getting these errors

        Error: (BuildBridgeTab)::web Maintenance:Object reference not set to an instance of an object.

        I removed the hub on the bridge and lights page of the plug in and tried re=adding but same error

        Alan
        shadowshaker

        I do not think you have the same issue. The error you show is only shown when one opens the bridge maintenance page. The plugin probably functions fine besides that error. It is also not a reason to start removing devices for it. It is probably best to start a new thread for this. In this new thread, let me know which bridge you are using and wich slider you try to open that causes this error to be logged? We will then take it from there.

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • #5
          Originally posted by w.vuyk View Post

          Yuch, they did this bridge update sooner then I expected. Was hoping they would do the production update a few weeks later - or are you in the beta program of Philips Hue too?

          You are a victim of the Philips name change to Signify. This is already solved in the latest beta. But be aware, make a backup before you install the beta. I think most issues are solved in the beta, but just be sure, have that backup in place. Be sure to read the notes here as it is a one way update, going back is including a HS database restore.

          Let me know if this works out?

          Wim
          Wim

          I am not currently using any betas. Happy to try it but as so often happens with home automation, it fails just before you go away for a few days! I will get a chance on Friday hopefully.

          Thanks for the pointer. Will report back...

          Jon

          Comment


          • #6
            The plugin will still be able to put lights on and off, so events should work. A work around for the number of errorlines is changing the polling frequency in the configuration page to a high value. Each refresh causes the errorline. As you are way it is less important maybe for devices to update to new status (they probably even wont change...) Set the polling frequency rate to say 120 to update only once per 2 minutes?

            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #7
              Originally posted by w.vuyk View Post

              You are a victim of the Philips name change to Lightify.

              Wait, don't you mean Signify? I noticed you used Lightify in the release notes for 2.0.4.5 too, but the Lightify name belongs to OSRAM. Philips Lighting (the parent company of Philips Hue) is changing to Signify.

              Hopefully you used the right name in the code rewrite, but just wanted to make sure..

              --Barry

              Comment


              • #8
                OK will open a new thread thanks

                Comment


                • #9
                  Originally posted by logman View Post

                  Wait, don't you mean Signify? I noticed you used Lightify in the release notes for 2.0.4.5 too, but the Lightify name belongs to OSRAM. Philips Lighting (the parent company of Philips Hue) is changing to Signify.

                  Hopefully you used the right name in the code rewrite, but just wanted to make sure..

                  --Barry
                  Barry,

                  You are right.. I am getting old, starting to confuse things LOL. I do mean Signify. And if I confused also it in my plugin... it is working here, received the update last week already as part of beta testing things, so I had to solve it for myself the hard way already
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment


                  • #10
                    Originally posted by w.vuyk View Post
                    The plugin will still be able to put lights on and off, so events should work.
                    Sadly not - all my bulbs are marked 'unreachable' in HS3 and nothing turns on or off.

                    Comment


                    • #11
                      Originally posted by NAB View Post
                      Sadly not - all my bulbs are marked 'unreachable' in HS3 and nothing turns on or off.
                      Is this after updatng to the beta?
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                      • #12
                        Originally posted by B50int View Post

                        Wim

                        I am not currently using any betas. Happy to try it but as so often happens with home automation, it fails just before you go away for a few days! I will get a chance on Friday hopefully.

                        Thanks for the pointer. Will report back...

                        Jon

                        Wim,

                        Just installed your Beta and its all come back alive with no more issues that i can detect.

                        Thanks for your great response, support and of course- the plugin! It's become an important integral part of my setup.

                        Jon

                        Comment

                        Working...
                        X