Announcement

Collapse
No announcement yet.

Problem with Multi Sensors Devices since last updates

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Multi Sensors Devices since last updates

    Hi Wim,

    With the last two plugin updates I noticed that the multi sensor devices is not working properly.

    First I noticed that they were not updating some devices, some did not update the humidity sensor, others the "lightlevel" sensor and others the pressure sensor. So I ran the plugin's built-in tool to redo the values ​​of these "Rebuild light values" and "Rebuild sensor values".

    Doing this made it worse, in addition to keeping the initial error, not updating some sensors, now the battery devices are reading the values ​​that should be of these sensors. See attached image to better understand the problem I am having.


    Click image for larger version

Name:	Battery.png
Views:	84
Size:	199.4 KB
ID:	1331504

  • #2
    Wow.... something is defiinitilly wrong there. Will check on this!
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      Nuno,

      I cannot find anything wrong here. With the version 2.0.0.0 and higher a conversion was done to get the devices in a parent/child situation that HST wants/needs for HS4. Did this conversion throw errors for you? Here I do not see these issue you are having.

      I think you still have my email address right? Could you send me a detailed log, where the start of the plugin is included? Let it run for at least 30 minutes?

      Thanks,

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        Done. I send you the file.

        I forget to say that when i press the button on the sensors they don't update in HS3. Don't no if it matters for the issue.

        In the very final of the test i run the "Rebuild light value" and "Rebuild Sensor value" just to help you see what is going on.

        Thanks for your help.

        Comment


        • #5
          I am seeing the same issue with multi sensor devices not working.

          Comment


          • #6
            Seeing the similar thing. Jowihue version 2.1.0.4. Attached image as an example device getting garbled with no temperature update for number of days and pressure value duplicated in battery state field.

            Click image for larger version

Name:	Annotation 2019-10-10 172244.jpg
Views:	50
Size:	27.9 KB
ID:	1331940

            Comment


            • #7
              I am only seeing the issue with the outdoor sensor. This shows up in the log every 5 minutes:


              Oct-10 7:09:28 AM JowiHue Device Hue Outdoor Sensor Light Level renamed to Hue Outdoor Sensor Light Level
              Oct-10 7:09:28 AM JowiHue Device Hue Outdoor Sensor Temp renamed to Hue Outdoor Sensor Temp
              Oct-10 7:09:28 AM JowiHue Device Hue ambient light sensor 1 renamed to Hue ambient light sensor 1
              Oct-10 7:09:28 AM JowiHue Device Hue temperature sensor 1 renamed to Hue temperature sensor 1


              Click image for larger version  Name:	Annotation 2019-10-10 070501.png Views:	0 Size:	62.3 KB ID:	1331972

              Comment


              • #8
                I hate to pile on... But I have around 25 devices that are being renamed. Except for me it is happening about every 14 minutes. Started after the most recent update (2.1.0.4).

                --Barry

                Comment


                • #9
                  Wim is working hard on fixing these bugs, I think it is coming soon the release of the new version that will fix this and other bugs. In addition he is also preparing to convert to HS4. I have to thank him here for his excellent work and his willingness to solve.

                  Comment


                  • #10
                    I have submitted the new version 2.1.0.5 that should stop a few issues I introduced whit the 2.1.0.4 release. One issue started confusing the battery device with the main devices, making you see the value of the battery device replaced. The new release should repair the battery device and work normal again.
                    Also the plugin would start renaming devices for no reason (name was already correct). this should now also stop....

                    Sorry for the mess up here

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • #11
                      Thanks Wim for the quick response and fix. 2.1.0.5 fixed the issues I was seeing

                      Comment


                      • #12
                        2.1.0.5 fixed the issues I was seeing with data garbling and renaming of devices to same name on regular basis. Thanks for sorting it out Wim.

                        Comment

                        Working...
                        X