Announcement

Collapse
No announcement yet.

JowiHue will not start!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JowiHue will not start!

    This morning JowiHue stopped working. I can control everything Z-Wave. And I can control a Zigbee lamp if I do it in deCONZ.
    I thought of starting debug logging, but it seems not to be available. In "Configuration" there is nothing but a message "Plugin is not in ready state yet, bridge unreachable?"
    There is connection between them. I started a browser on the Raspberry that runs deCONZ and it would show the Homeseer page.
    The log spits out messages: "Warning: JowiHue Plugin is not yet in ready state. Command not executed, please resend after initialisation finished". The last messages from JowiHue before this are these:
    okt-11 10.05.23 JowiHue Refresh bridge DeConz set to 45 seconds after establishing direct connection
    okt-11 10.05.22 JowiHue socket opened for DeConz on 192.168.1.32:443
    okt-11 10.05.15 JowiHue Error: (InitPlugin):Start:Collection was modified; enumeration operation might not execute.
    okt-11 10.04.53 Z-Wave Starting Z-Wave Polling for Network D10214E0...
    okt-11 10.04.45 JowiHue * Connected to bridge DeConz at 192.168.1.32:80
    okt-11 10.04.31 Z-Wave ************************************************************ *******************
    okt-11 10.04.31 Z-Wave STARTUP COMPLETE: All configured interfaces were successfully initialized.
    okt-11 10.04.31 Z-Wave ************************************************************ *******************
    I use 2 Raspbery PI. One for deCONZ and the other for Homeseer.
    Both were just rebooted (nicely telling them to do it) to see if that would help. It did not.

    Here is what it says about itself just now:

    Current Date/Time: 11.10.2019 11.25.38
    HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.435
    Linux version: Linux HomeTrollerZeeS2V2 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux System Uptime: 0 Days 1 Hour 21 Minutes 38 Seconds
    IP Address: 192.168.1.31
    Number of Devices: 307
    Number of Events: 85
    Available Threads: 394
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed:

    Enabled Plug-Ins
    2.1.0.5: JowiHue
    3.0.1.252: Z-Wave

    Regards
    Einar Sjaavik

  • #2
    Einar,

    I have send you a pm on this.
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      Hi Wim,

      I have also had this problem. Sometimes after a system reboot the plugin does not start, I have to disable the plugin on the Manegement tab and restart it to return to normal.

      Comment


      • #4
        Nuno,

        Check the 2.1.0.6 version, this should resolve this issue
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • #5
          So far so good After a few restarts and some tests, everything seems ok.

          Thanks Wim

          Comment


          • #6
            i still encounter this issue also, but not always. Even with the latest release (since i also using deconz en huebridge)
            Regards Bart
            ------------------------------------------
            Win7 64Bit on Intel NUCI7 with SSD
            HSPRO 3.
            Devices; 1370 Events; 691

            Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

            Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

            Comment


            • #7
              Bart,

              If it still happens to you now and then, it would help if I can see the logging. Are there errors logged in the HS3 log? If not, try to enable the tracing just before a restart, so I could check if it happens?
              I am guessing here it might be a different issue you are seeing here?

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #8
                hi wim,

                i send you the tracelog and db in a private message. Next to that i have one device who will create duplicate childevices upon plugin restart. its the xiaomi aqara double wall switch with Neutral ();

                Click image for larger version  Name:	jw.png Views:	0 Size:	99.5 KB ID:	1336886

                What i also see is that my HUE hub disconnects sometime, while its just accessible with the app (non cloud connection), and pings.

                on statup i sometimes (not always) get this these messages;


                nov-01 08:44:32 JowiHue Warning: Bridge HueBridgeBee is slow in responding. JowiHue temporary changed Refreshrate to 15 seconds for this bridge
                nov-01 08:44:32 JowiHue Warning: Bridge ZigbeeGW is slow in responding. JowiHue temporary changed Refreshrate to 15 seconds for this bridge
                nov-01 08:41:23 JowiHue Error: (InitPlugin)::Collection was modified; enumeration operation might not execute.
                nov-01 08:41:10 JowiHue Error:Object reference not set to an instance of an object.
                nov-01 08:41:10 JowiHue Addlight called, but bridgeserial is unknown....
                nov-01 08:41:10 JowiHue Warning: Or remove the devices belonging to this light
                nov-01 08:41:10 JowiHue Warning: Did you remove a light from the bridge but left the device? Re-add the light to the bridge and your events are save
                nov-01 08:41:10 JowiHue Warning: Orphaned Light found, not found on any connected bridge
                nov-01 08:41:10 JowiHue Warning: Named key:version - 13
                nov-01 08:41:10 JowiHue Warning: Named key:uniqueid - 00:15:8d:00:03:21:29:a9
                nov-01 08:41:10 JowiHue Warning: Named key:smart plug - True
                nov-01 08:41:10 JowiHue Warning: Named key:bridgeserial - 00212EFFFF04E932
                nov-01 08:41:10 JowiHue Warning: no serial number found for


                and the plugin wont start and states; Plugin is not in ready state yet, bridge unreachable?

                thanks in advance

                bart
                Regards Bart
                ------------------------------------------
                Win7 64Bit on Intel NUCI7 with SSD
                HSPRO 3.
                Devices; 1370 Events; 691

                Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                Comment


                • #9
                  Bart,

                  Send you a PM on the trace. I think it matches your last post with details. The plugin does not finish the initialisation due to an error. In detail you see this for the conbee... its refresh rate should be a lot higher then 30 seconds not 15 seconds only. I think I have solved it, but need you to test it?

                  Thanks

                  Wim
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment


                  • #10
                    wim,

                    the plugin no starts no mather what, But still have an issue with the 'kantoor' device. Which is online/active and on the drigde, and generates these errors upon startup;
                    nov-02 20:36:14 JowiHue Error:Object reference not set to an instance of an object.
                    nov-02 20:36:14 JowiHue Addlight called, but bridgeserial is unknown....
                    nov-02 20:36:14 JowiHue Warning: Or remove the devices belonging to this light
                    nov-02 20:36:14 JowiHue Warning: Did you remove a light from the bridge but left the device? Re-add the light to the bridge and your events are save
                    nov-02 20:36:14 JowiHue Warning: Orphaned Light found, not found on any connected bridge
                    nov-02 20:36:14 JowiHue Warning: Named key:version - 13
                    nov-02 20:36:14 JowiHue Warning: Named key:uniqueid - 00:15:8d:00:03:21:29:a9
                    nov-02 20:36:14 JowiHue Warning: Named key:smart plug - True
                    nov-02 20:36:14 JowiHue Warning: Named key:bridgeserial - 00212EFFFF04E932
                    nov-02 20:36:14 JowiHue Warning: no serial number found for
                    nov-02 20:36:00 JowiHue * Connected to bridge ZigbeeGW at 192.168.1.180:9095
                    nov-02 20:36:00 JowiHue * Connected to bridge HueBridgeBee at 192.168.1.120:80

                    and created devices which are already present, as posted above.
                    Regards Bart
                    ------------------------------------------
                    Win7 64Bit on Intel NUCI7 with SSD
                    HSPRO 3.
                    Devices; 1370 Events; 691

                    Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                    Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                    Comment


                    • #11
                      Bart,

                      Relooking the image you posted, this is not a switch, but it is a plug right? With a Aqara switch I am thinking a battery driven switch, but it seems this plugged in the wall?
                      Be sure to send me the Json of the JowiHue tab in the properties of the device as well?
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                      • #12
                        wim,

                        Its an inwall switch connected to mains info here: https://nl.aliexpress.com/item/32950...E&gclsrc=aw.ds

                        in requires a N and a L


                        It consists of 2 devices and a power device. The plugin duplicate the main switch devices.

                        all configs are empty and state; start light config -- Object reference not set to an instance of an object.


                        sw1

                        Smart plug

                        **************************** Object info *****************************
                        {
                        "type": "Smart plug",
                        "name": "Kantoor",
                        "modelid": "lumi.ctrl_ln2.aq1",
                        "swversion": "06-25-2018",
                        "uniqueid": "00:15:8d:00:03:21:29:a9-01",
                        "manufacturername": "LUMI",
                        "state": {
                        "on": false,
                        "alert": "none",
                        "reachable": true
                        },
                        "etag": "0950e86aeacea095e784f9012f6e81e8",
                        "hascolor": false
                        }
                        ************************* End Object info ***************************

                        and sw2

                        **************************** Object info *****************************
                        {
                        "type": "Smart plug",
                        "name": "Kantoor SW2",
                        "modelid": "lumi.ctrl_ln2.aq1",
                        "swversion": "06-25-2018",
                        "uniqueid": "00:15:8d:00:03:21:29:a9-02",
                        "manufacturername": "LUMI",
                        "state": {
                        "on": false,
                        "alert": "none",
                        "reachable": true
                        },
                        "etag": "0950e86aeacea095e784f9012f6e81e8",
                        "hascolor": false
                        }
                        ************************* End Object info ***************************

                        and the power device;

                        ZHAPower

                        **************************** Object info *****************************
                        {
                        "state": {
                        "lastupdated": "2019-11-01T22:22:53",
                        "power": 0
                        },
                        "config": {
                        "on": true,
                        "reachable": true
                        },
                        "name": "Verbruik Lampen Kantoor",
                        "type": "ZHAPower",
                        "modelid": "lumi.ctrl_ln2.aq1",
                        "manufacturername": "LUMI",
                        "swversion": "06-25-2018",
                        "uniqueid": "00:15:8d:00:03:21:29:a9-03-000c",
                        "ep": 3,
                        "etag": "d1a83183900d898d43be3bc7b575f61b"
                        }
                        ************************* End Object info ***************************


                        but the duplicate switches created contain no info; start light config -- Object reference not set to an instance of an object.


                        I will send the trace after reboot of the plugin when the devices are all removed.


                        Bart
                        Regards Bart
                        ------------------------------------------
                        Win7 64Bit on Intel NUCI7 with SSD
                        HSPRO 3.
                        Devices; 1370 Events; 691

                        Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                        Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                        Comment


                        • #13
                          I hijack back this thread. ;-)

                          Now the problem (from first post in this thread) is back again. Or a problem very much like it:
                          ov-14 19.26.07 JowiHue Warning: Bridge DeConz is slow in responding. JowiHue temporary changed Refreshrate to 27 seconds for this bridge
                          nov-14 19.19.27 JowiHue Warning: Bridge DeConz is slow in responding. JowiHue temporary changed Refreshrate to 18 seconds for this bridge
                          nov-14 19.16.30 JowiHue Warning: JowiHue Plugin is not yet in ready state. Command not executed, please resend after initialisation finished
                          nov-14 19.16.30 JowiHue Warning: JowiHue Plugin is not yet in ready state. Command not executed, please resend after initialisation finished
                          nov-14 19.16.30 JowiHue Warning: JowiHue Plugin is not yet in ready state. Command not executed, please resend after initialisation finished
                          nov-14 19.16.30 JowiHue Warning: JowiHue Plugin is not yet in ready state. Command not executed, please resend after initialisation finished
                          I have now the 2.1.0.6 version. And again deCONZ Phoscon will turn lights on/off. Running top on the raspberry that runs deCONZ shows around 95% CPU in idle.

                          Comment


                          • #14
                            Update: It works again after several reboots. A bit of a lottery it seems.

                            Comment


                            • #15
                              Einar,

                              Partly good news. I did find the issue on the slow response. It should be solved in the next version, but need few more tests before I can release it... Hoping to release it next week here.
                              -- Wim

                              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                              650 devices ---- 336 events ----- 40 scripts

                              Comment

                              Working...
                              X