Announcement

Collapse
No announcement yet.

Unable to get Zigbee thermostat recognized

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    That is good news. I will try to check in the plugin why it could not see the IP change. Did you deliberately change the IP, or is this a DHCP lease change?
    If it happens again, it should be good to stop the plugin, delete the bridge device only in the HS device list and restart the plugin.

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


      #17
      @w.vuyk, here is what I have in HS

      Click image for larger version

Name:	Capture.JPG
Views:	129
Size:	35.3 KB
ID:	1445974

      2 devices, the second one showing 2 features statuses. That thermostat can accept a remote external temperature and also report on power consumption.

      I'm guessing the one labeled "Status External Temperature?" is just that. However, I do not have a remote sensor connected so not much we can do to test this.

      The one labeled "Status Watts" should be the power consumption. That worked with the Sinope gateway but apparently not yet with the deCONZ. At least the plugin recognize and talks to it, judging by the timestamp beside it.

      On the 1st device, setpoint, mode and temperature work. I'm not certain exactly what the full heat does on the mode one though.

      The heating setpoint doesn't work. It's stuck on "Resting" while it should show "Heating" when the thermostat powers the floor heating element.

      As for the battery, I'm not aware the thermostat has one. It's a line powered device so... Unless there is a battery to maintain some stuff during a power failure, may be.

      Events are also able to update the mode and setpoint.

      SwoopX at Dresden has requested much information that I was able to supply and my understanding is that they are working on updating the REST-API to better work with the Sinope thermostat. Can't wait to see what they'll come up with. Yet, I'm very happy so far, much progress were achieved.

      One odd thing, in the Phosconn app and in the REST-API, there is a virtual sensor device named "Daylight sensor". That didn't carry over to HS. I was expecting all devices seen in the REST-API would be brought in HS.

      G.





      Comment


        #18
        Originally posted by w.vuyk View Post
        That is good news. I will try to check in the plugin why it could not see the IP change. Did you deliberately change the IP, or is this a DHCP lease change?
        Neither. I had setup a static IP on the PI long before it got configured in your plugin. The plugin never saw a DHCP assigned IP. No idea why but the .120 that was showing is in fact in the DHCP range.

        Originally posted by w.vuyk View Post
        If it happens again, it should be good to stop the plugin, delete the bridge device only in the HS device list and restart the plugin.

        Wim
        I'll try to remember that.

        Comment


          #19
          Originally posted by zguy View Post
          @w.vuyk, here is what I have in HS

          Click image for larger version  Name:	Capture.JPG Views:	0 Size:	35.3 KB ID:	1445974

          2 devices, the second one showing 2 features statuses. That thermostat can accept a remote external temperature and also report on power consumption.

          I'm guessing the one labeled "Status External Temperature?" is just that. However, I do not have a remote sensor connected so not much we can do to test this.

          The one labeled "Status Watts" should be the power consumption. That worked with the Sinope gateway but apparently not yet with the deCONZ. At least the plugin recognize and talks to it, judging by the timestamp beside it.

          On the 1st device, setpoint, mode and temperature work. I'm not certain exactly what the full heat does on the mode one though.

          The heating setpoint doesn't work. It's stuck on "Resting" while it should show "Heating" when the thermostat powers the floor heating element.

          As for the battery, I'm not aware the thermostat has one. It's a line powered device so... Unless there is a battery to maintain some stuff during a power failure, may be.
          I think the Status External Temperature? device should not be there, we will know once the updates in the deCONZ REST API are submitted. Many thermostats (including mine) are suggesting an external temperature device can be attached, but so far the developers have not been able to find the procedure to do this. Maybe sometime later...

          Updating the devices like "Status Watts", heating setpoint, etc will probably not update yet. For this the binding has to be done, where SwoopX is probably working on now. This will enable regular reporting for the thermostat.

          On the mode button, full heating is enabled on some thermostats (like mine, which is a thermostatic valve). Enabling this will fully open the valve to speed up initial heating during a short period of time (15 minutes or so, depending on the brand of thermostat). Probably not applicable for you at this point.

          Could you go to the properties of the device "Plancher Nord" and the "Plancher Nord Status" and select the JowiHue tab? You will find one or more JSON strings for both devices. Could you post those, so I can check if things are complete?


          Originally posted by zguy View Post
          @[B]w.vuyk
          One odd thing, in the Phosconn app and in the REST-API, there is a virtual sensor device named "Daylight sensor". That didn't carry over to HS. I was expecting all devices seen in the REST-API would be brought in HS.
          The daylight sensor is a virtual sensor for Phoscon that indicates sunrise and sunset periods fo the local machine. As HS4 is already presenting sunset and sunrise times this sensor is not populated by the plugin indeed. It would be a bit overkill
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


            #20
            Originally posted by w.vuyk View Post

            I think the Status External Temperature? device should not be there, we will know once the updates in the deCONZ REST API are submitted. Many thermostats (including mine) are suggesting an external temperature device can be attached, but so far the developers have not been able to find the procedure to do this. Maybe sometime later...
            The TH1300ZB does have a port to connect a remote sensor meant to be installed outdoor. I played with the idea of installing one initially but the logistic to route the cable was too much trouble and I dropped that idea.

            Originally posted by w.vuyk View Post
            Updating the devices like "Status Watts", heating setpoint, etc will probably not update yet. For this the binding has to be done, where SwoopX is probably working on now. This will enable regular reporting for the thermostat.
            That was my impression. Knowing them, what's your take, days, weeks, months?

            Originally posted by w.vuyk View Post
            On the mode button, full heating is enabled on some thermostats (like mine, which is a thermostatic valve). Enabling this will fully open the valve to speed up initial heating during a short period of time (15 minutes or so, depending on the brand of thermostat). Probably not applicable for you at this point.
            Quite right, the heater is electrical, not water based. Yet, I'd prefer not having unusable controls. Hopefully that too should be fixed by SwoopX.

            Originally posted by w.vuyk View Post
            The daylight sensor is a virtual sensor for Phoscon that indicates sunrise and sunset periods fo the local machine. As HS4 is already presenting sunset and sunrise times this sensor is not populated by the plugin indeed. It would be a bit overkill
            Absolutely agree. Was just curious.

            Originally posted by w.vuyk View Post
            Could you go to the properties of the device "Plancher Nord" and the "Plancher Nord Status" and select the JowiHue tab? You will find one or more JSON strings for both devices. Could you post those, so I can check if things are complete?
            Is this what you're looking for?

            Details Plancher Nord

            ZHAThermostat

            **************************** Object info *****************************
            {
            "config": {
            "heatsetpoint": 2300,
            "offset": 0,
            "on": true,
            "reachable": false,
            "schedule": {},
            "schedule_on": null
            },
            "ep": 1,
            "etag": "cb771e6a090f8a27ea5891f03a777667",
            "lastseen": "2021-01-06T21:51Z",
            "manufacturername": "Sinope Technologies",
            "modelid": "TH1300ZB",
            "name": "TH1300ZB",
            "state": {
            "lastupdated": "2021-01-06T22:47:09.769",
            "on": null,
            "temperature": 2397
            },
            "swversion": "497",
            "type": "ZHAThermostat",
            "uniqueid": "50:0b:91:40:00:01:63:3e-01-0201"
            }
            ************************* End Object info ***************************

            Details Plancher Nord Status External Temperature?

            ZHATemperature

            **************************** Object info *****************************
            {
            "config": {
            "offset": 0,
            "on": true,
            "reachable": true
            },
            "ep": 1,
            "etag": "9a3d18ae7a1aafd0baa39a654a3f96ec",
            "lastseen": "2021-01-07T22:06Z",
            "manufacturername": "Sinope Technologies",
            "modelid": "TH1300ZB",
            "name": "Plancher Nord Status",
            "state": {
            "lastupdated": "2021-01-06T01:52:46.324",
            "temperature": 2367
            },
            "swversion": "497",
            "type": "ZHATemperature",
            "uniqueid": "50:0b:91:40:00:01:63:3e-01-0402"
            }
            ************************* End Object info ***************************




            ZHAPower

            **************************** Object info *****************************
            {
            "config": {
            "on": true,
            "reachable": false
            },
            "ep": 1,
            "etag": "cb771e6a090f8a27ea5891f03a777667",
            "lastseen": "2021-01-06T21:51Z",
            "manufacturername": "Sinope Technologies",
            "modelid": "TH1300ZB",
            "name": "Plancher Nord Status",
            "state": {
            "current": 62672,
            "lastupdated": "2021-01-06T18:15:34.781",
            "power": null,
            "voltage": 240
            },
            "swversion": "497",
            "type": "ZHAPower",
            "uniqueid": "50:0b:91:40:00:01:63:3e-01-0b04"
            }
            ************************* End Object info ***************************

            Oh, as a side note:

            Click image for larger version

Name:	Capture.JPG
Views:	113
Size:	8.9 KB
ID:	1446247




            Comment


              #21
              Quick question, is it just me or does ZigbBee devices responds faster that Z-Wave ones?

              Comment


                #22
                I find that they respond faster as well.
                HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                Comment


                  #23
                  @w.vuyk, just saw this:

                  SwoopX linked a pull request that will close this issue yesterday
                  Enhance support for Sinope TH1300ZB thermostat #4137

                  Comment


                    #24
                    zguy

                    Sorry for the late response, was away for a few days. Thanks for your trust in this plugin .
                    The development for the REST API is following a two weeks schedule normally. 1st will be a beta cycle, the second will be a release. This way you have one beta and one release per month normally. But there has been a surprise beta with the 2.09.0 version, so I am a bit unsure how the current schedule will be.
                    There was supposed to be a new version on Januari 8, but that did not happen. The next release dat would be Januari 15, which would be expected to be a beta version. This will then probably also include your thermostat.


                    Quite right, the heater is electrical, not water based. Yet, I'd prefer not having unusable controls. Hopefully that too should be fixed by SwoopX.
                    Not sure if he will change this. It might have to come from the plugin. We can check once the updates are available. It might be best to reset the Thermostat once more with the new beta, so you are sure all attributes are from the new version. Often with an update deCONZ has to reread/initialise the attributes.

                    Quick question, is it just me or does ZigbBee devices responds faster that Z-Wave ones?
                    Yes, that is my experience too. I have some zwave devices here (very small network) but have been replacing almost all sensors now by Zigbee ones in the past few years. Especially for motion the difference is a lot.

                    *Edit*

                    ZHAPower

                    **************************** Object info *****************************
                    {
                    "config": {
                    "on": true,
                    "reachable": false
                    },
                    "ep": 1,
                    "etag": "cb771e6a090f8a27ea5891f03a777667",
                    "lastseen": "2021-01-06T21:51Z",
                    "manufacturername": "Sinope Technologies",
                    "modelid": "TH1300ZB",
                    "name": "Plancher Nord Status",
                    "state": {
                    "current": 62672,
                    "lastupdated": "2021-01-06T18:15:34.781",
                    "power": null,
                    "voltage": 240
                    },
                    "swversion": "497",
                    "type": "ZHAPower",
                    "uniqueid": "50:0b:91:40:00:01:63:3e-01-0b04"
                    }
                    ************************* End Object info ***************************
                    There is no Watts update for this sensor. It seems only voltage and current are reported. The plugin normally only reports Watts from this sensors. Was the Sinope gateway maybe calculating the watts? I would have to check if I could calulate it, or that maybe the devs in Github will do that now. They do this for plugs too, so maybe it is going to be included with the new version.



                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                      #25
                      *update* noticed in the code that Watts calulation is added by SwoopX. Looking great from here...
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                        #26
                        Originally posted by w.vuyk
                        Sorry for the late response, was away for a few days.
                        ​​​​​​​No problem. We all have a life 😊


                        Originally posted by w.vuyk View Post
                        *update* noticed in the code that Watts calulation is added by SwoopX. Looking great from here...
                        Cool!

                        I'm just happy I can finally bring those thermostats to HS. HS is the hearth of my system and having devices outside of its control is just not fun. It's been over 18 months I've been searching a way to do this. And at last it happens. Added my second thermostat to deCONZ this weekend and both already are controlled by HS and ordered a third one for the bathroom heated floor which is still on a old programmable thermostat (yuk 😁).

                        Quick question, is it just me or does ZigbBee devices responds faster that Z-Wave ones?

                        Yes, that is my experience too. I have some zwave devices here (very small network) but have been replacing almost all sensors now by Zigbee ones in the past few years. Especially for motion the difference is a lot.
                        Interesting. Always found Z-Wave sensors flaky at best. I'm still using X-10 sensors and they work better, except they're a pain to re-program when the battery goes belly up. Luckily they last.

                        Any brands better than others?

                        Regarding the API release schedule, will I get an advice, or you would get one may be? I'm not in a super rush to get the update but whenever it is available I'd like to be able to grab it as soon as possible.


                        Comment


                          #27
                          I will notify you when a new version is including the thermostat changes.
                          I also had a lot of x10 devices running, the motion sensor I was using then (MS13) was very reliable for sure. They are all here in a box and still functioning (around 15 years old....)
                          But I replaced them all by zigbee motion sensors as two way communication is more reliable I think.

                          As for brands, there are many good brands. Xiaomi/Aqara (chinese) is very popular due to the price tags on it, Philips Hue of course, IKEA etc. etc... for starters, check this page: https://www.phoscon.de/en/conbee2/compatible This will give you some insight of possible lights, switches and sensors. And searching on the github will show you even far more devices that will work on deCONZ (like the thermostats)
                          -- Wim

                          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                          650 devices ---- 336 events ----- 40 scripts

                          Comment


                            #28
                            Will you be supporting HS3 with this thermostat as well? I have a conbee1. Not sure of when I'll be updating to HS4.

                            Robert
                            HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                            Comment


                              #29
                              Robert,

                              I am afraid I have to disappoint you here. The codes of the HS4 version of the plugin and the HS3 version are to much different from each other. I cannot just copy the code from one plugin to the other. And enabling the newer models thermostat was a major change in the HS4 version, so in the HS3 version only the Eurotronics valves are supported.

                              In the HS4 version the thermostat implementation has been done more generic, so it should by default support most thermostats coming from deCONZ REST API now.

                              Wim
                              -- Wim

                              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                              650 devices ---- 336 events ----- 40 scripts

                              Comment


                                #30
                                Thanks Wim. I guess that's one reason to use my HS4 upgrade license.

                                Robert
                                HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                                Comment

                                Working...
                                X