Announcement

Collapse
No announcement yet.

Unable to get Zigbee thermostat recognized

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #76
    I am adding the Sinope Smart Plug & Smart Controller (ZigBee) RM3250ZB & SP2600ZB

    I have added the devices in Phoscon app. The devices and all their clusters are populated in deCONZ. I can communicate and control/read the clusters/data via deCONZ. The issue is that JowiHue, imported the device as an on/off device with only on/off as a command. It doesn't import any of the other clusters. I want to see the live amperage/wattage/voltage readings found in the Electrical Measurement & Simple Metering Cluster.

    In regards to REST-API, it brings up only on/off (what is in Phoscon).

    So the question is can we get the device's clusters/ their data points imported with the device so that we are able to see all the relevant data points from within JowiHue, or will it only take the core (switch) device from Phoscon and none of its attributes.

    Comment


      #77
      Originally posted by JoelWener View Post
      I am adding the Sinope Smart Plug & Smart Controller (ZigBee) RM3250ZB & SP2600ZB
      I don't know about these devices. I do know about Sinope though. I had an issue with one of their thermostats that failed. I initially was happy with them as they responded quite fast in replacing the failed device. But I'm no longer so happy as they are not answering more technical questions regarding a few more issues I have with their Zigbee thermostats. I'm pretty certain it's because I no longer use their GT130 gateway, but that is another story.

      Originally posted by JoelWener View Post
      I have added the devices in Phoscon app. The devices and all their clusters are populated in deCONZ. I can communicate and control/read the clusters/data via deCONZ. The issue is that JowiHue, imported the device as an on/off device with only on/off as a command. It doesn't import any of the other clusters. I want to see the live amperage/wattage/voltage readings found in the Electrical Measurement & Simple Metering Cluster.
      We'll see what @w.vuyk will suggest, I'm sure he will chime in soon. Yet, my suggestion would be to stop the JowiHue plugin then delete all related devices in HS. After that, go back to deCONZ and re-read all clusters of the relevant devices. After that re-enable the JowiHue plugin and see what it discovers.

      Did you check those devices are supported by deCONZ? I had to do a bug report for the then supposedly supported thermostats device I'm using.


      Originally posted by JoelWener View Post
      In regards to REST-API, where do I find this command/query/app. When I click REST-API in the deConz app, it takes me to the Phoscon app (website).
      You need to add an extension to your browser. I use Postman on Chromium. Once you got that, you can point to your deCONZ device with several URLs. But first, you need to register the tool into deCONZ. Check the API docs from deCONZ for more info.

      Originally posted by JoelWener View Post
      So the question is can we get the device's clusters/ their data points imported with the device so that we are able to see all the relevant data points from within JowiHue, or will it only take the core (switch) device from Phoscon and none of its attributes.
      The answer to this really depends on what the REST-API reports. Whatever is in there should be readable by the JowiHue plugin because it uses the same API to get its information. That said, I do have power related devices showing in HS for the Sinope thermostats. It's not consistent between of thermostats firmware revision difference though, again a pending question I have with Sinope.


      Comment


        #78
        Originally posted by JoelWener View Post
        Hi All,

        @w.vuy.k

        New using deconz and JowiHue. In DeconZ I see the ZigBee devices I have added. If I open the menu, and look at the clusters/all data points, I see all the different menus, points.

        In JowiHue, the device was created only with on/off and with none of the other characteristics of the device.

        How do I get the other device points to appear in Hue. Do I have to erase it from Hue and refresh, create points manually?

        Any help/direction would be greatly appreciated.
        Joel,

        This thread is about thermostats, but I understand you are adding different types devices? For the future it is better to start a new thread so I do not get too confused here

        It will help me if you could post the JSON that is shown on the HS device that was created on to the properties of the device and select the JowiHue tab. On the bottom of this page you will se the text string. Could copy and paste this for me, so I can have a look at the details?

        I saw you have posted a device request on the github, which is a good thing, because the device types are not mentioned yet on github and probably not yet fully supported. Normally, if they add the support the plugin will recognise them directly as there are no unknown sensor functions on these devices.

        I will als keep an eye on the two issues on github

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment

        Working...
        X