Announcement

Collapse
No announcement yet.

Invalid reference passed through an event

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Invalid reference passed through an event

    JowiHue has become almost entirely unusable (I can activate exactly 1 scene and no others) and I'm not sure what I may have done to cause this nor what I can do to fix it.

    preface: Yesterday I added 2 hue bulbs and one gledopto light strip to a new room on my bridge. Shortly after that the JowiHue plugin became unresponsive throwing a null reference exception error. I disabled the JowiHue plugin, upgraded to the latest version, bounced my HomeSeer server, removed and added the Hue Bridge.

    Today: whenever I try to activate a scene I get the following error:
    Error: (WaitEventThread)::Invalid reference passed through an event ref=41 please check your events?
    Depending on which scene I'm trying to activeate the "ref=XX" value changes. There is, somehow, exactly one scene I can activate, but this scene is really odd as it isn't setup on my Philips Hue app and I'm not sure where the heck it even came from. Its called "Bedroom scene red" in the event that helps.

    Everything works just fine through the Hue app, but I can't get anything to work from JowiHue except that one wacky scene. Any suggestions on things I could do to get this up and running again?

    #2
    You activate a scene by triggering a scene right? Could you post an image of one of the events while expanding the actions? It looks like a device that is also referred to is removed (ref id = 41) Did you delete devices after creating these events?
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


      #3
      When you say "device" what do you mean exactly? I haven't removed any of the Hue bulbs that I have. I did recently remove a broken light switch from my system, but that was in a different room and not directly related to anything Hue.

      Update: I uninstalled/reinstalled JowiHue, I removed the hue bridge from JowiHue, did a factory reset on my hue bridge, added the bridge back to JowiHue, still getting this error.

      Click image for larger version  Name:	Capture.PNG Views:	0 Size:	223.1 KB ID:	1449165

      Comment


        #4
        The plugin seems to want to find a device with reference 41, which does not exist anymore. If you go to the creativity page and open the scene "Bright", do you stil see all the lights mentioned there? If you do, could you create a detailed trace for me, following these steps:
        1. enable detailed trace and log to file options in the configuration page of the plugin
        2. stop and start the plugin, so we have the start of the plugin in the log
        3. once the plugin is started, trigger the event that throws the error
        4. Disable the detailed trace and log to file options
        5. Locate the logfile at \Logs\JowiHue.log in the HS install directory
        6. Send the file to jowihue at ziggo dot nl?

        Thanks,

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


          #5
          When I go to Creativity there is nothing under the scenes. Bright is a scene that I created on the Hue app on my phone. I haven't created any scenes in the creativity area, I've just been using ones that I had already created on in the Hue app. Regardless, I did what you asked and have sent you an email. Thank you so much for your help!

          Comment

          Working...
          X