Announcement

Collapse
No announcement yet.

errors in plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • errors in plugin

    i am using the plugin for a couple of days but get some errors in the log

    error in log is:
    15-11-2014 12:46:08 ~!~Error~!~Calling SetIOMulti in plugin JowiHuee objectverwijzing is niet op een exemplaar van een object ingesteld.
    15-11-2014 12:46:19 ~!~Error~!~In URLAction GET: Er is een time-out opgetreden voor de bewerking
    15-11-2014 12:46:19 ~!~JowiHue~!~GetJsonCommand::Error while performing GetJsonCommand: De objectverwijzing is niet op een exemplaar van een object ingesteld.

    any thoughts?

  • #2
    Akatar,

    Is this the first time you ran the plugin or was it running ok for a while?
    Are this the only errors and did the plugin continue after reconnecting to the bridge?

    The urlaction get error points to a reachabiltiy issue for the bridge, it seems the plugin was not able to reach the bridge for some time. It should reconnect again once the bridge is reachable though.

    I do not like seeing the object error, so if you would have more information what happened during that time, that could help me see what possible causes are.
    As I am seeing the SetIOMulti, I am guessing you tried to send a command through the webinterface maybe?

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      i tried the plugin for the first time,

      i you mean by using the webinterface the homeseer webinterface then it's correct

      the only info i have is this:

      i wanted to switch a light on and that doesn't work, so i used another device to switch that light on, just to see if the bridge is working. light went on and then i saw the erros in the log

      Comment


      • #4
        is the plugin polling the bridge?
        i noticed that when i turn the light on with another program that sometimes one light will stay off or when they turn on ,a few seconds later full on and not dimmed


        if so, can i turn the polling off? i only need to turn lights on or off

        Comment


        • #5
          Akatar,

          I think that creation of devices is showing an issue here. Not sure yet.
          Could you try and restart Homeseer once and see if the error stays?

          If the error stays, could you follow the next steps:

          1. Disable the JowiHue plugin
          2. Delete all JowiHue devices except the bridge device itself.
          3. Enable the JowiHue plugin.

          It should then recreate the devices. You can then check if the error persists.

          If it still persists You could do the above steps again, but then including deleting the bridge device itself.

          This plugin polls the bridge to be able to show the correct light values in the webinterface. You can set the frequency in the configuration page (default set to once per 2 seconds - 2000 ms) If you want to lower that, just change that value to a higher value.

          Wim
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • #6
            i still get these errors and with the plugin running once a while a light change from dimmed to full on

            can i stop the polling? i gues this is the problem and i don't need it

            Comment


            • #7
              Akatar,

              You cannot stop the polling, but you can lower the frequency like I said in my lat post. Polling is not setting the device, instead of that it is getting the status of devices. Any IFFT actions active maybe?

              If you set it to 1200000 it would poll once in 20 minutes. There is no way it woul be in the way. The situation you describe must come from another controler. If you doubt on that you could disable the plugin for a while to check on that.

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #8
                i will give it a try

                Comment


                • #9
                  Akatar,

                  Did you already find the software switching the light on?

                  There is a new version in the beta section of the updater now, it should solve or at least better the issue with bridges that are not reachable for some time. You can download it, the beta is for Linux installations to test.

                  Thanks,

                  Wim
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment


                  • #10

                    Comment


                    • #11
                      Akatar,

                      Did you install the plugin from the beta section? In this version (which is good for Windows, but beta for Linux users) a few issues regarding the issues you mentions are solved. Please confirm if you downloaded this and still see these issues.

                      Wim
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                      • #12
                        both are crashing, the errors were not from the beta. i download the beta now and will try again

                        Comment


                        • #13
                          with beta, plugin crashes every few minutes

                          Probleemhandtekening:
                          Gebeurtenisnaam van probleem: CLR20r3
                          Probleemhandtekening 01: hspi_jowihue.exe
                          Probleemhandtekening 02: 1.0.4.8
                          Probleemhandtekening 03: 546b42d2
                          Probleemhandtekening 04: mscorlib
                          Probleemhandtekening 05: 4.0.0.0
                          Probleemhandtekening 06: 4d92ee5e
                          Probleemhandtekening 07: 22b
                          Probleemhandtekening 08: 10
                          Probleemhandtekening 09: System.InvalidOperationException
                          Versie van besturingssysteem: 6.1.7600.2.0.0.256.1
                          Landinstelling-id: 1043
                          Aanvullende informatie 1: 0a9e
                          Aanvullende informatie 2: 0a9e372d3b4ad19135b953a78882e789
                          Aanvullende informatie 3: 0a9e
                          Aanvullende informatie 4: 0a9e372d3b4ad19135b953a78882e789

                          Comment


                          • #14
                            Akatar,

                            Could you try the following?

                            1. Disable the plugin
                            2. Delete the devices for lights as well as the groups? No need to delete the bridge.
                            3. Reenable the plugin (the beta 1.0.4.8) and see what happens.

                            When the plugin starts it will recreate the group and light devices.
                            I think the devices were created wrongly. Did you do a test with one of the earlier versions of the plugin maybe (in July perhaps?)

                            Wim
                            -- Wim

                            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                            650 devices ---- 336 events ----- 40 scripts

                            Comment


                            • #15
                              i don't try an older version of the plugin

                              i deleted the groups and lights and installed the beta

                              now sit and wait

                              Comment

                              Working...
                              X