Announcement

Collapse
No announcement yet.

MainThreadRoutine: Error: Object reference not set to an instance of an object

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MainThreadRoutine: Error: Object reference not set to an instance of an object

    I'm running a new HT SEL and the latest version of this plugin, but I get this error several times a day. Any suggestions?

  • #2
    jcrowthers,

    I have one user that has the same error. He did a reset of the bridge. The plugin does not catch the situation where it knows there is a registered bridge, which is unregistered by the reset.

    Could it be you have the same situation? If it is, the way around it now would be stopping the plugin and removing the bridge and its lights an groups from HS3. After that you can start the plugin and reregister the bridge.

    I am working on a solution for this situation.

    If you did not have this situation, please enable the debug functions in the plugin (in the configuration page) and send me the log, filtered on JowiHue, by PM to me?

    Thanks,

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      readded

      lt looks like that worked. I've been having an issue where in the middle of the night the bridge connection slows or disconnects and it reconnects 30 seconds later, so we'll see if I have the same issue when that occurs again.

      I've been tracking my network speed, and its not an issue with network speed, so I'm just watching it closely at this point.

      Love the plugin other than these minor issues. Thanks!

      Comment


      • #4
        I also see a slowdown every now and then. In my case I have a backup job running then and the bridges (and more in my network) recoveres again after that. so I would expect this should not be the cause of your error message originally.
        Let me know if the issue comes back. For nowI am hoping issues are solved

        Thanks,

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment

        Working...
        X