Announcement

Collapse
No announcement yet.

Updater shows 1.0.6.4 available but fails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updater shows 1.0.6.4 available but fails

    The updater keeps showing 1.0.6.4 is available, but then fails to download/install.

  • #2
    i have the same issue

    Comment


    • #3
      I am afraid the updated zip I send to the updater is corrupt. Normally I try to check first when a new update is published, becaus sometimes it is placed in a damaged way. I think it has happened again, but cannot check as I am on travel now.
      I have notified HST to check the file I send

      If you had 1.0.6.3 running correctly, you can skip the new version as no changes are done in there, other then solving an issue with the newtonsoft.json.dll file that occured to only some users.

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #4
        add me to the error
        Attached Files
        Ubuntu 16.10 (64) | HSPro 3.0.0.297 | Z-Wave 3.0.1.124 | Server .94 | BL BackUp | BLOccupied | BLLock | Media Controller | Jowi HUE | HSTouch | DSC-Envisalink | I-Tunes DAAP | DirecTV | Restart | Honeywell WiFi | Weather XML | RFX Com | + Android .117 : IOS 8

        Comment


        • #5
          I'm having an issue with errors on the log specific to JSON and then the object not set to instance error

          Comment


          • #6
            Originally posted by Automated View Post
            The updater keeps showing 1.0.6.4 is available, but then fails to download/install.
            I got confirmation from HST that there was an issue in the updater. I am on travel, so cannot test it myself, but you should now be able to download the new version correctly.

            Wim
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #7
              Dear Wim,

              Today I started a trial period of your Hue plugin, after I bought a Hue starter kit.
              Homeseer is v3.0.0.199

              Here is the a list of problem I can report.

              1) I installed v1.0.6.4 from the updater, but the downloaded HSPI_JowiHue.exe is v1.0.6.3 dated August, 27th.

              2) In the documentation, you state that with first installation of the database, a few animations are added, but I couldn't find any.

              3) I created a test animation "Test Christmas", with Scenes Christmas steps 1, 2, 3.

              If from step-3, I select Loop from step1, number of loops 5, the animation loops 5 times.
              If from step-3, I select Loop from step1, and check "Infinite loop", the animation doesn't loop anymore. It looks like infinite looping is broken.

              (Christmas step 1[T:2sec W:2sec] + Christmas step 2[T:2sec W:2sec] + Christmas step 3[T:2sec W:2sec]){*Infinite*}

              4) I created a test HomeSeer event with a JowieHue Start Animation action, and selected my "Test Christmas" animation.

              I tried to trigger the event, but the event system could never find the animation name. Here is the log:

              PHP Code:
              sept.-15 18:13:36         JowiHue    Animation not foundPlease check events
              sept
              .-15 18:13:36         JowiHue    Debug: :HandleAction was called
              sept
              .-15 18:13:36         Event    Event E10 E10 ONAction of JowiHueJowiHue Actions could not be carried out because its configuration is not complete
              If I create a second animation, then I can choose between 2 animations in the dropdownlist, and the selected animation starts when the event is triggered.

              I was able to reproduce the problem: deleted the HomeSeer event, deleted my second HomeSeer animation --> Only one Hue animation remaining in the list.
              Then created an event again, selected JowiHue Start animation, selected my "Test Christmas" animation, and got the same error as above when the event is triggered.

              It's a minor problem, as it only happens when there is only one animation.

              5) I tried to take snapshots of my light status to create scenes, but the SNAPSHOT button has a weird effect: CPU for the HSPI_JowiHue.exe process goes to 50%, and never decreases (waited more than 10 minutes, tried many times, after restarting the plugin, after restarting HomeSeer, after rebooting...) --> always same 50% CPU effect and the plugin is frozen (plugin pages do not respond... etc)

              The only log that shows after clicking the SNAPSHOT button is:
              PHP Code:
              sept.-15 18:26:09         JowiHue    Debug: :MainWatchTimerChecking plugin health 

              I really want to see Infinite loops and snapshots working


              Best regards,

              stipus
              --
              stipus

              Comment


              • #8
                FYI, I stopped the plugin, deleted the database, reinstalled again, and the problem with scene snapshots is gone.

                The problem with Infinite Looping is still there...
                --
                stipus

                Comment


                • #9
                  The updater no longer gives an error, but the actual package being installed is still 1.0.6.3, so it always shows that there is still an update to do.

                  Comment


                  • #10
                    Ok ... With 1.0.6.3, can you create a never ending animation ?

                    - Creativity / Animation
                    - Create a new animation
                    - Add 3 scenes as step1, step2, step3
                    - on the last scene, choose "loop from step1", and check infinite

                    Test the animation. Does-it loop forever ? With my setup it stops right after step3, and doesn't loop at all.

                    If I don't check infinite, and type a loop count (eg 10) ... Then the animation loops fine 10 times.
                    --
                    stipus

                    Comment


                    • #11
                      Originally posted by stipus View Post
                      Ok ... With 1.0.6.3, can you create a never ending animation ?

                      - Creativity / Animation
                      - Create a new animation
                      - Add 3 scenes as step1, step2, step3
                      - on the last scene, choose "loop from step1", and check infinite

                      Test the animation. Does-it loop forever ? With my setup it stops right after step3, and doesn't loop at all.

                      If I don't check infinite, and type a loop count (eg 10) ... Then the animation loops fine 10 times.
                      I was only commenting on the original topic of this thread, not the hijack. [emoji6]

                      Comment


                      • #12
                        OK thank you. I'll create a new topic for my question.
                        --
                        stipus

                        Comment


                        • #13
                          Originally posted by Automated View Post
                          The updater no longer gives an error, but the actual package being installed is still 1.0.6.3, so it always shows that there is still an update to do.
                          Automated,

                          I will fix that once I return from my travel, after September 26. I though I changed the version number, but appearently missed it. Just ignor it for now, as there is no difference in the plugin itself between these versions.

                          Thanks

                          Wim
                          -- Wim

                          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                          650 devices ---- 336 events ----- 40 scripts

                          Comment


                          • #14
                            Originally posted by Automated View Post
                            The updater no longer gives an error, but the actual package being installed is still 1.0.6.3, so it always shows that there is still an update to do.
                            Automated,

                            There is a corrected version in the updater now, which is reporting the correct version again. There are more changes that mightbe of interest for you, you can find them in the release notes in the sticky's

                            Thanks for your patience!

                            Wim
                            -- Wim

                            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                            650 devices ---- 336 events ----- 40 scripts

                            Comment


                            • #15
                              Thanks. I noted this yesterday and updated.

                              Comment

                              Working...
                              X