Announcement

Collapse
No announcement yet.

after every restart of jowihue plugin I have to re-register the bridge

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • after every restart of jowihue plugin I have to re-register the bridge

    Hi Wim,

    Last week I bought a hue starter pack and installed your plugin to give it a try.
    Installation went succesfull. I'm using hs3 linux version 208, I installed your plugin by manually downloading it from homeseer.com because your plugin is not listed in the plugin packages list.

    registering the bridge went fine. but every time I restart the plugin or restart homeseer I need to register the bridge again. Any ideas?

    Code:
    Oct-18 16:54:39	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:54:39	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:54:39	 	JowiHue	+ Unregistered bridge found on network at IP 
    Oct-18 16:54:39	 	JowiHue	Debug: :Probing Hue bridge at IP (removed)
    Oct-18 16:54:39	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:54:39	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:54:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:53:39	 	JowiHue	RefreshWatchTimer: Error: Object reference not set to an instance of an object
    Oct-18 16:53:39	 	JowiHue	Info: Unregistered bridges found on network
    Oct-18 16:53:39	 	JowiHue	Debug: :RefreshWatchTimer: Checking for lights and groups, maintenance lifetime usage
    Oct-18 16:52:39	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:52:39	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:52:39	 	JowiHue	+ Unregistered bridge found on network at IP address:
    Oct-18 16:52:39	 	JowiHue	Debug: :Probing Hue bridge at IP 
    Oct-18 16:52:39	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:52:39	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:52:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:50:39	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:50:39	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:50:39	 	JowiHue	+ Unregistered bridge found on network at IP address:
    Oct-18 16:50:39	 	JowiHue	Debug: :Probing Hue bridge at IP 
    Oct-18 16:50:39	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:50:39	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:50:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:48:39	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:48:39	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:48:39	 	JowiHue	+ Unregistered bridge found on network at IP address:
    Oct-18 16:48:39	 	JowiHue	Debug: :Probing Hue bridge at IP 
    Oct-18 16:48:39	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:48:39	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:48:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:47:57	 	JowiHue	Debug: :id:timer
    Oct-18 16:46:39	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:46:39	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:46:39	 	JowiHue	+ Unregistered bridge found on network at IP address
    Oct-18 16:46:39	 	JowiHue	Debug: :Probing Hue bridge at IP 
    Oct-18 16:46:39	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:46:39	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:46:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:44:39	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:44:39	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:44:39	 	JowiHue	+ Unregistered bridge found on network at IP address:
    Oct-18 16:44:39	 	JowiHue	Debug: :Probing Hue bridge at IP 
    Oct-18 16:44:39	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:44:39	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:44:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:42:39	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:42:39	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:42:39	 	JowiHue	+ Unregistered bridge found on network at IP address:
    Oct-18 16:42:39	 	JowiHue	Debug: :Probing Hue bridge at IP Serial= (removed)
    Oct-18 16:42:39	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:42:39	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:42:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:40:39	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:40:39	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:40:39	 	JowiHue	+ Unregistered bridge found on network at IP address
    Oct-18 16:40:39	 	JowiHue	Debug: :Probing Hue bridge at IP  Serial= (removed)
    Oct-18 16:40:39	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:40:39	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:40:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:38:52	 	JowiHue	Debug: :End search for bridges
    Oct-18 16:38:51	 	JowiHue	Debug: :id:timer
    Oct-18 16:38:45	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=False
    Oct-18 16:38:45	 	JowiHue	InitPlugin:No registered bridge found; please register a bridge through the configuration page
    Oct-18 16:38:45	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:38:45	 	JowiHue	Debug: :InitDevices: Device checks done
    Oct-18 16:38:43	 	JowiHue	Debug: :InitDevices: Searching for Hue devices
    Oct-18 16:38:42	 	JowiHue	SetLightSuspected: Bridge has been reset, setting all bridge lights suspected, so original settings can be restored later if needed
    
    Oct-18 16:38:42	 	JowiHue	Debug: :GetLightsFromBridge: Building list of lights connected to bridge '""'
    Oct-18 16:38:42	 	JowiHue	Debug: :Searching for bridges
    Oct-18 16:38:42	 	JowiHue	Debug: :Scanning for bridges starting
    Oct-18 16:38:42	 	JowiHue	* Connected to bridge "" at (removed)
    Oct-18 16:38:41	 	JowiHue	bridge Philips hue ip adress is (removed)
    Oct-18 16:38:41	 	JowiHue	bridge Philips hue is known as bridge, but is now unregistered. Please reregister through the configuration page.
    Oct-18 16:38:40	 	JowiHue	Debug: :InitDevices: Searching for Hue devices
    Oct-18 16:38:39	 	JowiHue	Debug: :InitPlugin:initial checks
    Oct-18 16:38:39	 	JowiHue	InitIO:Plugin basic initialisation done
    Oct-18 16:38:39	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:37:32	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:37:11	 	JowiHue	Debug: :id:oRefreshRate
    Oct-18 16:37:11	 	JowiHue	Debug: :RefreshRate:4.0
    Oct-18 16:36:57	 	JowiHue	Debug: :id:timer
    Oct-18 16:35:33	 	JowiHue	Debug: :UpdateStatusThread:Start with refreshrate set to 2000 ms
    Oct-18 16:35:33	 	JowiHue	Plugin succesfully started
    Oct-18 16:35:32	 	JowiHue	Debug: :InitPlugin:Config Done InitOK=True
    Oct-18 16:35:32	 	JowiHue	==============================================================================================
    Oct-18 16:35:32	 	JowiHue	Device of reporting bridge and light firmware updates is enabled
    Oct-18 16:35:32	 	JowiHue	0 Animations available for use in this plugin
    Oct-18 16:35:32	 	JowiHue	15 Local scenes available for use in the JowiHue plugin
    Oct-18 16:35:32	 	JowiHue	-------------------------------------Plugin info ---------------------------------------------
    Oct-18 16:35:32	 	JowiHue	3 Groups available on bridge 'Philips hue'
    Oct-18 16:35:32	 	JowiHue	4 lights connected to bridge 'Philips hue'
    Oct-18 16:35:32	 	JowiHue	-------------------------------------Bridge info ---------------------------------------------
    Oct-18 16:35:32	 	JowiHue	==============================================================================================
    Oct-18 16:35:32	 	JowiHue	Debug: :GetAnimations finished normal
    Oct-18 16:35:32	 	JowiHue	Debug: :GetScenes finished normally
    Oct-18 16:35:32	 	JowiHue	Debug: :RefreshDevices finished succesfully for bridge Philips hue
    Oct-18 16:35:32	 	JowiHue	Debug: :GetScenesFromBridge: Building list of scenes found on bridge 'Philips hue'
    Oct-18 16:35:32	 	JowiHue	Debug: :GetSensorsFromBrige: Building list of sensors connected to bridge 'Philips hue'
    Oct-18 16:35:32	 	JowiHue	Debug: :GetRulesFromBrige: Building list of Rules connected to bridge 'Philips hue'
    Oct-18 16:35:32	 	JowiHue	Debug: :GetGroupsFromBridge: Building list of groups on bridge 'Philips hue'
    Oct-18 16:35:32	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:35:32	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:35:32	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:35:32	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:35:32	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:35:32	 	JowiHue	Debug: :GetLightsFromBridge: Building list of lights connected to bridge 'Philips hue'
    Oct-18 16:35:32	 	JowiHue	Debug: :InitPlugin:Starting Bridge
    Oct-18 16:35:32	 	JowiHue	Debug: :InitPlugin: 1 registered bridge(s) found
    Oct-18 16:35:32	 	JowiHue	Debug: :SearchAndCheckBridges::1 bridge(s) found in this network
    Oct-18 16:35:32	 	JowiHue	Debug: :InitPlugin:Starting Device checks
    Oct-18 16:35:32	 	JowiHue	Debug: :MainWatchTimer: Checking plugin health
    Oct-18 16:35:25	 	JowiHue	Debug: :id:timer
    Oct-18 16:34:06	 	JowiHue	Debug: :RefreshDevices finished succesfully for bridge Philips hue
    Oct-18 16:34:06	 	JowiHue	Debug: :GetScenesFromBridge: Building list of scenes found on bridge 'Philips hue'
    Oct-18 16:34:06	 	JowiHue	Debug: :GetSensorsFromBrige: Building list of sensors connected to bridge 'Philips hue'
    Oct-18 16:34:06	 	JowiHue	Debug: :GetRulesFromBrige: Building list of Rules connected to bridge 'Philips hue'
    Oct-18 16:34:06	 	JowiHue	Debug: :GetGroupsFromBridge: Building list of groups on bridge 'Philips hue'
    Oct-18 16:34:06	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:34:06	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:34:06	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:34:06	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:34:06	 	JowiHue	Debug: :checking suspected lights
    Oct-18 16:34:06	 	JowiHue	Debug: :GetLightsFromBridge: Building list of lights connected to bridge 'Philips hue'
    Oct-18 16:34:06	 	JowiHue	Debug: :Createuser BridgeRow.User:xxxxx
    Oct-18 16:34:06	 	JowiHue	Registering bridge was succesfull
    Thanks
    Zigmund
    Last edited by zigmund; October 30th, 2015, 01:32 PM. Reason: fixed

  • #2
    Zigmund,

    Posted my answer earlier, but somehow it got discarded I guess.

    I am running the plugin on Linux myself for testing purposes. It runs fine, so it should have ran on your installation as well. The reason why it is not in the plugins list is that I have temporary removed it as some users are complaining about a memory leak. The latest test of some users and me are looking good though, it seems the last updates have solved the issue.

    One remark from you triggers me, you said you bought the starter set last week? Did you receive the new bridge (square version)? As There are some small changes made by Philips in the UPNP handshake. They are delivering different data, so that might be part of an issue.

    I have ordered a new bridge version to test, but it seems that even developers have to wait till november where the bridges will start selling as seperate items. I do not need an starter set anymore


    But if this is the case, you have to wait untill get my hands on a bridge to check..


    But to kill my curiousity, could you send me the results in de description xml of the bridge?

    You can get this file by opening the browser, entering (ip of your bridge)/description.xml. Send me the contents of this xml through PM? Do not post it here....


    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      no new bridge

      Wim,

      the bridge is the "old" version, not the homekit version.

      I will send you the detailed information you requested.

      Zigmund

      Comment


      • #4
        Ok, then I think i will have to do a clean test with the latest bridge updates. Maybe somehting changed there.. I did not yet do that since the last firmware updates of the bridge

        Thanks

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • #5
          Zigmund,

          I tested a clean install of the plugin on Windows as Linux, and each time a new registration works, no matter wich environment I use. I cannot copy it here?

          When you do the restart of Homeseer, are the jowiHue devices still visible in the deviceutility page? The plugin writes information about the bridge to devices in the homeseer database, so I am wondering if somehow this database is protected or returned to old state on restart?

          Wim
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • #6
            fixed it

            Wim,

            Fixed it. First I removed all JowiHue devices in Homeseer. Then I registered the bridge again. Now the problem is solved.

            I'm not sure but I think the root-cause of the problem was I first installed the bridge with a different ip address on my local network. After that I did a factory reset of the bridge and re-installed the plugin but I did not remove the JowiHue devices in homeseer.

            So after factory reset or ip-change all devices must be removed in homeseer.

            Happy it's working now. Thank you.
            Zigmund

            Comment


            • #7
              Zigmund,

              Glad to hear it is working now
              Yes, up till now you need to delete the devices that belogn to a bridge that has been reset. This will change with the new bridge version.....

              Could you keep an eye on memory usage of the plugin in Linux for a few days for me? If it is stable I am a happy guy

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #8
                I will monitor on memory usage and let you know.

                Comment


                • #9
                  memory usage

                  Hi Wim,

                  after monitoring memory usage for two days I see memory usage is slowly growing
                  from 41 Mb till now 121 Mb (measurement in 40 hours)

                  Zigmund

                  Comment


                  • #10
                    Wich is already high I am afraid. Sounds like it will grow to to 500 Mb in 8 or so days....
                    I wonder why Linux is showing this behaviour and Windows is not showing this at all...

                    Back to the drawing table I suppose

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment

                    Working...
                    X