Announcement

Collapse
No announcement yet.

Can't install the plugin - message says "expired" but version is 3.0.0.13

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't install the plugin - message says "expired" but version is 3.0.0.13

    Greetings,

    I am trying to install and start the plugin for the first time from HS3, but it won't start. The plugin status message is "WARNING: Failed getting InterfaceStatus from LGSmartThinq - the interface was not found in the list of active interfaces, the list may need to be refreshed." In the log, I see the messages listed below. I am not trying to upgrade from a previous version, and I've never had this plugin before. If I can get this working, it would be great to be able to manage my LG A/C unit. Thanks for all your help!

    Jan-07 5:15:46 PM Plug-In Finished initializing plug-in LGSmartThinq
    Jan-07 5:15:46 PM Starting Plug-In LGSmartThinq loaded in 503 milliseconds
    Jan-07 5:15:46 PM Info Plugin LGSmartThinq with instance: has disconnected
    Jan-07 5:15:46 PM LGSmartThinq ERROR Error ending LGSmartThinq Plug-In
    Jan-07 5:15:46 PM Error Initializing plug-in(1): LGSmartThinq Instance::The plug-in has expired and will no longer run. Please download the official one from the HS3 Updater. Time to load: 10 milliseconds
    Jan-07 5:15:46 PM LGSmartThinq Starting initialization.
    Jan-07 5:15:46 PM Starting Plug-In Initializing plugin LGSmartThinq ...
    Jan-07 5:15:45 PM Info Plugin LGSmartThinq has connected. IP:127.0.0.1:57535

  • #2
    Same here. I paid for the plugin and it worked for about a month. Not sure exactly when it quit because I was having issues with the new LG units themselves and they were powered down for quite some time. Now they are working, the Thinq app is working on my iPhone, but the plugin in HS3 Pro is not. Below are the entries from my log:

    Please help!
    Jan-12 10:26:11 PM Info Plugin LGSmartThinq has connected. IP:127.0.0.1:54608
    Jan-12 10:26:11 PM Starting Plug-In Initializing plugin LGSmartThinq ...
    Jan-12 10:26:11 PM Error Initializing plug-in(1): LGSmartThinq Instance::The plug-in has expired and will no longer run. Please download the official one from the HS3 Updater. Time to load: 4 milliseconds
    Jan-12 10:26:11 PM LGSmartThinq ERROR Error ending LGSmartThinq Plug-In
    Jan-12 10:26:11 PM Starting Plug-In LGSmartThinq loaded in 312 milliseconds
    Jan-12 10:26:11 PM Plug-In Finished initializing plug-in LGSmartThinq
    Jan-12 10:26:11 PM Info Plugin LGSmartThinq with instance: has disconnected

    Comment


    • #3
      Experiencing the same issue - started after I deleted my devices to refresh/troubleshoot today XboxMeister

      Here's my log. I tried deleting and reinstalling, even deleting all config fiiles and ini files. I checked for the Newtonsoft dll in the HS3 root as well as some others have reported that this is an issue - no stray Newtonsoft dll... i deleted the one in the /bin/LGSmartthinq directory and reinstalled to no avail. I've come to depend highly on this plugin as we have 6 LG heat pumps throughout the house (in fact I was the beta tester and the original person who pushed XboxMeister to create it. It's a super piece of software!
      Jan-21 1:28:47 PM Plug-In Finished initializing plug-in LGSmartThinq
      Jan-21 1:28:47 PM Starting Plug-In LGSmartThinq loaded in 301 milliseconds
      Jan-21 1:28:47 PM Info Plugin LGSmartThinq with instance: has disconnected
      Jan-21 1:28:47 PM LGSmartThinq ERROR Error ending LGSmartThinq Plug-In
      Jan-21 1:28:47 PM Error Initializing plug-in(1): LGSmartThinq Instance::The plug-in has expired and will no longer run. Please download the official one from the HS3 Updater. Time to load: 6 milliseconds

      Comment


      • #4
        Has anyone else heard back from XboxMeister yet? I have messaged/emailed him several times with no reply - which is really not like him when I was working with him on this plugin. Worried that something may have happened to him.

        I tried setting the system clock/date back to 11/25/2019 before installing the plugin. This worked, although as soon as the date went back to today's date, the same error with "plug-in expired" notice popped up again.

        I've come to depend heavily on this plugin!

        Comment


        • #5
          I have not heard anything yet. Perhaps he was busy after the move? Still hoping to hear something.

          Comment


          • #6
            Heard back from official support. Apparently XboxMeister is away but will be back in 2 weeks or so. So we should just hang tight!

            Comment

            Working...
            X