Announcement

Collapse
No announcement yet.

Problem with LutronQS plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with LutronQS plugin

    Hi. I am trying to set up HS3 to talk to my Lutron QS lighting system. It's big, about 400 devices.

    The startup appears fine - connects to the Lutron system,. and with debug on, after I ask it to create devices that don't yet exist, it starts a long laundry list of device imports. But in the end, none of the devices show up in HS, though it's obvious that they must have been created, because new rooms show up as options that weren't present before.

    Here is an error that happens early in the process:
    Oct-24 7:27:38 PM Error Posting back to plugin web page LutronQSConfig: Object reference not set to an instance of an object.-> at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.PostBackProc(String page, String data, String user, Int32 userRights) at Scheduler.proxyPage.postBackProc(StateObject& state, String Data)

    And after that error, I see these warnings every 30 secs or so.
    :
    Oct-24 7:31:21 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
    When it seems to be done, the MAIN_REPEATER device says "Not Connect".

    BTW, when it's importing all the devices, HS becomes very unresponsive. It's still working in respond to web commands, but slowly...

    Any ideas as to what might be wrong?

    thx
    mike

    #2
    Mike,

    Can you post the details of your system, windows? Ver of HS? Ver of QS plugin

    Comment


      #3
      Originally posted by DonMor View Post
      Mike,

      Can you post the details of your system, windows? Ver of HS? Ver of QS plugin
      Thanks for the quick turnaround!

      This is HS3 Pro 3.0.0.548 running on up to date and patched Windows Server 2019, as a Guest VM with 8 GB of RAM and 6 CPUs, and I am running v 3.0.0.105 of the plugin in evaluation mode.

      After I posted the question, I discovered a couple things:

      1) The MAIN_REPEATER now shows as connected.

      2) The devices were made, but not under the LUTRONQS floor, they mirror the QS system's config of "Main Floor", "Upper Floor", etc...

      3) Nothing seems to work. The devices statuses all show as off, and pushing any of the buttons don't generate any actions on the system. In fact, I have debug mode on, but there is nothing in the log about any commands being sent, or any updates going on. Here are all the plugin's log after I restarted HS3 last night:
      Oct-25 1:06:50 AM Info Plugin LutronQS with instance: has disconnected
      Oct-24 11:59:38 PM Error Initializing plug-in(2): LutronQS Instance::Object reference not set to an instance of an object.STACK: at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
      Oct-24 11:51:53 PM Plug-In Finished initializing plug-in LutronQS
      Oct-24 11:51:53 PM Starting Plug-In LutronQS loaded in 15017 milliseconds
      Oct-24 11:51:38 PM Starting Plug-In Initializing plugin LutronQS ...
      Oct-24 11:51:38 PM Info Plugin LutronQS has connected. IP:127.0.0.1:60067
      Oct-24 11:51:38 PM Plug-In Interface LutronQS is running as a trial, 30 days remaining.
      Oct-24 10:42:05 PM Info Plugin LutronQS with instance: has disconnected
      Oct-24 9:34:18 PM Error Initializing plug-in(2): LutronQS Instance::Object reference not set to an instance of an object.STACK: at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
      Oct-24 9:26:18 PM Starting Plug-In Initializing plugin LutronQS ...
      Oct-24 9:26:18 PM Starting Plug-In LutronQS loaded in 15096 milliseconds
      Oct-24 9:26:03 PM Info Plugin LutronQS has connected. IP:127.0.0.1:56784
      Oct-24 9:26:02 PM Warning I/O interface LutronQS is down, executable is not running, restarting ...
      Oct-24 9:25:32 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 9:25:32 PM Info Plugin LutronQS with instance: has disconnected
      Oct-24 8:27:50 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:27:19 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:26:49 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:26:19 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:25:49 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:25:18 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:24:48 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:24:18 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:23:48 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:23:18 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:22:47 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:22:17 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:21:47 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:21:17 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:20:46 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:20:16 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:19:46 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:19:42 PM LutronQS Now try to Log in Lutron
      Oct-24 8:19:16 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:18:44 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:18:13 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:17:43 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:17:13 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:16:43 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:16:13 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:15:43 PM LutronQS Now try to Log in Lutron
      Oct-24 8:15:42 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:15:12 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:14:42 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:14:12 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:13:41 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:13:11 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:12:41 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:12:11 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:11:41 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:11:10 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:10:40 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:10:10 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:09:40 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:09:09 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:08:39 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:08:09 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:07:39 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:07:09 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:06:38 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:06:08 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:05:38 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:05:08 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:04:37 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:04:07 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:03:37 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:03:07 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:02:37 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:02:06 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:01:36 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:01:05 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:00:35 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 8:00:05 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:59:35 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:59:04 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:58:34 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:58:04 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:57:34 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:57:03 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:56:33 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:56:03 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:55:32 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:55:02 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:54:32 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:54:02 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:53:31 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:53:01 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:52:31 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:52:01 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:51:31 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:51:00 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:50:30 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:50:00 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:49:30 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:48:59 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:48:29 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:47:59 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:47:29 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:46:59 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:46:28 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:45:58 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:45:28 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:44:58 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:44:28 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:43:57 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:43:27 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:42:57 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:42:27 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:41:56 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:41:26 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:40:56 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:40:25 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:39:55 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:39:25 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:38:55 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:38:24 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:37:54 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:37:24 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:36:54 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:36:24 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:35:53 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:35:23 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:34:53 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:34:23 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:33:53 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:33:22 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:32:52 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:32:22 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:31:52 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:31:21 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:30:51 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:30:21 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:29:51 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:29:21 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:28:50 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:28:20 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:27:50 PM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
      Oct-24 7:27:38 PM Error Posting back to plugin web page LutronQSConfig: Object reference not set to an instance of an object.-> at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.PostBackProc(String page, String data, String user, Int32 userRights) at Scheduler.proxyPage.postBackProc(StateObject& state, String Data)
      Oct-24 7:22:40 PM LutronQS Now try to Log in Lutron
      Oct-24 7:22:36 PM Starting Plug-In Plugin LutronQS started successfully in 17990 milliseconds
      Oct-24 7:22:33 PM Plug-In Finished initializing plug-in LutronQS
      Oct-24 7:22:33 PM Starting Plug-In LutronQS loaded in 15070 milliseconds
      Oct-24 7:22:18 PM Starting Plug-In Initializing plugin LutronQS ...
      Oct-24 7:22:18 PM Info Plugin LutronQS has connected. IP:127.0.0.1:58074
      Oct-24 7:22:18 PM Plug-In Interface LutronQS is running as a trial, 30 days remaining.
      Oct-24 7:21:03 PM Plug-In Found plug-in: LutronQS, version: 3.0.0.105

      Comment


        #4
        Can you try the beta version

        Comment


          #5
          Ok, updated successfully to Beta v 3.0.0.106. It started up fine, and connected via telnet, and this time, when I pushed a button, I saw it send commands that didn't actually end up doing anything in the room. None of the actual Lutron devices has a last change field with any value set.

          Should I delete all the devices and try and have the plugin recreate them?




          Comment


            #6
            So I went ahead with the delete and recreate devices, and it threw this error again:
            Oct-25 9:54:59 AM Warning Plugin LutronQS is not responding but it is still running, not restarting yet.
            Oct-25 9:54:46 AM Error Posting back to plugin web page LutronQSConfig: Object reference not set to an instance of an object.-> at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.PostBackProc(String page, String data, String user, Int32 userRights) at Scheduler.proxyPage.postBackProc(StateObject& state, String Data)

            Anything else I can do to get you more debugging output? The log still shows it going through all the Lutron devices after the error.

            Comment


              #7
              I’ll PM you

              Comment


                #8
                BTW, I see the plug in having problems talking to the QS system when I push a button on the web interface (which is running HWQS version 15.02):
                Oct-25 4:35:52 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:52 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:52 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:46 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:46 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:46 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:41 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:41 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:41 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:36 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:36 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:36 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:30 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:30 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:30 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:25 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:25 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:25 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:20 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:20 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:20 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:14 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:14 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:14 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:08 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:08 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:08 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:35:03 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:35:03 PM LutronQS Now try to Log in Lutron
                Oct-25 4:35:03 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:34:57 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:34:57 PM LutronQS Now try to Log in Lutron
                Oct-25 4:34:57 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:34:52 PM LutronQS Debug Command Send SEETOUCH_KEYPAD: #DEVICE,16,6,4
                Oct-25 4:34:52 PM LutronQS Debug Command Send SEETOUCH_KEYPAD: #DEVICE,16,6,3
                Oct-25 4:34:52 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:34:52 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:34:52 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:34:52 PM LutronQS Now try to Log in Lutron
                Oct-25 4:34:52 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:34:47 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:34:47 PM LutronQS Now try to Log in Lutron
                Oct-25 4:34:47 PM LutronQS connected to the telnet IP address: 10.1.1.15Port: 23
                Oct-25 4:34:46 PM LutronQS Debug Command Send SEETOUCH_KEYPAD: #DEVICE,16,5,4
                Oct-25 4:34:46 PM LutronQS Debug Command Send SEETOUCH_KEYPAD: #DEVICE,16,5,3
                Oct-25 4:34:46 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:34:46 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:34:41 PM LutronQS Warning Lost connection with Telnet
                Oct-25 4:34:41 PM LutronQS Debug Command Send SEETOUCH_KEYPAD: #DEVICE,16,5,4
                Oct-25 4:34:41 PM LutronQS Debug Command Send SEETOUCH_KEYPAD: #DEVICE,16,5,3
                Oct-25 4:34:39 PM LutronQS Debug Command Send SEETOUCH_KEYPAD: #DEVICE,16,5,4
                Oct-25 4:34:39 PM LutronQS Debug Command Send SEETOUCH_KEYPAD: #DEVICE,16,5,3

                None of the devices have a device last change time. Does the PI poll for changes, or is the connection supposed to be open continuously and then updates to status get pushed to the PI over the connection?

                Comment


                  #9
                  You should have a return with ~output... when light changes the #device is a command you send to simulatea press of a keypad or pico, #output is for a switch

                  the telnet stay connect all the time and listen all the change in real time

                  Comment

                  Working...
                  X