Announcement

Collapse
No announcement yet.

Trying to count Ra2 button presses / releases with no luck.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trying to count Ra2 button presses / releases with no luck.

    I'm trying to program actions based on multiple presses and releases of a SeeTouch keypad button, but I can't get a button to do anything in HS3 using the RA2 plugin if its LED is already lit (after the first press and release). I think this worked previously a few years ago, but now I can only use as triggers LED status changes, but not the "Press" status in HS or the names of the buttons on the keypad device. More detail: I have a button called "Just So" that sets 8 lights to various dim levels. I want to be able to tap it 2 or 3 times to get all the lights to go to 100%. The repeater will show a "Release" command in the Telnet each time I hit the button, even if its single/multi room scene and LED are already on. Interestingly, I never see a "Press" (3) in Telnet. In Telnet, I can see it as ~DEVICE,24,1,4 (Device 24, button 1 [Just So], release) in the standard monitoring every time I tap it, but no trigger in HS seems to key off of this activity. I've tried using the keypad device as the trigger with both "This device had its value set to" and "The device changes and becomes" the scene name, and also both of those with the device that is the scene name with the press status, but neither triggers when the button is pressed and released. Can you help? Maybe add a "release (button name)" trigger?

    #2
    First try do do paragraph on your post, it is very hard to follow.

    No reason it should not work.

    Can you post a screen shot if the seetouch device and also a screen shot of your events, then I'll be able to assist you.

    Comment


      #3
      Thank you for the quick reply. Sorry, I know that was confusing. Please see below. The main issue is that the "Just So Tap" event never fires. The Just So Counter never increments. If I make this same set of events with a Pico, it works perfectly.

      Comment


        #4
        I forgot to mention that "James Office All 100" is a phantom scene on the main repeater, but that's not relevant here. It never gets that far.

        Comment


          #5
          Mike,

          It look like you use the main control, you need in the event to use the Press device. See the attachment.

          Click image for larger version

Name:	Even.png
Views:	67
Size:	115.8 KB
ID:	1471449Click image for larger version

Name:	Seetouch.png
Views:	62
Size:	109.7 KB
ID:	1471450

          Comment


            #6
            I am using HS3 so it looks different. There is no device/feature in HS3 that I can find. Is the attached what you mean? This still doesn't work, I think because the repeater never reports a press (3). Repeater reports a "Release" (4) but not a "Press." Please see the Telnet readout. There is only ~DEVICE,24,1,4 but no ~DEVICE,24,1,3 .

            Comment


              #7
              I have event that is trigger with the press, I'll see tonight what the telnet show in my house. in the program it does use the 3 to activate.

              you can check your monitoring parameter with the telnet, see the photo.
              Click image for larger version  Name:	Monitiring.png Views:	0 Size:	438.1 KB ID:	1471482

              Comment


                #8
                Thanks for looking. I wonder why mine isn't registering the presses. Is there any special config I need to do on the SeeTouch device or plugin?

                Comment


                  #9
                  Mike,

                  this is my reporting from Telnet, I also did the ?monitor,255 that give you all the parameter of your monitor

                  Hope this can help. Give us your feedback.

                  3 = press
                  4 = release
                  9,1 = Led on
                  9,0 = Led off


                  ~DEVICE,72,2,3
                  ~DEVICE,72,2,4
                  ~DEVICE,72,82,9,1
                  ~DEVICE,72,2,3
                  ~DEVICE,72,82,9,0
                  ~DEVICE,72,2,4
                  ~DEVICE,72,2,3
                  ~DEVICE,72,82,9,1
                  ~DEVICE,72,2,4


                  ~MONITORING,1,2
                  ~MONITORING,2,2
                  ~MONITORING,3,1
                  ~MONITORING,4,1
                  ~MONITORING,5,1
                  ~MONITORING,6,1
                  ~MONITORING,8,1
                  ~MONITORING,9,1
                  ~MONITORING,11,1
                  ~MONITORING,12,1
                  ~MONITORING,14,1
                  ~MONITORING,16,2
                  ~MONITORING,17,1
                  ~MONITORING,18,1
                  ~MONITORING,19,2
                  ~MONITORING,20,2
                  ~MONITORING,21,2
                  ~MONITORING,22,2
                  ~MONITORING,23,1
                  ~MONITORING,24,2
                  ~MONITORING,25,1

                  Comment


                    #10
                    Very weird. Mine never reports the Press in Telnet, even with full monitoring. Is yours Inclusive or Essentials (I am only Essentials)? Is your keypad a hybrid or just keypad (This is just a keypad)? I wonder what is different. This is what I see:
                    GNET> ?MONITORING,255
                    ~MONITORING,1,2
                    ~MONITORING,2,2
                    ~MONITORING,3,1
                    ~MONITORING,4,1
                    ~MONITORING,5,1
                    ~MONITORING,6,1
                    ~MONITORING,8,1
                    ~MONITORING,9,1
                    ~MONITORING,11,1
                    ~MONITORING,12,1
                    ~MONITORING,14,1
                    ~MONITORING,16,2
                    ~MONITORING,17,1
                    ~MONITORING,18,1
                    ~MONITORING,19,2
                    ~MONITORING,20,2
                    ~MONITORING,21,2
                    ~MONITORING,22,2
                    ~MONITORING,23,1
                    ~MONITORING,24,2
                    ~MONITORING,25,1
                    GNET> ~DEVICE,24,1,4
                    ~OUTPUT,19,1,1.00
                    ~OUTPUT,19,29,0
                    ~OUTPUT,19,30,1,1.00
                    ~OUTPUT,23,1,25.00
                    ~OUTPUT,23,29,0
                    ~OUTPUT,23,30,1,25.00
                    ~OUTPUT,22,1,80.00
                    ~OUTPUT,22,29,0
                    ~OUTPUT,22,30,1,80.00
                    ~DEVICE,24,81,9,1
                    ~DEVICE,24,85,9,0
                    ~OUTPUT,28,1,1.00
                    ~OUTPUT,28,29,0
                    ~OUTPUT,28,30,1,1.00
                    ~OUTPUT,32,1,50.00
                    ~OUTPUT,32,29,0
                    ~OUTPUT,32,30,1,50.00
                    ~OUTPUT,33,1,100.00
                    ~OUTPUT,33,29,0
                    ~OUTPUT,33,30,1,100.00
                    ~DEVICE,38,85,9,0
                    ~DEVICE,20,85,9,0
                    ~DEVICE,29,85,9,0
                    ~DEVICE,30,85,9,0
                    ~DEVICE,30,81,9,1
                    ~OUTPUT,42,1,11.00
                    ~OUTPUT,42,29,0
                    ~OUTPUT,42,30,1,11.00
                    ~DEVICE,20,81,9,1
                    ~DEVICE,29,81,9,1
                    ~DEVICE,38,81,9,1
                    ~DEVICE,39,81,9,1
                    ~DEVICE,39,85,9,0
                    ~DEVICE,44,81,9,1
                    ~DEVICE,44,85,9,0
                    ~DEVICE,49,81,9,1
                    ~DEVICE,49,85,9,0
                    ~DEVICE,50,81,9,1
                    ~DEVICE,50,85,9,0
                    ~OUTPUT,51,1,25.00
                    ~OUTPUT,51,29,0
                    ~OUTPUT,51,30,1,25.00
                    ~DEVICE,52,81,9,1
                    ~DEVICE,52,85,9,0


                    Comment


                      #11
                      Also, is your button a toggle or a single/multi-room scene? My button is a single/multi-room scene. Thanks for looking at it with me.

                      Comment


                        #12
                        I think it is toggle, can you try it with toggle, if this is the case I’ll change for Release 4 instead of Press 3 when I read the feedback. But will keep 3 for the action.

                        Comment


                          #13
                          Thank you. Reading the release would be very helpful! I tried a toggle button on a hybrid keypad and still no Press:
                          GNET> ~DEVICE,20,4,4
                          ~DEVICE,20,84,9,0
                          ~OUTPUT,40,1,0.00
                          ~OUTPUT,40,29,0
                          ~OUTPUT,40,30,1,0.00
                          ~OUTPUT,41,1,0.00
                          ~OUTPUT,41,29,0
                          ~OUTPUT,41,30,1,0.00
                          ~DEVICE,24,84,9,0
                          ~DEVICE,29,84,9,0
                          ~DEVICE,30,84,9,0
                          ~DEVICE,38,84,9,0
                          ~DEVICE,39,84,9,0

                          Comment


                            #14
                            What version of software do you use for Lutron Ra2

                            Comment


                              #15
                              Software is Ra 2 Essentials 12.9.0.

                              Comment

                              Working...
                              X