Announcement

Collapse
No announcement yet.

Magic Color Controllers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RK15 ok i am going to need you to send some command with Packet Sender. sorry to be a pain

    if works should set red to 100%
    packetsender -xtw 500 <bulb IP> 5577 "31 FF 00 00 00 00 F0 0F 2F"

    if works should set red to 100%
    packetsender -xtw 500 <bulb IP> 5577 "31 FF 00 00 00 F0 0F 2F"

    if works should set warm white to 100%
    packetsender -xtw 500 <bulb IP> 5577 "31 00 00 00 FF 00 0F 0F 4E"

    if works should set cool white to 100%
    packetsender -xtw 500 <bulb IP> 5577 "31 00 00 00 00 FF 0F 0F 4E"

    if works should set warm white to 100%
    packetsender -xtw 500 <bulb IP> 5577 "31 00 00 00 FF 0F 0F 4E"

    can you just tell me if any work, i suspect both 1, 3, 4 should work for you, if so will require one more bulb type to be created in app if none work then i think the v8 firmware will be offering something else additional and i will have to see if i can purchase a device. but i don't have the same available for same in the UK. I do have however

    https://www.amazon.co.uk/Equivalent-...agic+Home+Bulb

    which hopefully with a later version i may hit the same issue. but if you can let me know the results above before i purchase a bulb i don't need

    Comment


    • 31 FF 00 00 00 F0 0F 2F set red
      31 00 00 00 FF 0F 0F 4E set white

      Comment


      • I think by looking at the app the cool white is only red,blue,green on full

        Comment


        • Ok. It's late and I've finished for the night here butbut ba on those commands you've confirmed work. I need to recheck the logic as I believed this is what I was sending in the last beta. But will 100% check tomorrow morning. And let you know

          Comment


          • based on what you stated that the following commands worked.

            31 FF 00 00 00 F0 0F 2F set red
            31 00 00 00 FF 0F 0F 4E set white


            I have confirmed that when you have your device set to bulb, you 100% do actually send the command as per the above red command.

            I have release v1.0.0.302 that now includes a BulbRgbWarmwhiteCoolwhite, as i can see from other sources that there is now a need for that device type also. but i dont think this is for your bulb. but i also have introduced a delay between the colour and white commands in case that was causing issues. and i also have made it skip the white set if its current value is 0

            for testing can you ensure that in the Magic home app you set all the whites level to off and the red to about half. then start the plugin and wait for discovery, once that is finished, just set the red slider to Full, does this increase the brightness of the Red to Full? it 100% should do in my testing as it sends the exact red command above.

            after which try different combinations of colour or whites, or colour and whites. let me know your results

            Comment


            • have mode set for bulb and color sliders are working but if I turn on warn white it goes on but if I try to change the colors the bulb blinks and stay warn white I have to move warn white slider to 0 then change color and i have no cool white

              Comment


              • is there a way to link 2 bulbs together so u only need to change 1 bulb color and the rest will change.

                Comment


                • I keep getting these errors in log

                  Attached Files

                  Comment


                  • Yes I get the same issue. Simply put we attempted to send data and recieve a response. But the device failed to send any response. There's not much I can do other than downgrade it from an error to a debug log entry. These devices aren't the best bit they do work. But they don't always respond and you need multiple attempts to achieve a response

                    Comment


                    • these bulbs stop changings colors https://www.amazon.com/gp/product/B0...A2BM80QFXW4SS3
                      i have then set for BULBRGBWARNWHITECOOLWHITE any ideas.

                      Comment


                      • These should just be set to bulb i think

                        Comment

                        Working...
                        X