Announcement

Collapse
No announcement yet.

Events Not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    ocyberbum Just to let you know i haven't forgotten about you, work has been very busy of late. to prevent the need for me going back and forward, i have purchased a bulb to test directly against, so i should be able to get a handle on it quickly once it arrives tomorrow.

    Comment


    • #17
      ocyberbum I have just received the bulb and done some initial testing. My bulb is the same firmware and is exhibiting the same behaviour. I should be able to fix this in a new beta tomorrow

      Comment


      • #18
        Thanks Fuzzy, I appreciate the time and effort to help me... i was hoping you wouldn't have to purchase one but i know that has to make it simpler to fix, and there not bad lights for the price. After i get some of those bulbs installed around my house im looking at setting up a magiclight addressable led 65ft strip for the front of the house, they recommend the one below with the Alexa controller. I also added a link to the controller that looks like it would work with your plug in. The addressable Leds looks to have a lot of interesting effects.
        Then im hoping to get a hometroller +magichome plugin and some magichome RGBW controllers to setup some lights in my camper!!!

        https://www.superlightingled.com/201...on-p-2162.html

        controller
        https://www.superlightingled.com/122...nt-p-1194.html

        Comment


        • #19
          ocyberbum it seems that the cool white option on the bulb is what has thrown me, if its set to BulbRgbWarmhiteCoolwhite then i am sending a byte for the cool white channel. this is being rejected by the bulb as it does not accept the command.

          This bulb and most likely yours needs to be set to just bulb, then stop the plugin and delete the cool white device type (as cool white on these bulbs is just RGB all set to 100%) then restart the plugin. as soon as i did this my bulb works fine.

          please check yours is also the same.

          Comment


          • #20
            ok i followed the same instructions and everything seem to work until i turned the warm white on and then it stop working so im guessing the Cool and Warm white devices can not be used with Bulb type, I also see that if i select yellow in (colour) and try to dim it with slider above the colour it changes colors. If try to use the main pwr slider to dim the colour device it does nothing but off or on (no Dim). I can dim the prime colors RGB using there sliders if i pick R,G, or B in the colour. so if i select RED in the colour, i can go to the device Red and use that slider to dim it

            Comment


            • #21
              with the bulb only the Warm white or RGB can be used, not both at the same time. so if you set the warm white it will set all rgb channels to 0. this is a limitation of these bulbs.

              FYI to make things easier for you events to find out what the 2% dim of a specific colour is first select your colour e.g i select purple in the colour picker as below.

              Click image for larger version

Name:	Capture.PNG
Views:	40
Size:	29.2 KB
ID:	1295638

              if i then change the V value of the HSV to be 2 as highlighted this will provide the same colour at 2% brightness, this can be done from events and additionally the colour picker, i hope this helps you with events for specific brightness so you done need to select the colour and then change the brightness in the event.

              Click image for larger version

Name:	Capture.PNG
Views:	38
Size:	29.0 KB
ID:	1295639

              Comment


              • #22
                also worth noting that in this version i did improve the main dimming functionality

                Comment


                • #23
                  hey fuzzy i used that method on the device management, but i cant get my events to work even if i set it 100%
                  Attached Files

                  Comment


                  • #24
                    ocyberbum the MagicHome Beta has been updated to v1.0.0.336 which should fix your issue with events, i have also reworked the action slightly so it now keeps the colour selection when re-editing the rule.

                    Comment


                    • #25
                      Awesome... everything seems to be working with events and the dim trick makes things a lot easier since i don't need to add dim commands to my events. good thing i ordered 2 more bulbs today!! and i also ordered this kit below.. Fuzzy Do you think it will work good with your plug-in since it has a magic controller?

                      https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

                      Comment


                      • #26
                        ocyberbum Both the RGB and RGBW controllers from that link will work fine, for the RGB one, just set to Rgb, and the RGBW one just set to RgbWarmwhite.

                        I have both of those and they work well with the plugin,

                        you posted links to the addressable ones in post #19, these wont i think work, but i am ordering some from China to test against so i will get support added but it won't be straight away as the delivery from china takes 3-4 weeks.

                        Comment


                        • #27
                          The addressable ones im going to try and do in the next two or three months when the weather here gets a little warmer! so no problems waiting on that project while you do some testing. i'm going to add some more RGB bulbs around the house in the meantime. i have been looking at the same companies 80w flood light bulbs (link below) to put out back of my house/garage but im not sure if that would be worth the money or not ....but with your awesome plug in giving me more options... i got to pace myself to make sure i don't have to many projects for the budget!!!

                          https://www.amazon.com/gp/product/B0...0?ie=UTF8&th=1

                          Comment


                          • #28
                            Hey Fuzzy i was adding my 2 other bulbs today and they are working with the plug in but all bulbs after changing the color using the Event Colour picker for the new bulbs it gave me this error attached when i clicked submit
                            Attached Files
                            Last edited by ocyberbum; March 30th, 2019, 02:38 PM. Reason: all bulbs error on submit

                            Comment


                            • #29

                              Fuzzysb its been awhile and i have ordered more magiclights below and for some reason when i set the 1st bulb ex color post#28 FFFFFF it works fine, but if i add a 2nd bulb event ex #28 00bf5f or 3rd etc i get the page full of code and i have to go back to the event page and click on the Event label again (This one was St patricks day) for each one after that. The only time it gives me the code on any events is on the rgb light bulbs after i add the 2 or more commands. The RGB light stripes work perfect. Could you please take a look when you can i am ordering another 4 bulbs

                              Thanks

                              Comment


                              • #30
                                Will look at this when I return next week

                                Comment

                                Working...
                                X