Announcement

Collapse
No announcement yet.

mcsMQTT Plugin

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Michael McSharry View Post
    My mistake. I had the HS URL hard coded while testing remotely. Fixed it in 3.0.9.2 to connect to localhost.
    This fixed it for me.
    Thank you!
    https://forums.homeseer.com/forum/de...plifier-plugin

    Comment


      [qoute]Here only see mcsMQTT version .91 in the updater for Linux.[/quote]

      Probably a browser refresh or similar issue. The updater control file has 3.0.9.2.

      Comment


        Originally posted by Michael McSharry View Post
        I deleted my HSPI_mcsMQTT.exe and this allowed me to use updater to install it again. It installed and then when I started it everything was as expected. I suggest trying again and if you have an issue then confirm it is exactly the same issue that was posted.
        I deleted HSPI_mcsMQTT.exe , i am able to install the plugin but it does not start.

        When i wrote this message, I able to install it before too. But was not able to start it..(pending)

        edit: restarted HS3 and it is ok now
        Last edited by MattL0; March 22, 2018, 08:29 PM.

        Comment


          Originally posted by Summerguy View Post
          I deleted HSPI_mcsMQTT.exe , i am able to install the plugin but it does not start.

          When i wrote this message, I able to install it before too. But was not able to start it..(pending)

          edit: restarted HS3 and it is ok now
          Question: Do you have the 'Load plug-ins in the background on startup' under the Labs tab disabled?
          RJ_Make On YouTube

          Comment


            I have only Export to JSON and Import from JSON lines on my Labs tab

            Comment


              Page refreshed fine a bit ago and updated fine here.

              I did post under the HS3 beta section that it appeared that the updater wasn't working correctly earlier today.

              [ATTACH]67335[/ATTACH]

              Mar-08 6:50:42 PM Updater Install/Update of package mcsMQTT was successful.
              Mar-08 6:53:20 PM Plug-In Finished initializing plug-in mcsMQTT
              Mar-08 6:53:20 PM Info Plugin mcsMQTT has connected. IP:127.0.0.1:41650
              Mar-08 6:53:20 PM Starting Plug-In Initializing plugin mcsMQTT ...
              Mar-08 6:53:20 PM mcsMQTT Version 3.0.9.2 Registered with Homeseer
              Mar-08 6:53:23 PM Starting Plug-In Plugin mcsMQTT started successfully in 3115 milliseconds
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
              HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
              Fanless IntelĀ® Celeron N3160 SoC 8Gb
              HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
              HSTouch on Intel tabletop tablets

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

              Comment


                I have only Export to JSON and Import from JSON lines on my Labs tab

                This is what I see running HS3 V.423 these days. I have not had issues with V.423 running in Ubuntu Linux.

                [ATTACH]67336[/ATTACH]

                One of a general plugin issue that has cropped up is lingering plugins running after Homeseer is shut down.

                Tested here and the mcsMQTT is shutting down properly after shutting down Homeseer. Used HTop to test.
                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
                Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
                HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
                Fanless IntelĀ® Celeron N3160 SoC 8Gb
                HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
                HSTouch on Intel tabletop tablets

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                Comment


                  It is enable.

                  Comment


                    I'm running 3.0.92 and I see 3.0.94 is available. Even though it looks like 3.0.94 installs the updater keeps saying it's available. here is the log.

                    Mar-14 8:10:17 PM Starting Plug-In Plugin mcsMQTT started successfully in 33571 milliseconds
                    Mar-14 8:09:44 PM mcsMQTT Version 3.0.9.4 Registered with Homeseer
                    Mar-14 8:09:44 PM Starting Plug-In Initializing plugin mcsMQTT ...
                    Mar-14 8:09:44 PM Info Plugin mcsMQTT has connected. IP:127.0.0.1:39606
                    Mar-14 8:09:43 PM Plug-In Finished initializing plug-in mcsMQTT
                    Mar-14 8:09:26 PM Updater Install/Update of package mcsMQTT was successful.
                    https://forums.homeseer.com/forum/de...plifier-plugin

                    Comment


                      Also, I had to move my homeseer VM from Ubuntu to a new Lubuntu install (long story) but now mcsmqtt is complaining that my topic is already subscribed to.

                      How do I wipe everything and start over?
                      https://forums.homeseer.com/forum/de...plifier-plugin

                      Comment


                        The updater status display is not something I can control. As long as you are running the version you desire then that should be good enough. 3.10.10.0 was just uploaded with some nice features. Manual has not been updated yet.

                        Most information is contained in the HS Device PED with redundancy in the /data/mcsMQTT.db file. To start over you need to remove the mcsMQTT plugin devices either from Device Management of "A"ccept checkbox from mcsMQTT setup. You should also delete the database. You likely can delete all you backup databases in the same folder.

                        I do not know what you exact message is about subscriptions, but it may be associated with the Discovery radio option. I do not know if Mosquitto complains about being subscribed multiple times. I did not think it did. You may be able to get rid of the message by changing the radio button and then perhaps changing it back again.

                        Comment


                          I'm unable to get 3.0.10.0 installed, and I think the reason is that you have the wrong filename in your updater:
                          http://mcssprinklers.com/mcsMQTT_HS3.txt

                          Code:
                          mcsMQTT,HSPI_MCSMQTT.exe,,3.0.10.0,63,2,mcsSprinklers.com,,mcsMQTT_3_0_10.0.zip,4,Free,Michael McSharry,MCSMQTT,http://mcsSprinklers.com/MQTT.jpg,http://mcsSprinklers.com/HSupdater_mcsMQTT.htm,,
                          It's referring to http://mcssprinklers.com/mcsMQTT_3_0_10.0.zip, which gives a 404 not found. I think the correct URL is http://mcssprinklers.com/mcsMQTT_3_0_10_0.zip ...

                          Comment


                            Thank you. Fixed

                            Comment


                              Michael

                              Just upgraded to 3.0.10 from 3.0.9.. Starting the plugin I get 30-40 lines of:

                              Mar-15 15:49:08 mcsMQTT AddToMQTTSend Key= Line 0 Conversion from type 'DBNull' to type 'String' is not valid.

                              Windows 7

                              Pete
                              HS 2.2.0.11

                              Comment


                                Related to new fields being added to database, but I did not get the errors during my testing. I changed now to explicitly test for null fields and added a debug to isolate the problem field if it occurs again. In updater as version 3.0.10.1.

                                Comment

                                Working...
                                X