Announcement

Collapse
No announcement yet.

mcsMQTT Plugin

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Added feature in 3.4.13.0. Submitted to Updater and available at http://mcsSprinklers.com/mcsMQTT_3_4_13_0.zip. Opened discussion thread at https://forums.homeseer.com/forum/li...ing-hs-devices

    Comment


    • @Michael McSharry
      Thank you! I will test this tonight and report back.

      Cheers

      Comment


      • Any chance non-english letters would be supported in payloads? For example norwegian letters æ ø å becomes ?? in HomeSeer.

        Comment


        • See if the file at http://mcsSprinklers.com/HSPI_MCSMQTT34164.zip takes care of the issue. Before this it should have been handling the HS to MQTT publish, but was using ASCII for the MQTT to HS subscribe.

          Comment


          • Tnx, that solved my issue

            Comment


            • Have a new install, hoping to utilize the mcsMQTT plugin, running HS3 on the Troller Zee S2, and I built a Raspberry Pi 3 which is running the Mosquitto broker (and eventually his $10 USB stick). Mosquitto works internally to that broker system, can publish commands and subscribe session in same system receives it.

              Now trying to test publishing from the Broker Raspberry Pi system,
              over to the Homeseer Troller (with mcsMQTT plugin) with:

              pi@MQ_Broker:~ $ mosquitto_pub -h 10.89.1.172 -m "ON" -t test/topic
              Error: Connection refused

              Do I need to also install Mosquitto over in the Homeseer Troller system, for the plugin to pickup on this? Or is the plugin the code that is listening for the publication?


              Comment


              • Do I need to also install Mosquitto over in the Homeseer Troller system, for the plugin to pickup on this?

                no.

                The Homeseer 3 plugin running in Windows or Linux doesn't need anything else installed on the same machine.

                It is optional to install the Mosquitto broker on same said machine or any other machine. All you need to configure with the mcsMQTT plugin is the IP of the Mosquitto broker. If it is on the same computer then just utilize the loopback address: 127.0.0.1 for a broker IP.

                You can install the mosquitto broker on just about anything and it might be easier for you just to install it on the Zee2.

                Personally here have it installed on an RPi that was also a nodered, owfs, SDR Satellite NOAA mapper and ZNet like device.

                Moved it over to other devices which worked fine. Lightest device was an OpenWRT micro router which I am now using as a WAP just for SonOff firmware updated devices.

                I have read that historically there were issues running Mosquitto Broker on RPi Stretch..probably now fixed though.

                Here run it fine on Ubuntu 18.10 64 bit, RPi2 Stretch and Jessie and OpenWRT current release.

                Here moved my HS3 lite (Zee2) OS over to a Pine 64 2Gb computer a couple of years back and it runs better for me in Ubuntu 18.10 on Pine 64 computer than the RPi. That is me though.

                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                Comment


                • Only need and want mosquitto in one place. Since mosquitto_pub and mosquitto broker are on the same computer I do not think "-h 10.89.1.172" is needed. It should default to localhost. If the "-h" is included then it should be the IP of RPi/mosquitto broker.

                  When mcsMQTT is setup on the General Tab it will need the IP of RPi/mosquitto broker.

                  Comment


                  • I'm getting some action and history over in HS on the plugin side now. Let's see if I can configure that side correctly now. Thanks

                    Comment


                    • You can validate that it is working looking at the mcsMQTT tab called statistics.

                      Click image for larger version

Name:	stats.jpg
Views:	21
Size:	83.6 KB
ID:	1266656
                      - Pete

                      Auto mator
                      Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                      Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                      X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                      Comment


                      • Been tinkering with another application that runs in Linux called MQTT.fx. It provides a nice MQTT interface.

                        Click image for larger version

Name:	MQTT.jpg
Views:	24
Size:	83.1 KB
ID:	1266661

                        The Homeseer 3 mcsMQTT interface works great for this stuff and is really quick.

                        Click image for larger version

Name:	mcsMQTT.jpg
Views:	20
Size:	117.3 KB
ID:	1266662
                        - Pete

                        Auto mator
                        Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                        Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                        X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                        Comment


                        • I am messing around with mcsMQTT and Zigbee2mqtt and a GE Link Bulb. I got HS3 to control the bulb by changing the "Encode Payload per template:" to "{"state":"$$STATUS:","brightness":"$$VALUE:"}". If I reboot the HS3 computer or disable/enable the mcsMQTT plugin, the "Encode Payload per template:" changes itself to "{^2state^2:^2$$STATUS:^2,^2brightness^2:^2$$VALUE:^2}". I can manually change it back and it works until the next reboot or disable/enable. Thanks for the Zigbee2mqtt USB adapter. (My head hurts but it works = So cool!!)

                          Comment


                          • I believe this was corrected in http://mcsSprinklers.com/mcsMQTT_3_4_17_0.zip. All you need from the zip is the HSPI_mcsMQTT.exe to replace the same file in the HS3 folder.

                            Comment


                            • Thanks Michael! I upgraded to v3.4.17.0 but the "Encode Payload per template:" still changes itself to "{^2state^2:^2$$STATUS:^2,^2brightness^2:^2$$VALUE:^2}". I tried to "Delete the Sub Topic" and recreate it but the payload template still changes on reboot. What is the best way to keep mcsMQTT on the current version? Thanks again!

                              Comment


                              • I normally put the current version in the Homeseer Updater, but I was waiting for some feedback and then forgot.

                                I looked at the source and it all looks good to handle the quote in the database with use of ^2 as a replacement.

                                I recompiled to just make certain. It is attached. If this does not work for you then I will setup a test environment.
                                Attached Files

                                Comment

                                Working...
                                X