Announcement

Collapse
No announcement yet.

"Color picker" support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I guess not - I assumed updating the plugin actually started running the updated version. Manual stop/start definitely had an impact.

    Unfortunately, the first observation is it appears to have orphaned the devices it previously created. In the setup, their associate boxes are unchecked, and checking them created a second identical-looking device.

    Next was it didn't appear to like that debug was enabled and there was already a debug text file. Restarted the plugin a couple times and still only had the tail from the shutdown in it. Renamed that file then restarted and it seemed happy again.

    So, I'm now seeing a hex color on the left side of the device, but it doesn't change when I make a change with the color picker. It appears that the STRING is being set on device creation, but not updated when the VALUE changes, which seems to be working as intended. Progress?

    Attached image shows after the debug log below.

    Code:
    6/28/2018 11:49:00 AM   585627  | SetIOMulti 758, oCAPI.ControlType=Color_Picker
    6/28/2018 11:49:00 AM   585632  | Update Accepted 758 to ##FFFFFF StatusType=5
    6/28/2018 11:49:00 AM   585653  | Updating Device from 16711680 PayloadNumeric=False
    6/28/2018 11:49:00 AM   585656  | RGB ##FFFFFF is not valid format, saved as 0
    6/28/2018 11:49:00 AM   585663  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/rgb/set,Payload=##FFFFFF
    6/28/2018 11:49:00 AM   585689  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/rgb,Payload=#000000
    6/28/2018 11:49:00 AM   585747  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/hsv,Payload=0,0,0
    6/28/2018 11:49:00 AM   585805  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/brightness,Payload=255
    6/28/2018 11:49:00 AM   585863  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/mired,Payload=153
    6/28/2018 11:49:00 AM   585872  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/0,Payload=0
    6/28/2018 11:49:00 AM   585880  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/1,Payload=0
    6/28/2018 11:49:00 AM   585888  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/2,Payload=0
    6/28/2018 11:49:00 AM   585895  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/3,Payload=212
    6/28/2018 11:49:00 AM   585902  | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/4,Payload=0
    Attached Files

    Comment


    • #17
      I just noticed the apparent error in the debug log about ##FFFFFF not valid format. I presume that's just a corner case as other colors seem to not have that particular error, but have the same result in the UI.

      Code:
      6/28/2018 12:13:03 PM   2029028 | SetIOMulti 758, oCAPI.ControlType=Color_Picker
      6/28/2018 12:13:03 PM   2029032 | Update Accepted 758 to #7fff00 StatusType=5
      6/28/2018 12:13:03 PM   2029039 | Updating Device from 16320777 PayloadNumeric=False
      6/28/2018 12:13:03 PM   2029041 | RGB #7fff00 saved as 8388352
      6/28/2018 12:13:03 PM   2029045 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/rgb/set,Payload=#7fff00
      6/28/2018 12:13:03 PM   2029090 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/rgb,Payload=#7FFF00
      6/28/2018 12:13:03 PM   2029145 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/hsv,Payload=90,100,100
      6/28/2018 12:13:03 PM   2029200 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/brightness,Payload=255
      6/28/2018 12:13:03 PM   2029255 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/mired,Payload=153
      6/28/2018 12:13:03 PM   2029260 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/0,Payload=127
      6/28/2018 12:13:03 PM   2029265 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/1,Payload=255
      6/28/2018 12:13:03 PM   2029270 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/2,Payload=0
      6/28/2018 12:13:03 PM   2029276 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/3,Payload=212
      6/28/2018 12:13:03 PM   2029281 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/4,Payload=0
      Attached Files

      Comment


      • #18
        Note your external device is returning a double # prefix for the selected color. I suggest you fix it at the sending device. This could affect other MQTT devices that are subscribed to the topic. I will make mcsMQTT more tolerant of bad format and use the last six characters. This is 3.4.5.4 in the updater.

        Just noticed your second post where you had recognized the ##
        RGB #7fff00 saved as 8388352 in the debug shows what mcsMQTT is putting in DeviceValue. When I do this on my system it shows properly in the color picker control as I showed earlier. I will try a test on Linux to see how it works there.

        I also noticed that your device has the DeviceString with a pattern. This should be blank. I will force it blank in 3.4.5.4.

        Comment


        • #19
          Curious about the ##FFFFFF, got two different results when simply clicking OK after popping up the color picker vs picking a color but leaving the slider so it was still white.

          (edit) - Added attachments to show it initially has a # prefix and all caps FFFFFF in the picker box, then once you click on a color (but the result is still white), it changes to lowercase ffffff without the leading #

          Code:
          6/28/2018 1:15:25 PM    5771354 | SetIOMulti 758, oCAPI.ControlType=Color_Picker
          6/28/2018 1:15:25 PM    5771359 | Update Accepted 758 to #ffffff StatusType=5
          6/28/2018 1:15:25 PM    5771372 | Updating Device from 8388352 PayloadNumeric=False
          6/28/2018 1:15:25 PM    5771375 | RGB #ffffff saved as 16777215
          6/28/2018 1:15:26 PM    5771381 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/rgb/set,Payload=#ffffff
          6/28/2018 1:15:26 PM    5771417 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/rgb,Payload=#FFFFFF
          6/28/2018 1:15:26 PM    5771474 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/hsv,Payload=0,0,100
          6/28/2018 1:15:26 PM    5771532 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/brightness,Payload=255
          6/28/2018 1:15:26 PM    5771589 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/mired,Payload=153
          6/28/2018 1:15:26 PM    5771597 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/0,Payload=255
          6/28/2018 1:15:26 PM    5771604 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/1,Payload=255
          6/28/2018 1:15:26 PM    5771611 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/2,Payload=255
          6/28/2018 1:15:26 PM    5771619 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/3,Payload=212
          6/28/2018 1:15:26 PM    5771626 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/4,Payload=0
          6/28/2018 1:15:36 PM    5782374 | SetIOMulti 758, oCAPI.ControlType=Color_Picker
          6/28/2018 1:15:37 PM    5782378 | Update Accepted 758 to ##FFFFFF StatusType=5
          6/28/2018 1:15:37 PM    5782390 | Updating Device from 16777215 PayloadNumeric=False
          6/28/2018 1:15:37 PM    5782399 | RGB ##FFFFFF is not valid format, saved as 0
          6/28/2018 1:15:37 PM    5782408 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/rgb/set,Payload=##FFFFFF
          6/28/2018 1:15:37 PM    5782435 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/rgb,Payload=#000000
          6/28/2018 1:15:37 PM    5782493 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/hsv,Payload=0,0,0
          6/28/2018 1:15:37 PM    5782550 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/brightness,Payload=255
          6/28/2018 1:15:37 PM    5782608 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/mired,Payload=153
          6/28/2018 1:15:37 PM    5782615 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/0,Payload=0
          6/28/2018 1:15:37 PM    5782623 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/1,Payload=0
          6/28/2018 1:15:37 PM    5782630 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/2,Payload=0
          6/28/2018 1:15:37 PM    5782638 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/3,Payload=212
          6/28/2018 1:15:37 PM    5782645 | ActoOnMessageFor Trigger Topic ESPURNA_BASEMENT/channel/4,Payload=0
          Attached Files
          Last edited by mattster98; June 28th, 2018, 12:25 PM. Reason: Added attachments for clarity

          Comment


          • #20
            If you look at the statistic tab for Last Published topic you can see exactly what mcsMQTT is publishing. The debug "updated accepted ..." is what mcsMQTT is receiving from the broker. The SetIOMulti in the debug is when HS color picker has been used and mcsMQTT is going o publish.

            Should transition to 3.4.5.4 so you are working with the latest plugin.

            Comment


            • #21
              I'm not yet seeing an update available - still current on 3.4.5.2

              Comment


              • #22
                I missed your post last week. I observe the same thing with the updater. Perhaps HST has transitioned to only doing internally managed plugin uploads. When this process started I had some questions that never got answered and did not follow-up. I will need to get back with them.

                The zip file is at http://mcsSprinklers.com/mcsMQTT_3_4_5_4.zip. When plugin is not running unzip the .exe to the HS folder. Reenable the plugin.

                Comment


                • #23
                  thanks for adding this, it is working with my magichome rgbw devices. one thing i cant make work is alexa support. has anyone tried this?
                  HS3 Pro on Windows 8 64bit
                  53 Z-wave nodes(46 devices, 7 remotes), 15 DS10a's, 10 ms16a's, 9 Oregon Sensors, W800, RFXCOMtrx433, Way2Call, 3 HSTouch Clients, 2xRussound CAS44, Global Cache GC100-12,10 Rollertrol blinds(+ zwave) ,3 Squeezebox Radios and 1 Squeezebox Boom,DMX Arduino via ethernet,Rain8Net,3x Echo Dot's


                  Check out my electronics blog here:
                  https://www.facebook.com/RaptorsIrrationalInventions

                  Comment


                  • #24
                    Originally posted by Raptor View Post
                    thanks for adding this, it is working with my magichome rgbw devices. one thing i cant make work is alexa support. has anyone tried this?
                    I have this working, but not the way you would think, i just untick the voice option of the devices and then load the Magic home alexa skill, i do this for all the thermostats, Hue and Magic home devices, that way i can control from Homeseer, but the alexa skill also works, and like what happened yesterday, my homeseer install stopped working after a windows update killed it, and my automations stopped, but i could at the every least control the lights via voice. it is the best of both worlds IMHO

                    Comment


                    • #25
                      Alexa supports HUE protocol such as done with Phillips and Tasmota firmware. I have used Alexa with MagicLight bulbs (RGBW) with things such as "Alexa, turn den light blue". I have older UPB lighting which I do Alexa On/Off control via HS. I have also used Alexa Routines to accept non-HUE/Wemo verbage to give the desired control (e.g. "Alexa, close garage door"). Are MagicHome devices directly Alexa compatible?

                      Comment


                      • #26
                        Sorry forgot to specify, im using magichome hardware with Tasmota firmware, but i can't get the color picker device in homeseer to appear in alexa, was there a trick to it?
                        HS3 Pro on Windows 8 64bit
                        53 Z-wave nodes(46 devices, 7 remotes), 15 DS10a's, 10 ms16a's, 9 Oregon Sensors, W800, RFXCOMtrx433, Way2Call, 3 HSTouch Clients, 2xRussound CAS44, Global Cache GC100-12,10 Rollertrol blinds(+ zwave) ,3 Squeezebox Radios and 1 Squeezebox Boom,DMX Arduino via ethernet,Rain8Net,3x Echo Dot's


                        Check out my electronics blog here:
                        https://www.facebook.com/RaptorsIrrationalInventions

                        Comment


                        • #27
                          I don't think you can get the color with Alexa yet, what I have done is set up events to change the color and then use Alexa's routines to fire those events. Works basically the same after setup as you only get certain colors in Alexa anyway. Using Espurna for all my Magic Home controllers (28 now) I like that firmware for Led controllers as the web interface has a color picker incuded, so that helps somewhat.

                          John

                          Comment

                          Working...
                          X