Announcement

Collapse
No announcement yet.

Revisiting SonOff Basic firmware updates

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Revisiting SonOff Basic firmware updates

    Just a separate post here relating to the SonOff basic Wifi Modules.


    Over the last week here updated 2 SonOff 4 Channel Pro's sent to me by a HomeSeer user.

    Updated them and

    Tested them online for one day and they worked fine.

    I left two SonOff WiFi basics online and had configured them via DHCP reservation.

    One was updated via OTA and the other was updated via a serial JTAG connection. Checked them for a few days and all was well.

    Attached is also an early firmware V1.5 for the Sonoff basic wifi switch, dual switch and temperature sensor.

    Yesterday noticed that the two remained as clients connected to my test AP and saw them on the PFSense box but I could not ping them or get to the GUI.

    I unplugged both of them and plugged one in. It came up fine and I could get to the GUI. Updated the Bin file then a few hours later it appeared to drop off the network but remained in the client list under DHCP reservation and I saw the MAC address up in the wifi client list on the AP.

    Now revisiting the two of the SonOff basics via the serial connection.

    11th of June, 2018
    AM
    1 - connected JTAG / enabled minicom
    2 - watched communications - see it connecting, see it getting a DHCP address - cannot ping or go to web gui
    3 - uploaded a basic wifi switch sketch - configured for AP - worked fine
    4 - uploaded basic boot bin V1.5 from SonoffWifiSmartModule dot zip below
    5 - uploaded mcs.bin
    6 - reboot and connected to AP, got a DHCP address, able to ping IP and go to web gui
    7 - first one worked with .12 bin and second one did not.

    PM
    1 - first one from this morning was offline in the afternoon (frustrating)
    2 - redid them both except brought to V.11 and duplicated AP information on second settings.
    3 - push button tab came off while putting the cover on one. Easy to set in place with a tiny screwdriver pushing on the tabs.
    3 - Both worked and working now for about 1 hour.

    Did the above for two WiFi basic Sonoff switches.

    Left the two plugged in for time bean.

    12th of June, 2018
    AM
    1 - Two SonOff wifi basics up and running on second day. Configured both of them for DHCP reservation.
    2 - Using May, 2018 v.11 bin file as earlier update to v.12 took the two devices off line after a bit.

    13th of June, 2018
    PM
    1 - Two SonOff Wifi basics online
    2 - move the two over to another WAP, unplugged them and plugged them in again and both came on line just fine.
    Attached Files
    Last edited by Pete; June 13th, 2018, 02:51 PM.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel CPU - Mono 5.20
    Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e BeeLink 4Gb BT3 Pro - Mono 5.20

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

  • #2

    Comment


    • #3
      Thank you Michael.

      Why do you have so many images posted?



      Just thought (5.9.12) it was some sort of issue with the firmware of the radio which I was trying to change with the variety of images posted. None of them did anything to the radio firmware that I could see. BUT they did always connect to the WAP. I couldn't even talk to the ITEAD radio firmware with the Arduino IDE application. I did read about some deep sleep state switch in the INO configuration relating to the SonOFF stuff.

      Did you test utilize 5.9.12 firmware? Did it connect to the WAP for you?

      For Don's two SonOff Pro's never did the serial thing with them. Just the OTA and the update to V.5.9.11. Did not configure the Mosquitto stuff on these and was looking for a stable WAP connection which worked with 5.9.11.

      Moving from V5.9.11 to V.5.9.13 is working fine.

      V.5.9.12 did not work. It would hang trying to connect to WAP. Well and you could tell without a serial connection just watching the LED blinking. When I used the older SonOff or Tasmota IDE's modded with my WAP stuff it did connect right away editing the INO file with my WAP information.

      This could have been also that I didn't configure the Mosquitto broker connection until it sat for a few days.

      Been working very well with no issues connecting to the WAP. Unplugged it and plugged it in a few times and always connecting now. Making changing, saving changes, restarting device always connects.

      Before configuring it in the garage and putting it above the GDO yesterday installed a 1-wire temperature sensor using VCC, Ground and GPIO 14. Console shows a sensor trying to connect but I get no value on the main page of the Tasmota GUI BUT I have not installed a resistor on it. I have a few old Midon boards purchased a few years back with only temperature sensors on them. Easy connect to the SonOff device.

      [ATTACH]69408[/ATTACH]

      and looking to test a GPIO connection to a tiny PIR. Never have had good luck though with the PIR in the garage during the summer. Just a tinkering experiment here.

      [ATTACH]69409[/ATTACH]

      Trying a 1-wire DS18S20 temperature sensor with a 10k Ohmn pull up resistor.

      [ATTACH]69412[/ATTACH]

      00:00:06 APP: (UTC) Mon Jun 18 16:50:49 2018
      00:00:06 APP: (DST) Sun Mar 25 02:00:00 2018
      00:00:06 APP: (STD) Sun Oct 28 03:00:00 2018
      17:50:50 MQT: GarageDoor1/POWER = On
      17:50:57 MQT: GarageDoor1/STATE = {"Time":"2018-06-18T17:50:57", "Uptime":0 0, "Vcc":3.499, ....
      17:50:57 MQT: GarageDoor1/Door = INDETERMINATE
      17:50:57 HTP: Main Menu
      17:50:58 DSB: Sensor CRC error
      17:51:00 HTP: Console
      17:51:07 WIF: Checking connection...
      17:51:07 WIF: Connected

      Got it...I had connected the 1-wire ground wire to the serial pin.

      Temperature is off maybe cuz I am using a 10k versus a 4.7k pull up resistor.

      [ATTACH]69413[/ATTACH]
      Last edited by Pete; June 18th, 2018, 12:27 PM.
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel CPU - Mono 5.20
      Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e BeeLink 4Gb BT3 Pro - Mono 5.20

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

      Comment

      Working...
      X