Announcement

Collapse
No announcement yet.

SonOff WiFi basic firmware 5.9.13g mcsMQTT Version 3.4.11.0

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SonOff WiFi basic firmware 5.9.13g mcsMQTT Version 3.4.11.0

    This Sonoff device has been left in place and working fine now for over a month or two. I updated mcsMQTT to version Version 3.4.11.0 last week.

    This morning updated computer (Ubuntu updates) and rebooted the server restarting HS3. Noticed a couple of issues which I cannot figure out.

    I have attached open and closed garage door sensors and mosquitto status has alway been open, closed and intermediate.

    This morning I see open, closed, intermediate and open&closed variable payloads which triggers the open garage door event ever 2 minutes or so.

    Click image for larger version  Name:	oopenandclosed.jpg Views:	1 Size:	13.3 KB ID:	1253143

    Never have seen an open&closed payload before. This is causing the garage door open event to trigger.

    Click image for larger version  Name:	VSP.jpg Views:	1 Size:	51.4 KB ID:	1253144

    Partially opened garage door and it shows correct status of INTERMEDIATE.

    Opening the garage door never shows OPEN and stays at INTERMEDIATE

    Closing garage door never shows CLOSED and shows OPEN&CLOSED.

    Looks almost as if the Sonoff Wifi basic firmware is scrambled some. I powered on and off device and rebooted it and see nothing in the console.

    Note here I have not touched the SonOff WiFi basic and have left it in place connected to the two reed sensors.

    Looked at the SonOff wifi console and see nothing there which is odd. Nothing=> no verbiage.

    Could my SonOff Wifi Module be an issue now? Temperatures here have dropped to freezing.

    I have restarted it a couple of times now and the up time status never changes.

    Removed it this morning, disconnecting the sensors and will put it on the workbench to see what is going on.

    Wierd cuz it's been fine now for a long time.

    Figured it out on the workbench.

    1 - tested shorting out one GPIO and ground - seeing console show closed
    2 - tested shorting out another GPIO and ground - seeing console show open
    3 - tested not connecting any GPIO to ground - shows intermediate
    4 - tested showing both GPIO pins to ground - shows open&closed and no console verbiage.

    Next checking the reed sensors with a VOM.

    Both of the reed sensors on the garage door appear fine. Wondering if one of them got stuck in the closed position making both of them closed and that messaging open&closed and shutting off the console?

    Disconnected the current glued on DS18B20 sensor replacing it with another DS18B20 sensor and glued another 3 terminal gizmo on the case.

    Synopsis of issue and not related to firmware or current version of plugin.

    - both reed switches had remained in the closed position creating a new message "open&closed"
    - this in turn disabled console messages (IE: both GPIO pins to ground).

    xxxxxxx
    Last edited by Pete; October 14th, 2018, 11:46 AM.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel CPU - Mono 6.00
    Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e BeeLink 4Gb BT3 Pro - Mono 6.00

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

  • #2
    This is indicating that both your door position sensors are active. Normal states are [one active, one inactive] or in the case the door is moving then [both are inactive]. My first guess is that the wiring to the sensor or pull-up resistor has come undone. Another thought is that serial logging has not been turned off when GPIO1 or 3 are being used for sensors rather than TX/RX. I think the browser console command is "SerialLog off"

    Comment


    • #3
      Thank you Michael.

      Configuration:

      GPIO 3 - 57 Door Closed

      GPIO 4 - 56 Door Open

      No pull up resistors here has worked fine now for a couple of months.

      These are using 22/2 to 22/4 wires soldered and heat shrinked to over the GDO where two wires are twisted together and all wires are tinned.

      This is parallel to two commercial style garage door sensors which also go to 22/4 wire back to the alarm panel zones.

      Looks like a reed sensor got stuck in NC mode such that both sensors were grounded and this caused the console not to display.

      When I removed the Sonoff from the top of the garage door opener and disconnected the two reed sensors and plugged it back in all appeared normal.

      On the workbench testing no connectivity between ground and GPIO3 and GPIO4 and it showed INTERMEDIATE
      Testing GPIO3 to ground and GPIO4 to ground showed OPEN and CLOSED like it used to.
      Testing GPIO3 and GPIO4 to ground showed "OPEN&CLOSED" messages and no console verbiage.

      GPIO 14 for the DS18B20 sensor does use a pull up resistor between DQ and VCC and that has worked fine.

      While it was on the workbench here pulled off the old Ardunio 18B20 board which never did show accurate temperatures and install an older AAG 18B20 temperature sensor on it. Working well and the temperature is fine.

      I have wanted to do this for a while now but didn't feel like climbing up over the GDO to remove the Sonoff WiFi module. Never seen a reed sensor get stuck in the closed position. The two reed sensors are glued to the two garage door sensors and using massive magnets on the garage door.

      Wondering if that is due to the temperature changes here?

      Curious too why taking GPIO3 and GPIO4 to ground at the same time would disable the console messaging?

      I disabled the serial port logging as I am not using the RX/TX for serial communications.
      Last edited by Pete; October 14th, 2018, 02:36 PM.
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel CPU - Mono 6.00
      Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e BeeLink 4Gb BT3 Pro - Mono 6.00

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

      Comment


      • #4
        This problem brought to mind how our pipeline valves use limit switches for status and control with old dedicated RTUs, and later on PLCs.
        2 bit status was:
        Open 1 0
        Close 0 1
        Travel 1 1
        Error 0 0

        We did use some SPDT reed switches on deeply buried hydraulically operated valves. These were mounted above ground on the valve stems.
        Generally the problem with these switches was either shifted out of position, or cracked glass.

        Comment


        • #5
          No harm done here as the testing system parallels the wired to the alarm panel system and the open and close of the garage door is not automated. The wired system is using 2 commercial style NC/NO switches (3 wires) and I created a wired loop such that it only works one way or another.

          Newest GDO wiring saftey stuff is autonomous from add ons. Concurrent and before this happened the MyQ Chamberlain receiver logic board went out.

          Initially did the diagnostic stuff then called customer service who blamed my LED lighting (now two years working) RF causing the board to disfunction? What a joke.

          It appears that the increase in prices now relate to technology while concurrently the build of these devices is garbage these days.

          The old style physical button 2 wire GDO open close switch has been replaced now with a 2 wire digital signal for better security?

          Will never take remote control of the GDO to the cloud any how. Works fine here via VPN these days.

          Warranty is only a year on the Chamberlain logic board and all of the electronics except for a 6 year warranty on the motor.

          Testing the bad board it appears to have a bad solder or crack in it that I cannot see or fix. Never had any issues with old Liftmaster / Sears Craftman GDO of old.

          It was an easy fix to swap in a new board. It was a PITA to manually work the garage door for a few days.

          No local dealers would sell me a board and I would have waited about a week for an appointment such that I ordered the board 2 day UPS which took more like 4 days to get here.

          Did update (unrelated/related) water shutoff switch modernized with limit switches (wired to panel) a few years back.

          I quit automating the GDO stuff in the 1990's due to a WAF gotcha. Wife pulled in to the detached garage one day while on a cellular conference call. She sat in the car while it was still running while the automation shut the garage door after a few minutes automagically.
          Last edited by Pete; October 17th, 2018, 07:30 AM.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel CPU - Mono 6.00
          Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e BeeLink 4Gb BT3 Pro - Mono 6.00

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

          Comment

          Working...
          X