Announcement

Collapse
No announcement yet.

Zigbee2MQTT on Windows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Michael McSharry
    replied
    In the configuration.yaml file you can explicitly specify the log file such as
    Code:
    advanced:
      log_directory: c:\temp
    The default location for it (log.txt) is the log subfolder of the data folder where you have configuration.yaml. Multiple subfolders and files are created to keep a fully history.

    When I have new device I run from command prompt rather than as an autostart so that I can see the traffic. I started with a Iris 3326-L motion sensor and the difficulty I had was getting it to pair. I started a github thread and others chimed in and the device is now supported. It is at a different location so I am not able to verify.

    Leave a comment:


  • ServiceXp
    replied
    Ok, I got everything setup and running on Friday, with no devices. I cannot figure out how to add a 0388557 Iris motion sensor. There are several places where the instructions refer to a log file that will contain all connection information, but I can't find it for the life of me.

    I realize this motion sensor is not support, but everything I read indicates I should me able to see the connection information in some log...

    Any idea were I should look?

    Leave a comment:


  • ServiceXp
    replied
    Ian got me going with a signed driver that worked. I hope to move through the steps over the week end..

    Leave a comment:


  • Michael McSharry
    replied
    The zigbee2mqtt thread referenced in the first post has subsequent discussion including success by clockbrain. Perhaps you could engage in that discussion to get some help. Using a RPi for special purpose interfaces is also not a bad idea as most of the emerging HA world seems to be Linux based.

    Leave a comment:


  • ServiceXp
    replied
    I'm dead in the water, without a signed driver. Windows 10 will NOT allow an un-signed driver installation anymore. It appears they have removed every method of disabling the driver signing verification system.

    Ian PM'd me his driver, but it would not install for me. Has the same un-signed error as the original.

    Leave a comment:


  • Michael McSharry
    replied
    I added a 7a step to the instructions I posted at the top of this thread. I suspect it will help the problem Ian had, but not certain. I also sent Ian an email about the signed driver. Hopefully is listening in.

    Leave a comment:


  • ServiceXp
    replied
    Originally posted by IanIreland View Post
    With thanks to Mr Google and a little knowledge I now have a signed driver. If anybody else has the same problem give me a shout.
    I ran into the same problem... Giving you shout :-)

    Leave a comment:


  • oldmate95
    replied
    I ran into the same issue as IanIreland on Windows Server 2012 r2.

    I came across this thread (https://github.com/coreybutler/nvm-w...ment-340249164), so I tried the following:



    1. Installed nodejs LTS 10.15.0 x64
    2. Installed Git (x64)
    3. Created new registry dword32 for 'HKLM:\SYSTEM\CurrentControlSet\Control\FileSystem' -Name 'LongPathsEnabled' -Value 1
    4. Rebooted PC
    5. Opened a cmd & cd to c:\zigbee2mqtt
    6.Run command: npm i semver
    Some bits about node_modules flashed past, eventually semver was installed.
    The node_modules folder was then available inside c:\zigbee2mqtt

    7.Run command: npm start
    Zigbee looked like it started but spat out errors about resetting USB.
    I'm waiting for my ebay order of the CC USB, so I can't test any further past this point.

    This is my first time playing with any of the node.js etc stuff, so I don't have any idea of what I'm doing. Seems promising so far!
    Normally I wouldn't register to a forum just to post a reply, but I know how frustrating it is to find a forum thread with no answer to the problem you're having!

    Good luck all

    Leave a comment:


  • IanIreland
    replied
    Thanks for the reply. I will play when I have time. I may have to download again as I don't have that directory!!

    Leave a comment:


  • Michael McSharry
    replied
    my install on Windows has semver.cmd and semver.js at C:\opt\zigbee2mqtt\node_modules. I have not used node.js before so don't really know the process to debug based upon the error reported. Another idea is the PATH as I see you are using P rather than C. Another idea is to ask on the github link I posted at the top or start your own issue on that forum.

    Using Windows puts you on the road least traveled.

    Leave a comment:


  • IanIreland
    replied
    I am beginning to think this is more complex than I thought!
    Click image for larger version

Name:	js.PNG
Views:	510
Size:	22.9 KB
ID:	1268429

    Leave a comment:


  • IanIreland
    replied
    Superstar - thank you.

    Leave a comment:


  • Michael McSharry
    replied
    Here is my configuation.yaml file that I used for testing on Windows. In your case it would be COM6 rather than COM15

    # Home Assistant integration (MQTT discovery)
    homeassistant: false

    # allow new devices to join
    permit_join: true

    # MQTT settings
    mqtt:
    # MQTT base topic for zigbee2mqtt MQTT messages
    base_topic: zigbeeWindows
    # MQTT server URL
    server: 'mqtt://192.168.0.30'
    # MQTT server authentication, uncomment if required:
    # user: my_user
    # password: my_password

    # Serial settings
    serial:
    # Location of CC2531 USB sniffer
    #port: /dev/ttyACM0
    #port: TI CC2531 USB CDC
    port: COM15

    Leave a comment:


  • IanIreland
    replied
    I'm working through the instructions.

    In 6 how should the com port appear in the configuration file? I currently have;
    serial:
    # Location of CC2531 USB sniffer
    port: /dev/ttyACM0

    My com port is 6

    Leave a comment:


  • IanIreland
    replied
    With thanks to Mr Google and a little knowledge I now have a signed driver. If anybody else has the same problem give me a shout.

    Leave a comment:

Working...
X