Announcement

Collapse
No announcement yet.

Newbie Need help with iFan02 Mqtt

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newbie Need help with iFan02 Mqtt

    Hi

    FYI I mainly used Zwave but is giving sonoff a try and MQTT

    I have read the extensive manual and read most of the forum post but can't get the following to work. Any advice and help would be great

    Ifan02 has been flashed with tasmota and is working
    Michael plugins also working in HS3

    But i cannot get the ifan 02 to work


    the Sonoff config as attached


    If i use the following command in the sonoff console, everything works but not from HS3 MQTT

    Lounge/cmnd/Ifan/FanSpeed 0
    Lounge/cmnd/Ifan/FanSpeed 1
    Lounge/cmnd/Ifan/FanSpeed 2
    Lounge/cmnd/Ifan/FanSpeed 3

    Lounge/cmnd/Ifan/Power 0
    Lounge/cmnd/Ifan/Power 1

    I tried also mqtt.fx and MQTTLens without success

    How should i configure the Topics,sub and Pub??

    Cheers


  • #2
    I think the difficulty you are having is separation of the Topic from the Payload. Your HS Device Publish Topic should not have the " 3". If you want to send a payload of 3 then you will use the HS Device Management and enter the value of 3 for device 450. Setting the Device Value of Device 450 to 3 could also be done via event or script..

    If the numbers 0, 1, 2 and 3 have meaning such as Off, Low, Medium, High then you could also change how they appear in HS status by using either List or Button on the Edit tab for HS Device Conrol/Status UI. If you want 4 buttons then use Button. If you want a list selector then use List. For HS Device VSP List then enter Off=0<submit>, Low=1<submit> etc.

    I believe the default is that DeviceValue (0,1,2,3) will be in the payload. This can be explicitly specified on Edit tab for Publish Payload Template of $$VALUE:. Had you wanted the text rather than the number then it would be $$STATUS:. In your case you want a number going to ifan

    Comment


    • #3
      Originally posted by Michael McSharry View Post
      I think the difficulty you are having is separation of the Topic from the Payload. Your HS Device Publish Topic should not have the " 3". If you want to send a payload of 3 then you will use the HS Device Management and enter the value of 3 for device 450. Setting the Device Value of Device 450 to 3 could also be done via event or script..

      If the numbers 0, 1, 2 and 3 have meaning such as Off, Low, Medium, High then you could also change how they appear in HS status by using either List or Button on the Edit tab for HS Device Conrol/Status UI. If you want 4 buttons then use Button. If you want a list selector then use List. For HS Device VSP List then enter Off=0<submit>, Low=1<submit> etc.

      I believe the default is that DeviceValue (0,1,2,3) will be in the payload. This can be explicitly specified on Edit tab for Publish Payload Template of $$VALUE:. Had you wanted the text rather than the number then it would be $$STATUS:. In your case you want a number going to ifan

      Thanks for your reply . i will give it another go

      Comment

      Working...
      X