No announcement yet.

dropping decimal in HS3

  • Filter
  • Time
  • Show
Clear All
new posts

  • dropping decimal in HS3

    The MQTT Inbound subscription properly shows the value with the decimal however once device is created in HS3 the decimal value is dropped.

    How can I maintain the complete value as received by MQTT including decimals

  • #2
    Most likely because the HS Device Management setup for this device has specified 0 decimals. Look at Status Graphic tab for this device and you should see something like the attached where the decimal precision is specified as 1 Click image for larger version

Name:	Capture.PNG
Views:	27
Size:	23.6 KB
ID:	1281774


    • #3
      Hello Michael, thanks for the response. I have the decimal precision set as 1. The start and end values are defined differently but this should not matter... I think .


      • #4
        I see you are using Centigrade which means that the period likely not the decimal delimiter for your regional settings. Give it a try with regular expression on Edit tab to change the period to a comma. There is an example of this in the mcsMQTT.pdf document. I could also be related to how mcsMQTT handles comma/decimal internally, but let us try the easiest thing first.


        • #5
          the Centigrade is added by the Suffix. I am not doing any conversion at the payload level. If I remove the Suffix there is no difference and decimal value is not showing.
          The payload values shows correctly with the decimal for all payloads its only when displayed in HS3 it drops the decimal.

          Click image for larger version

Name:	5.PNG
Views:	27
Size:	45.3 KB
ID:	1281799

          I did the change as you suggested but still no love..

          Click image for larger version

Name:	6.PNG
Views:	28
Size:	25.5 KB
ID:	1281800


          • #6
            Michael, well looks like its working now. I've rebooted the HS3 and it took the update. Not sure if this update had some sort of fix for MQTT but all devices are now properly showing the decimal. No changes were made to the config. I've reverted the change in the above slide and all is good.

            Thank you as always for your prompt repose. I GREATLY appreciate it !!!