Announcement

Collapse
No announcement yet.

Cannot get Temp sign/Suffix to display in HS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot get Temp sign/Suffix to display in HS3

    Hi

    I am trying to get the Temp sign and humidity to display from Sonoff TH10 Mqqt in HS3 without any success

    I have read the previous post and followed what Michael suggested and still cant get the Temp or any Suffix to display
    Any help would be great

    Click image for larger version

Name:	Mqtt temp.JPG
Views:	8
Size:	26.8 KB
ID:	1281867

    Click image for larger version

Name:	Mqtt temp1.JPG
Views:	7
Size:	201.6 KB
ID:	1281868Click image for larger version

Name:	Temp1.JPG
Views:	10
Size:	52.4 KB
ID:	1281865Click image for larger version

Name:	Temp.JPG
Views:	12
Size:	30.3 KB
ID:	1281864Click image for larger version

Name:	Temp3.JPG
Views:	14
Size:	106.2 KB
ID:	1281866

  • #2
    On the Edit tab change the Control/Device UI from Text to Number. When text it is stored in DeviceString. When Number it is stored in DeviceValue. Assure that your incoming payload has numbers and not stuff formatted with suffix etc. Use regular expression on Edit tab if you need to clean it up. The one payload you showed looked to be a number, but mcsMQTT likely saw something in the past that was not a number and that is why it selected text.

    Comment


    • #3
      Originally posted by Michael McSharry View Post
      On the Edit tab change the Control/Device UI from Text to Number. When text it is stored in DeviceString. When Number it is stored in DeviceValue. Assure that your incoming payload has numbers and not stuff formatted with suffix etc. Use regular expression on Edit tab if you need to clean it up. The one payload you showed looked to be a number, but mcsMQTT likely saw something in the past that was not a number and that is why it selected text.
      Thanks Michael

      Really appreciate

      Comment

      Working...
      X