Announcement

Collapse
No announcement yet.

Using ":" in topic messages changed to "%3A"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using ":" in topic messages changed to "%3A"

    I am using this plugin for a couple of month now and I really like it.

    I upgrade the plugin tonight and found that something is working different now. I am using a MQTT to ESP-now gateway and use mac-addresses in topics.
    This used to work without any problem. After upgrading to the latest version this does not work anymore.
    With old version (3.4.7.0) the topic being published: espnowgw1/30:AE:A4:CF:38:6C/updatefreq
    With new version the topic looks like this: espnowgw1/30%3AAE%3AA4%3ACF%3A38%3A6C/updatefreq

    Is this something I can change in a setting?

    Many thanks for this great plugin.

  • #2
    This was done to have a standard URI encoding. I was concerned that it may cause some issues.

    The last version before this change was made is 3.4.17.4 which can be obtained at http://mcsSprinklers.com/mcsMQTT_3_4_17.4.zip

    I suspect I will be adding a config option as different users have different perspectives on encoding. In the mean time you can get 3.4.17.4. The change log is in the sticky at the start of this forum.

    Comment


    • #3
      Many thanks, everything works fine again.

      Comment


      • #4
        I looked at the code and see that I had already expanded the existing setting on General Page about encoding spaces in the topic so it not only applies to spaces but to all special characters per URI encoding rules. If you change this setting to show spaces in topics then you should be back to what you expect when using the most recent release in the updater.

        Comment


        • #5
          Check it and it works.

          Comment

          Working...
          X