Announcement

Collapse
No announcement yet.

Cheap Tuya Smart Plug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cheap Tuya Smart Plug

    I found this smart plug for $4.99 for a single unit on Amazon.



    I do not see this plug on the tuya-convert list of compatible devices https://github.com/ct-Open-Source/tu...atible-devices. But I plan to try flashing it with Tasmota, use the Generic module type and experiment with the GPIO pin assignments.
    Anyone have pointers on doing this without opening the plug and without bricking the device?

  • #2
    I used generic device. Avoid GPIO 0 and 2 until everything else does not work. Do the button first since that configures it as an input and minimizes chances of something going wrong.

    Comment


    • #3
      Michael, I have found the Relay1 and Led1 GPIOs by experimentation - but none of the GPIOs seem to work for Button1. Any ideas? Here's what I have so far:

      Comment


      • #4
        Never mind, I figured it out. It was GPIO1 for Button1. Will update shortly with template info..

        Comment


        • #5
          The EVA LOGIK smart plug https://www.amazon.com/Socket-Outlet.../dp/B06XZ3J66L can be flashed with Tasmota using tuya-convert https://github.com/ct-Open-Source/tuya-convert. Here are the GPIO assignments based on the Generic (18) module:



          Here is the Tasmota template for this device:

          {"NAME":"EVA LOGIK Plug","GPIO":[255,17,255,255,255,255,255,255,255,52,21,255,255],"FLAG":0,"BASE":18}

          Comment


          • #6
            Good work. I'll add this one to mcsMQTT.pdf if it is OK with you.

            Comment


            • #7
              Thanks. No problem. Go right ahead

              Comment


              • #8
                Wow, those are cheap. Too bad there is no EU version :-(

                Comment


                • #9
                  It must have been a price mistake. Went up to $9.99 today. Lucky for me, I got a bunch of them at the $4.99 price.

                  Comment


                  • #10
                    I purchased four of these a couple of weeks ago and went through the process of flashing as laid out in Michael's MQTT manual (Thanks Michael). However, only two of the four worked after flashing. I thought I had bricked them, so purchased four similar products as the EvaLogik models were no longer in stock or available. Damn, if these didn't work, too. But, I thought I'd try the configuration of the Lunatek plugs found in Michael's manual. Voila! It worked. Then, the thought came to me that maybe the "bricked" EvaLogik modules had a different configuration than described in this thread. That premise was correct. I tried the Lunatek configuration and the button and relay worked, but not the LED. After some experimentation I found the correct configuration. So, if these plugs become available again here's a alternative configuration if the one found above doesn't work:

                    Click image for larger version

Name:	Screen Shot 2019-11-13 at 8.05.08 PM.png
Views:	252
Size:	388.0 KB
ID:	1339896

                    Comment


                    • #11
                      Thanks for sharing.

                      I recently did a water shutoff valve and was surprised that the GPIO had changed from what I had found documented by another that did the Tuya convert. One explanation is that the product label does not indicate what is inside as the marketing team buys whatever is either cheapest or available.

                      Is it ok if I add your find to mcsMQTT.pdf?

                      Comment

                      Working...
                      X