Announcement

Collapse
No announcement yet.

HomeSeer does not shutdown but restarts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Thank you very much for this extensive answer and solution! It works fine and the message about unsuccessfull shutdown of HS has disappeared.

    When I now shutdown HS I can see that the mono processes of the plug-ins disappear one by one. It takes about a minute or 2 before the HS process (HSConsole.exe) is ended.

    ---
    Cor

    Comment


      #17
      Originally posted by zwolfpack View Post
      homeseer.service
      hsstop.sh
      shutdown_controller.sh
      I am still seeing "HomeSeer was not shut down successfully the previous time it was started" with the aforementioned systemd & scripting.
      My Zigbee 4.0.6.0 Beta plugin is not terminating and Insteon 3.0.7.8 is taking a long time but does eventually disappear (about 45 seconds).
      I've tried disabling those two plugins (the exe's disappear) and then stop/start the service but I still see the message.
      HSConsole.exe --log is the first to disappear followed by the plugins shortly after.

      Date/time=2020-05-13 1:46:56 AM PDT
      Version=HS4 Pro Edition 4.0.5.0 (Linux - Debian 10.4, mono 6.8.0.123)
      License=Registered
      Uptime=0 Days 0 Hours 4 Minutes 8 Seconds
      Lan IP=192.168.1.103 (Debian10)
      Device Count=138
      Event Count=66
      Plugins Enabled=NetCAM:,Pushover 3P:,SDJ-Health:,Insteon:,BLLock:,Z-Wave:,Zigbee:
      Modules/Threads=77 Modules, 64 Threads
      Available Threads=399
      HomeSeer Memory Used=142 Mbytes
      HS4Pro running on HP ProDesk
      Plugins: Z-Wave, mcsMQTT, SDJ-Health, CurrentCost
      HA 0.117.5 running on ThinkCenter M73
      Add-ons: AccuWeather, Adaptive Lighting, Alexa Media Player, COVID-19, Geofency, Google Cast, HACS, Insteon, IPP, Life360, Local IP, Logitech Harmony Hub, Mobile App, MQTT, Nest, OpenWeather, OpenZWave, SpeedTest, Ubiquiti UniFi, Zigbee
      Integrations: AppDaemon, Duck DNS, Entiry Controller, File Editor, Google Drive Backup, Home Panel, Mosquitto, NGINX SSL Proxy, Samba, TasmoAdmin, Terminal SSH, motionEye
      OpenZWave 1.6 running on RPi3B+ with RaZberry controller

      Comment


        #18
        In my case the Console.exe is disappearing as last mono process. The others disappear one by one in a rather quick way. The disappearing of Console.exe may take up to 2 minutes.
        I am using Raspbian Buster (Linux 10, mono 6.8.0.105) on a Raspberry Pi4B, would that make a difference?


        Date/time=13-5-2020 12:20:42 CEST
        Version=HS4 Standard Edition 4.0.5.0 (Linux)
        Uptime=0 Days 22 Hours 19 Minutes 34 Seconds
        User/Access=Cor (Admin)
        Lan IP=192.168.1.20 (RPi4-HS4)
        Device Count=481
        Event Count=250
        Last Event Ran=Polling devices : Polling Slof2 - Node 8, Ran at 13-5-2020 12:20:05
        # of unique event scripts=14
        Plugins Enabled=DoorBird:,UltraLog3:,Tuya:,Device History:,Pushover 3P:,Z-Wave:,mcsMQTT:,CM15A:,Arduino:
        Modules/Threads=133 Modules, 98 Threads
        Available Threads=399
        HomeSeer Memory Used=219 Mbytes

        Comment


          #19
          Originally posted by dbrunt View Post
          I am still seeing "HomeSeer was not shut down successfully the previous time it was started" with the aforementioned systemd & scripting.
          With this set up, the shutdown is initiated via the web by the 'curl' command. If you require a password to access the main page it needs further configuration.

          This command should cause HS to shut down. What output does it produce?

          Code:
          curl --data 'ConfirmShutdownhs=Yes' "http://localhost:80/LinuxTools"
          * change 80 to the port you're using if not the default.

          Comment


            #20
            I use the hsstop.sh script to stop HomeSeer. This script is in post #15.
            ---
            Cor

            Comment


              #21
              Originally posted by zwolfpack View Post
              This command should cause HS to shut down. What output does it produce?
              Code:
              curl --data 'ConfirmShutdownhs=Yes' "http://localhost:80/LinuxTools"
              root@Debian10:/home/homeseer# curl --data 'ConfirmShutdownhs=Yes' "http://localhost:80/LinuxTools"
              ["LinuxTools","\u003cbr\u003e\u003cb\u003eShutting down HomeSeer, you will no longer have access to this page.\u003c/b\u003e\u003cbr\u003e","tailfile",""]root@Debian10:/home/homeseer# ps -ef|grep mono
              root 19182 2093 0 13:05 pts/0 00:00:00 grep mono
              root@Debian10:/home/homeseer#

              And that did a clean shutdown...

              Click image for larger version

Name:	Clean Shutdown.PNG
Views:	40
Size:	159.9 KB
ID:	1385308


              I had another look at my hsstop.sh that I copied from post #15 and pasted into 'vi' and found the error.

              I changed this:
              Click image for larger version

Name:	hsstop.sh error.PNG
Views:	32
Size:	12.5 KB
ID:	1385309
              to this:
              Click image for larger version

Name:	hsstop.sh fixed.PNG
Views:	32
Size:	32.1 KB
ID:	1385310
              ...and it's working now. Thanks!
              HS4Pro running on HP ProDesk
              Plugins: Z-Wave, mcsMQTT, SDJ-Health, CurrentCost
              HA 0.117.5 running on ThinkCenter M73
              Add-ons: AccuWeather, Adaptive Lighting, Alexa Media Player, COVID-19, Geofency, Google Cast, HACS, Insteon, IPP, Life360, Local IP, Logitech Harmony Hub, Mobile App, MQTT, Nest, OpenWeather, OpenZWave, SpeedTest, Ubiquiti UniFi, Zigbee
              Integrations: AppDaemon, Duck DNS, Entiry Controller, File Editor, Google Drive Backup, Home Panel, Mosquitto, NGINX SSL Proxy, Samba, TasmoAdmin, Terminal SSH, motionEye
              OpenZWave 1.6 running on RPi3B+ with RaZberry controller

              Comment


                #22
                Originally posted by dbrunt View Post
                I had another look at my hsstop.sh that I copied from post #15 and pasted into 'vi' and found the error.

                ...and it's working now. Thanks!
                Thank you, I've fixed the post to remove that extra linefeed.

                Comment


                  #23
                  Click image for larger version

Name:	thumbs up.PNG
Views:	30
Size:	3.2 KB
ID:	1385321
                  HS4Pro running on HP ProDesk
                  Plugins: Z-Wave, mcsMQTT, SDJ-Health, CurrentCost
                  HA 0.117.5 running on ThinkCenter M73
                  Add-ons: AccuWeather, Adaptive Lighting, Alexa Media Player, COVID-19, Geofency, Google Cast, HACS, Insteon, IPP, Life360, Local IP, Logitech Harmony Hub, Mobile App, MQTT, Nest, OpenWeather, OpenZWave, SpeedTest, Ubiquiti UniFi, Zigbee
                  Integrations: AppDaemon, Duck DNS, Entiry Controller, File Editor, Google Drive Backup, Home Panel, Mosquitto, NGINX SSL Proxy, Samba, TasmoAdmin, Terminal SSH, motionEye
                  OpenZWave 1.6 running on RPi3B+ with RaZberry controller

                  Comment

                  Working...
                  X