Announcement

Collapse
No announcement yet.

Howto get HSdevice value to mscMQTT

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I will see into this tomorrow and report back later. Thanks for now.

    Comment


      I removed the obsolete devices 704 and 705 as you advised and once again I repeated your steps (italic):

      1 - From General tab, deselect statistics devices to be created in HS. Check!
      2 - From HS Devices view the statistics. Well, this is not possible, they all disappeared after I deselected statistics devices to be created in HS! So I selected this again and I can see the devices. Mine are in the MQTT Room, not in Floor as with you. I observe that all devices are updated but that the Broker status is offline!
      Furthermore I see the double devices in the HS4 device manager, but in the legacy device manager I see just the parent statstics with the 17 child devices as shown below.

      Click image for larger version

Name:	2020-07-10_112424.png
Views:	91
Size:	82.6 KB
ID:	1401243
      3. Click on the Statistics device and at the bottom use the Delete icon. This will remove it and all the children (features). The HS device page should no longer show any of these. Make certain there are none in other rooms or categories to confirm that you have all record of earlier created statistics devices removed. Check!
      4. From General tab, restore statistics in HS. In my case they were allready checked, see point 2.
      5. Restart HS and observe the warning messages are not present. Well the same warning messages still appear in the logfile.
      Also all devices are double again, only in the HS4 device manager. In the legacy device manager as in the figure above, except the Broker status now is online!

      The double devices have no features (No extra features for this device) and no Statics/ Graphics (Advanced settings, changes could cause devices to not work as expected). Is it normal that these devices are doubled? They are not in the legacy device manager so could this be a HS4 problem?

      Comment


        You should be happier with http://mcsSprinklers.com/mcsMQTT_5_4_0_1.zip
        Toggle the General Tab button to create the statistics devices. Note the update/suspend control is on a new child device and no longer on the root device.

        Comment


          YES, I am happy now. No more warnings in the HS logfile and no double devices in HS4 device manager!

          MQTT is now in Floor and Room.

          Thanks for now!

          Comment


            Michael,

            if I look at the statistics then about 4% is 'Not Accepted'. Is this a normal number?
            Is it comparable with packet collision?
            It is working great now!

            Click image for larger version

Name:	2020-07-23_122638.png
Views:	39
Size:	332.7 KB
ID:	1405102

            Comment


              Packet collision has no bearing. The difference in the accepted and not accepted counts are topics that are sent by broker that are associated with HS devices vs. those that are not associated. What does not seem correct to me is that device 1258 and 1256 reflect the same topic so they should exist in only one of the two. I will take a look and see if I observe something similar. It it not something I normally look at.

              Comment


                I was confused because the plugin created the wrong names for "Last Received not-Accepted" for Topic and Payload. These should be "Last Received" without the "not-Accepted". The counts are correctly labeled. This means you have received 322 topics today that were not associated with HS devices and 11094 topics that were associated. This is 3%. Normal depends upon each person's setup. There should be some topics that are on the Association tab that are not associated to HS devices. These topics are being received at a 3% rate of the others that are associated.

                Comment


                  OK, so it comes down to changing 'Accepted' to 'Associated' ?

                  Comment


                    I just installed the new HS4 version 4.1.2.0 so the HS4 system was restarted. I notice that the statistics devices are not updated, All status fieds are 0 except the online status, that is green and OK.
                    I tried disable and enable the plugin but no change. Also tried suspend / resume but no change.

                    I unchecked the 'Show Statistics in HS Devices and mcsMQTT Statistics Tab' and checked again. All new devices appear but all are 0.

                    In the association tab everything looks fine, things just work.

                    Did i mis sonething? I am running Version 5.4.0.1 of mcsMQTT.

                    Comment


                      You did not leave well-enough alone. 4.1.2.0 broke the numeric update in devices. This is for both HS3 and HS4 plugins. I did make a minor update to the Statistics in HS3 plugin to match the HS4 plugin. The HS3 one is at http://mcsSprinklers.com/mcsMQTT_5_4_0_7.zip

                      Comment


                        It is working correctly again, including the updated text in the statustics devices.
                        Thank you!

                        Comment


                          In the plugin statistics page there is still referene to 'accepted' topics and payloads.

                          Comment


                            I'll fix the text in the next update. I submitted a HS4 issue on Github last week for lack of numeric update unless graphic formatting is defined. I observed this defect in 4.1.2.0 but not in 4.1.1.0 or earlier.

                            Comment

                            Working...
                            X