Announcement

Collapse
No announcement yet.

Generator integration with MQTT, trouble with triggering script

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Generator integration with MQTT, trouble with triggering script

    I have successfully integrated my Generac generator to Homeseer using MQTT plugin and software developed here: https://github.com/jgyates/genmon/wiki

    I have Homeseer devices that track generator values which are updating appropriately:

    Click image for larger version

Name:	generator devices.jpg
Views:	82
Size:	57.6 KB
ID:	1395681
    I am trying to trigger a script based on the device string for dev ref 5743, generator Status Run Log, using Easy Trigger and I can't get the event to trigger. I have tried multiple variations of the string matching to no avail.

    My question is, is Homeseer registering the device string change of these MQTT devices so that Easy Trigger will pick them up?

    If so, then perhaps there is some html coding in the device string that makes it not match?

    Or maybe this is an issue with Easy Trigger... thought I would post here first.

    #2
    For what I see for 5743 is the last payload of "Run Log". I also see a Device Status of "06/21/20... - Auto". What I think is likely is the Edit tab in mcsMQTT for Control/Status UI is not set to Text and the "06/21/20... - Auto" is part of a VSP definition. If you are triggering on text then your Control/Status UI should be set to Text radio.

    Comment


      #3
      Turns out it is already selected as text.

      Click image for larger version

Name:	dev ref 5743.jpg
Views:	60
Size:	129.8 KB
ID:	1395694

      Comment


        #4
        It should then be storing the payload in DeviceString. Another suggestion is to use the current version that explicitly stores in the DeviceString based upon radio setting that was added to the Edit tab. http://mcsSprinklers.com/mcsMQTT_5_3_0_3.zip. Unzip mcsMQTT_2020.dll into \bin\mcsMQTT folder. HSPI_MCSMQTT.exe into HS folder. Even it this does not help you will need to be in sync with my source to do further debug.

        Comment


          #5
          Upgraded to 5_3_0_3 and selected "store payload in HS Device String" and it worked !

          Thank you for your help and an excellent plugin

          Comment


            #6
            Originally posted by prsmith777 View Post
            Upgraded to 5_3_0_3 and selected "store payload in HS Device String" and it worked !

            Thank you for your help and an excellent plugin
            I'm curious, did you try doing anything with the software you can buy to monitor Generator First? I'm not really thrilled about paying another fee for software but I was wondering if you looked at that?

            Comment


              #7
              Originally posted by Tomgru View Post

              I'm curious, did you try doing anything with the software you can buy to monitor Generator First? I'm not really thrilled about paying another fee for software but I was wondering if you looked at that?
              If you are talking about the Generac monitor and software, then no I didn't consider it. Didn't want to pay extra $$ when the RPi hardware is cheap and the software free.

              Comment


                #8
                Originally posted by prsmith777 View Post

                If you are talking about the Generac monitor and software, then no I didn't consider it. Didn't want to pay extra $$ when the RPi hardware is cheap and the software free.
                That's what I figured

                Comment

                Working...
                X