Announcement

Collapse
No announcement yet.

HS4 Client Can not pick up any topics?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 Client Can not pick up any topics?

    I have been testing your plugin.

    Im running HS4 PRO
    windows 10
    .net 4.8xx

    i have a broker installed as service x64 on the same win machine.
    I only changed the port number in the mosquito config so far.

    first time I tested it was before you made the HS4 version.
    and it seem to work for a while adding new topics and stuff.
    then something went wrong so I installed the HS4 version.
    same thing again.

    I might do something wrong right now it is not discovering any new topics at all.

    i have the explorer mqtt installed on a different Mac and I can see all topics from the broker, so the broker works.

    I have this time only installed the plugin version from plugin store I also tried the 5.6xx version no luck.

    before installing this time I did delete all files related to your plugin manually after delete the plugin and start completely over.

    i of course restarted HS4 every time.

    right now I have only setup the ip-adress and the port for the broker.

    is there something I miss ? I have read your doc maybe I missed something.

    Click image for larger version

Name:	BBED3F4A-D388-4F16-8F38-A23E32F0A32E.png
Views:	43
Size:	176.7 KB
ID:	1427683
    Click image for larger version

Name:	7E2A7BCE-BA25-49FE-8AB8-5AF4F3C18322.png
Views:	16
Size:	54.5 KB
ID:	1427684


    #2
    It looks like you are connected to broker. What do you have setup for Topic Discovery / Subscriptions in the Inbound Management section on General tab?

    Comment


      #3
      It is just the standard config.


      Click image for larger version

Name:	45F1AA78-1209-4A44-9FE4-5E470407C0A1.png
Views:	18
Size:	273.8 KB
ID:	1427700

      Comment


        #4
        If debug is enabled from General tab then the subscribe list actually being requested of the broker will show up in /data/mcsMQTT/mcsMQTT Debug.txt. It will also show received messages, but statistics show nothing has been received.

        I have never tested with other port numbers, but if it connects then the port should be fine.

        Another debug approach is to use the mcsMQTT broker (clear the broker ip text box) and setup node red to use it on port 1883.

        There was another similar discussion about a week or two ago in what I think was in the mcsMQTT HS3 forum where the user had some network-type issues. That discussion may give you some ideas as well.

        Comment


          #5
          I only changed the port because of debug. IF it was the port number 1883 that was conflict any thing.

          also the firewall is disable.

          I have been using the built in broker before I can do that again for a debug.
          but I stopped using it because it run the fans wild on the pc.

          I also thinking if it could be anything to do that the mosquito I installed is 64bit instead of 32bit.

          but also my nodered is connecting fine to the mosquito it did not work very well with your built in broker.

          I will test this later today and see if anything is helping.

          and check the suggested forum.

          Comment

          Working...
          X