Announcement

Collapse
No announcement yet.

Shelly Duo - RGB GU10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shelly Duo - RGB GU10

    Hi all,

    I have received one of these:

    https://shop.shelly.cloud/shelly-bul...automation#432

    But integration in HS is only half it seems. Some statuses are there (and follow if I modify through the webinterface of Shelly device), but some seem missing. Also graphics are missing, and commands not possible. For my other device (plug) everything was plug & play. Anyone has experience with this device and how to configure?

    Kind regards.

    #2
    Shelly has not released an API for the DUO GU10. Only the original DUO. If you provide some basic information I can integrate it.. The easiest thing to do is enable debug on mcsMQTT. Cycle power on the GU10. Post \data\mcsMQTT debug.txt or email it to mcsSolutions at CenturyTel dot net.

    Comment


      #3
      Dear Michael,

      Ordered the original duo, but somehow received the brand new RGB version. Debug sent to your mail.

      Kind regards.

      Comment


        #4
        I made the updates in the attached which goes in the \bin\mcsMQTT folder for the HS3 plugin. The install process should be
        1. remove power from the bulb
        2. On General tab, Inbound Management section, Obsolete row: enter shellies/shellycolorbulb/# in the text box. This will remove all previously discovered info on the topic. If there were previously HS devices created then remove them if they are not automatically removed.
        3. disable mcsMQTT plugin
        4. unzip the attached to \bin\mcsMQTT
        5. enable mcsMQTT plugin
        6. apply power to the bulb. A set of devices should be created such as below

        Click image for larger version

Name:	Capture.PNG
Views:	53
Size:	381.5 KB
ID:	1459250

        Comment


          #5
          Hi Micheal,

          Thanks for the quick response. However I am afraid the result was not what I hoped.
          • the 'obsolete' action did not do the trick, but that is not a big issue since I can delete individually
          • bigger problem is that, with the new dll activated, my system becomes very unstable
            • plugin does not start completely (plugin pages not availalbe)
            • plugin management page can not be displayed
            • standard devices page becomes extremely slow, events start behaving strange etc.
            • I tested several times using old dll an then again new dll. With old dll my system works OK, with new not at all
          Any ideas?

          Comment


            #6
            I'm not certain what base plugin version of the HS3 plugin you are using, but if not reasonably current it may not be compatible with the attached dll. The entire plugin is at http://mcsSprinklers.com/mcsMQTT_5_15_0_0.zip. The Updater Override process to use it is described at the bottom of the first post at Direct Storage from HS Devices to InfluxDB - HomeSeer Message Board

            Comment


              #7
              I am using 5.14.2.3, the current one on the HS plugin page.

              Comment


                #8
                It should be OK, but still the best way to proceed is to follow the instructions referenced in post #6 to install the full plugin. If that does not work then the debug will be using the current software.

                Comment


                  #9
                  I submitted this version to the Updater so you should also be able to get it through normal channel in a few days.

                  Comment


                    #10
                    Used the procedure / version described in post #6. Works fine now ūüėä

                    Comment


                      #11
                      Need to come back on my previous post. Color bulb is working, however topics / associations connected to my HS devices disappeared for the plug i have. Status of the HS devices is still updated, however on/off command is no longer working. How can I repair this?

                      Comment


                        #12
                        however topics / associations connected to my HS devices disappeared for the plug i have
                        Can you provide some screen shots of the issue. I do not understand.

                        however on/off command is no longer working
                        Enable debug from the top of General tab. Attempt to control the on/off. Post debug file that will be in \data\mcsMQTT\mcsMQTT Debug.txt.

                        Comment


                          #13
                          First image: HS devices. Status updating, command no longer working, it did before bulb was added. Second image current topics / associations. The ones linked to the HS devices in image 1 disappeared after adding the bulb.
                          Attached Files

                          Comment


                            #14
                            Note you are showing the shellies/announce topic and not the shellies/shellyplug-s-B575C8 topic. Do you not have this topic in the Association tab? Are the Association tab filters set of only show the shellies/announce topic?

                            Can you email \data\mcsMQTT\mcsMQTT.db to mcsSolutions at CenturyTel dot net? This is the database of MQTT topics and their associations with HS devices.

                            If you do not want to provide the email then suggest to use the same process as was used to obsolete the Duo but now the plug (i.e. in obsolete textbox +/shellyplug-s-B575C8/#). Also delete the HS devices manually.

                            Comment


                              #15
                              Only announce topics exist, no other topics exist for the shellyplug. No filters active, cleared all filters to be sure.

                              DB is on its way.

                              Comment

                              Working...
                              X