No announcement yet.

HS Newbie - industrial PLC - Tbox

  • Filter
  • Time
  • Show
Clear All
new posts

    HS Newbie - industrial PLC - Tbox

    Hi everybody and thank you to welcome me in this forum.
    English is not my mother tongue, so please forget my errors and mistakes.
    *** see updateS at the end ***

    I'm not new in HA but I'm new here. Few specs to define myself.
    I run an industrial PLC (Tbox-Servelec, master), with a lot of hooked modbus devices. Barionet slave modbus tcp with 1wire sensors, different modbus rtu slaves like energy meters (eastron), some rtu slaves (temcocontrols), some rtu 1wire unit (I like 1wire sensors...) from cel-mar (Poland), some chineses modbus relays... A bit messy, but this is working.

    I control principally a (kind of old - 7 years) geothermal unit without any new HA data: I installed current sensors, temp sensors and pressure sensors to retrieve interesting data. I need to install a btu meter very soon (should be calibrated) to receive those important infos. I plan to install in the spring thermal vacuum solar panels (to heat water), coupled with an instant water heater... Pffff, a lot of work ;-)

    My problem: the plc has very little memory and I'm struggling everyday to display my data. Imagine, I program built-in html webpages to display temperatures and graphs (I use Rgraph functions), but I need to use html compressor, url shrinkers and other funny stuff to minimize my code...

    I work in IT and I'm really interested to use HS on a server and create nice and easy pages, including for my tablets/cellphones). The plc is working mostly in standalone mode (no need to run a server to let it work) with embedded ladder/basic programs. HS will be used to display things and interact... maybe a little bit easier. I'm a lot concern about security and I don't need really to access frequently my units. But I want to retrieve data and very interesting (personal joke) info, like how many flushes I've done this month or how long were my weekly showers. Yes, I installed thoses flow sensors in my toilet and shower... And, obviously, I have a very WAF here ;-)

    After this long intro...

    I want to be sure that modbus plugin will work with HS. I didn't purchase HS yet. Nor the plugin. I will test the HS trial. I can purchase the modbus plugin if it works with the trial (asked support team). And waste the plugin if not working.
    But I'll appreciate your comments here. Obviously, I won't discard my modbus units ($$$), so I'm looking for a nice HA with functioning modbus plugin.
    Does HS will do the job ?

    Many thanks to all of you who will give me hope and answers !

    Update 2 days later.
    - Installed trial HS and downloaded modbus plugin: OK
    - added modbus TCP gateway (barionet - - 502): OK
    - Passed connectivity test to gateway: OK
    - added device (holding device RW - register 934 - int16 - signed): OK -
    - checked read only / device enabled on the settings
    - this device is a temperature sensor
    - tested this device through modbus poll: OK , value is now 243 (aka 24.3 celsius)
    - went to homeseer home
    - clicked on poll device
    - obtained this:
    1 @ Polling: Modbus System Barionet (Status isResult not set by Plugin))
    0 @ Polling: Modbus System Kitchen-bario (Status isResult not set by Plugin))

    Where is my error ?

    Update #2 (going better... and not):
    I checked the forum and discovered that I can't check at the same time read only and enabled (not obvious because my sensor is read only...)
    then I obtained a value, yeah !
    ok, the value is integer and I need a float one (24.3 instead of 243)
    for an unknown reason a "good" value (243) was displayed for the register 934, that's the good point.
    5 minutes later, I tried to add a second sensor (register 938): OK
    But no data on this one AND I lost the value of the first one ;-(
    deleted the second sensor, the first one remained unknown
    but 5 minutes later, the right value reappeared...
    sound a little weird to me
    Any idea ?

    update #3:
    added 3 sensors: OK
    Polling seems weird, or strange, or random.
    where can I control those polling parameters ?
    Btw, is it a place where I can find the settings of those modbus plugin parameters ?

    update #4:
    found the modbus plugin parameters and set them to 1 minute.
    added more sensors...
    discovered that the last change info is not reflecting the last poll, but the last change (seems obvious) !
    Because some temperatures didn't change that fast, the last change info stayed for a long time, so my (wrong) feeling. Fixed

    Playing by myself is of course a little bit more difficult at first, but playing without help teach me how it works faster ;-)
    Anyway, have a nice year 2018, with a lot of success, and good health.
    Attached Files
    Last edited by ppz1961; December 31, 2017, 01:41 PM. Reason: updated my post