Announcement

Collapse
No announcement yet.

Help getting started with Fronius inverter

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help getting started with Fronius inverter

    Hi, even after much reading up and down this group I can't get data using this plugin from my new Fronius Primo inverter. I see reference to other people getting the Float32 values into Homeseer ok but I'm having no luck. I've got polling working fine using "Modpoll -c 5 -r 40070" as an example. My inverter is set to type "111" Single Phase SunSpec so that seems to be the Float32 registers rather then an integer etc. I'm able to use Modpoll and other tools to grab data say for example 40108 for MPPT DC power, well at least get some numbers back that don't mean much to me but they might need scaling etc.

    Am I meant to do anything on the Status Grpahic's tab for each register to define the range etc or should just getting the numbers correct in the Modbus tab be enough? I've tried every combo of using 40108 or 108 etc with signed and unsigned and 0 or 1 as the multiplier and different timeout and delay times but still no data in the child device. I scaled it back to just the parent and one enabled device at a time but still nothing.

    Some examples below.

    Any input would be much appreciated since I thought I could work my way though this as a technical IT chap myself but I'm just guessing now.

    Thanks!
    Click image for larger version

Name:	2019-06-01 21_46_33-42,0410,2049 (1).pdf - Foxit Reader.png
Views:	93
Size:	355.0 KB
ID:	1308210
    Click image for larger version

Name:	2019-06-01 22_23_31-Modify Garage Garage Inve....png
Views:	56
Size:	24.0 KB
ID:	1308211

    #2
    I got it going last night finishing up at 2.30am... I'll post my settings once the coffee shakes have warn off

    Comment

    Working...
    X