Announcement

Collapse
No announcement yet.

HS4 setup question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 setup question

    Today I decided to upgrade to HS4 and also bought your HS4 plugin (being a fan since a long time).
    I have an USB Plugwise Circle+ interface, which I managed to get setup and working. I can see also the devices in the rooms (not sure whether these came through the HS3 upgrade process as I imported the config). Unfortunately on the Plugwise plugin page I don't see any devices, only the circle+.
    Therefore I was curious to read the manual of your HS4 plugin, but couldn't find that. Could you help me?

    #2
    Hi ABL,

    Thanks for using my plugin! One of the goals for the HS4 version was to make the whole process a lot easier. Scanning of devices and adding them to HomeSeer is no longer needed. New devices will be detected automatically, and therefor, no list of devices is shown on the setup pages anymore. There is nothing to configure anyway. Any device known to the stick that was added to the Plugwise network will result in a HomeSeer device with relevant features.

    I still need to update the manual, need to find some time.

    Just use the devices as you did before and forget about the complicated configuration.

    Thanks!
    stefxx

    Comment


      #3
      Thanks for your quick reply and the confirmation that I'm not overlooking anything.
      I was wondering if you can help me out how I can make a separate device for the total kWh (total usage) for each device. My goal is to push that to InfluxDB and Grafana as separate devices...

      Comment


        #4
        Great!

        Not sure I understand your question. Every device already has a total kWh feature (child device) that you should be able to use for this right?.
        stefxx

        Comment


          #5
          Indeed, that's what I expected as well. But I can't see the child device, only the device itself.

          Example: When I choose the Devices tab and filter on my Living Room I can see 'TV' Plugwise circle.

          Click image for larger version

Name:	Device.PNG
Views:	93
Size:	34.9 KB
ID:	1402803
          Hovering over the black button it shows the current Watt and total kWh. However I would like to see the kWh as a separate child device. I think I should enter some information in the settings page of my device (Settings/Features/Status/Graphics/PlugWisePro), but I can't figure out what to enter to make the child device visible. Or should I do something else?

          Comment


            #6
            I think something has gone wrong migrating from the old free Plugwise plugin to this paid version. All times that are reflected in the plugwise devices are of the older HS3 installation. Should I delete all plugwise devices and try to restart the plugin from scratch?

            Comment


              #7
              Not sure what's happening. There is nothing you should do or configure to see those child devices (named features in HS4).

              Make sure you are in "List View" instead of "Grid View". Make sure no filters are applied and select the "Plugwise Stick" category. This should show all (and only) Plugwise devices.

              You should see something like this:
              Click image for larger version

Name:	Annotation 2020-07-15 221306.png
Views:	91
Size:	112.5 KB
ID:	1402811
              stefxx

              Comment


                #8
                From which version did you upgrade?
                stefxx

                Comment


                  #9
                  Never mind, "the old free Plugwise plugin". That doesn't work.

                  https://forums.homeseer.com/forum/li...fore-upgrading

                  Yes, I suggest to stop the plugin, remove all plugwise devices and start the plugin again. New devices will be created automatically. Note that events and scripts that reference those devices will need to be adjusted.
                  stefxx

                  Comment


                    #10
                    I selected the list view and deleted all filters/rooms/floors... There is no Plugwise Stick filter in my category list. I just looked at the old HS3 directory and I can find a manual indicating it was V3.0.

                    Comment


                      #11
                      Just deleted all my Plugwise devices (about 30), disabled the plugin and started the plugin. 17 devices were created automatically, so not all. Furthermore, as I can see now, no child devices have been created...

                      Also tried to delete my gateway and activate it anew, also resulting in only 17 devices. When closing HS4 and starting Plugwise Source software, all 31 devices are live.

                      Thereafter, I deactivated the Plugwise plugin, deleted all devices and gatewat, shut down HS4 and restarted my Windows 10 pc. Started all over again, now 18 modules are shown and only 1 of them shows a child device (watt). Maybe it just takes time to have HS4 load all data (as I have these plugs for many years), so I will have a look again tomorrow morning...

                      Comment


                        #12
                        Turned out that all devices and features existed already, but somehow lost their root/child relation (in HS4 terms, device/feature relation). Unsure how that happened, but as the HS4 device list doesn't show any childs (features) that are not connected to a root (device), it was difficult to spot the issue.

                        If anyone runs into the same issue, let me know as I would like to understand if this was a glitch or something wrong in the plugin. Anyway, it can be resolved by removing all child devices (features) by using the /deviceutility interface (the old HS3 interface).

                        Thanks!
                        stefxx

                        Comment


                          #13
                          And many thanks for your quick solution and tremendous service. All is running perfect now. Although I used the old free plugin for many years without any issues, the new functions of the new plugin are very smooth and helpful...

                          Comment

                          Working...
                          X