Announcement

Collapse
No announcement yet.

Support for HS220 wall dimmer switch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jasv
    replied
    Bummer that you had to remove/re-add. The plug in should have recognized the difference in about 5 minutes. Glad it is working now. Thanks for the update.

    Leave a comment:


  • MrPCHead
    replied
    Originally posted by jasv View Post

    I got my KL110 and tested. I've put in version 2021.3.14.0 in the beta section. I added the "versions" in the settings so we can make sure we are running the right code.
    I did see the same error you pointed out and could not figure it out so I cannot tell you 100% that it is fixed. However, I tested different ways to add, turn off dimming, etc and it works each and every time. It is a "reach" but sometimes DLLs get loaded into memory and you might have to restart HS or even your computer. The settings page will tell you for sure. Please update both the .exe and the .dll..

    Click image for larger version

Name:	tplink_dll.png
Views:	24
Size:	101.3 KB
ID:	1463243
    Success! I swapped in the EXE and DLL, restarted the plugin and no change. I ultimately had to remove/re-add the two bulbs and now they are fully functional as dimmable devices! I added them back to the relevant events and everything is working as expected.

    Thanks so much!

    Leave a comment:


  • jasv
    replied
    Originally posted by MrPCHead View Post

    I've updated the DLL. Nothing changed and when I enable the plugin it immediately throws those same two errors.
    I got my KL110 and tested. I've put in version 2021.3.14.0 in the beta section. I added the "versions" in the settings so we can make sure we are running the right code.
    I did see the same error you pointed out and could not figure it out so I cannot tell you 100% that it is fixed. However, I tested different ways to add, turn off dimming, etc and it works each and every time. It is a "reach" but sometimes DLLs get loaded into memory and you might have to restart HS or even your computer. The settings page will tell you for sure. Please update both the .exe and the .dll..

    Click image for larger version

Name:	tplink_dll.png
Views:	24
Size:	101.3 KB
ID:	1463243

    Leave a comment:


  • jasv
    replied
    bummer.

    The fact that the error got thrown again tells me that either I posted the wrong DLL or the DLL didn't' get downloaded properly. Those messages are no longer in the code.

    I get my KL110 today. I will test and see why this device is different.

    Leave a comment:


  • MrPCHead
    replied
    Originally posted by jasv View Post

    My instructions were wrong. The plugin DLL must also be updated/replaced. Please look at the instructions again (I've updated them)
    I've updated the DLL. Nothing changed and when I enable the plugin it immediately throws those same two errors.

    One more thing: I removed one of the bulbs from HS4 entirely then added it back via the plugin discovery method. It found the bulb immediately but as before, the plugin tab data showed IsDimmable:false even though the "manage devices page" details showed IsDimmable:1. As before, I disabled the plugin, edited the INI file to "true", restarted the plugin, and no change.

    Leave a comment:


  • jasv
    replied
    Originally posted by MrPCHead View Post


    FYI, I'm seeing these two errors frequently in the log:

    PollAndUdateHSDevices() - Device: Kasa Bulb 1 with ref: 836 had an error: please use Kasa to verify that it is online. Error: Bulb does not support color temperature changes.

    My instructions were wrong. The plugin DLL must also be updated/replaced. Please look at the instructions again (I've updated them)

    Leave a comment:


  • jasv
    replied
    Originally posted by MrPCHead View Post


    FYI, I'm seeing these two errors frequently in the log:
    HSPI_TPLinkSmartHome4

    Error
    PollAndUdateHSDevices() - Device: Kasa Bulb 2 with ref: 838 had an error: please use Kasa to verify that it is online. Error: Bulb does not support color temperature changes.
    HSPI_TPLinkSmartHome4

    Error
    PollAndUdateHSDevices() - Device: Kasa Bulb 1 with ref: 836 had an error: please use Kasa to verify that it is online. Error: Bulb does not support color temperature changes.

    That log info is very helpful . I ordered a KL110 but I think I know what the issue is. I will try to post another beta tonight. Worst case I get my KL110 tomorrow and I can fix it then.

    Leave a comment:


  • MrPCHead
    replied
    Originally posted by jasv View Post
    Hmm. Can you check the installed plugins to make sure it says version 2021.3.13.0?
    Can also take a look at TPLinkSmarthome4 tab to see if the "isDimmer" is now true?
    2021.3.13.0 is the plugin version.

    Here's the TPLinkSmarthome4 tab info:

    Plugin Extra Data (PED)
    TPLink_json:{'ip_address':'10.1.1.20','tpl_device_type':'SMA RTBULB','isColor':false,'hex_color':'','isMeter':false,'isDi mmable':true,'isDisabled':false,'jvCount':0,'color_temp':0,' devVersion':'2021.3.4'}

    Polling is not disabled.

    FYI, I'm seeing these two errors frequently in the log:
    HSPI_TPLinkSmartHome4
    Error
    PollAndUdateHSDevices() - Device: Kasa Bulb 2 with ref: 838 had an error: please use Kasa to verify that it is online. Error: Bulb does not support color temperature changes.
    HSPI_TPLinkSmartHome4
    Error
    PollAndUdateHSDevices() - Device: Kasa Bulb 1 with ref: 836 had an error: please use Kasa to verify that it is online. Error: Bulb does not support color temperature changes.


    Leave a comment:


  • jasv
    replied
    Originally posted by MrPCHead View Post

    disabled plugin, replaced the EXE with updated version, enabled plugin, waited 1/2 hour. No change. Rebooted machine, no change.
    Also, can you be sure you have polling enabled in the settings?

    Leave a comment:


  • jasv
    replied
    Hmm. Can you check the installed plugins to make sure it says version 2021.3.13.0?
    Can also take a look at TPLinkSmarthome4 tab to see if the "isDimmer" is now true?

    Leave a comment:


  • MrPCHead
    replied
    Originally posted by jasv View Post

    I've posted version 2021.3.13.0 to the beta thread which is here
    There are instructions on what to do there.
    I did manage to recreate the issue and the beta should fix it. Give it about 5 minutes after restarting the plugin and your devices should then have a slider for dimming.
    disabled plugin, replaced the EXE with updated version, enabled plugin, waited 1/2 hour. No change. Rebooted machine, no change.

    Leave a comment:


  • jasv
    replied
    Originally posted by MrPCHead View Post

    Happy to help. Where should I look for the beta?
    I've posted version 2021.3.13.0 to the beta thread which is here
    There are instructions on what to do there.
    I did manage to recreate the issue and the beta should fix it. Give it about 5 minutes after restarting the plugin and your devices should then have a slider for dimming.

    Leave a comment:


  • MrPCHead
    replied
    Originally posted by jasv View Post

    I think I know the issue. I will post a beta later today that I hope you can also help with testing. Thanks.
    Happy to help. Where should I look for the beta?

    Leave a comment:


  • jasv
    replied
    Originally posted by MrPCHead View Post

    Happy to help if I can.

    So I disabled the plugin, changed the config file, restarted the plugin, and nothing has changed, i.e., no dimmer controls for the bulbs.
    I think I know the issue. I will post a beta later today that I hope you can also help with testing. Thanks.

    Leave a comment:


  • MrPCHead
    replied
    Originally posted by jasv View Post

    I think the problem has to do with the versions. if you notice the tab data shows isDimmable:false but the details from the device show is_dimmable:1 (or true). When the device was created I didn't capture the dimmable correctly.

    Could you ...
    1. disable the plugin
    2. edit your HSPI_TPLinkSmartHome4.ini file in the config folder
    3. change KL110 from isDimmable:false to isDimmable:true
    4. Restart the plugin
    5. Test dimming of one of your KL110s

    The version I am working on right now will refresh the settings and prevent this issue. Thanks for pointing it out.
    Happy to help if I can.

    So I disabled the plugin, changed the config file, restarted the plugin, and nothing has changed, i.e., no dimmer controls for the bulbs.

    Leave a comment:

Working...
X