Announcement

Collapse
No announcement yet.

LIFX Bulb Not Detected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • LIFX Bulb Not Detected

    Just installed my first LIFX bulb. It's working fine with the phone app, but UltraLighting3 does not detect it.

    I have homeseer installed on Linux (Synology NAS using Docker.) The plugin is version 3.0.6158.37550. The bulb is one of the new 3rd gen A19 bulbs. Router is an ASUS RT-AC68U. I'm not having any issues connecting to other devices on the network, like Global Cache IR and Ecobee thermostat.

    Any ideas? Since other networked devices work fine, would it be possible to allow manually adding a light using it's IP or MAC address, or is that not possible based on how the plug-in works?
    Last edited by AEBogdan; December 13th, 2016, 06:31 PM.

  • #2
    Two weeks lift on my trial. Was hoping to have these working before Christmas. Any thoughts or ideas or assistance?

    Comment


    • #3
      I haven't seen that issue before, but do you happen to have 2 network cards in the machine running Homeseer? Ultra added an option so you can choose what nic/network you want it to look for the bulbs on because of some people running 2 cards.

      Jeff

      Comment


      • #4
        If I leave the IP address out, UltraLighting3 starts. I tried binding to each of the two Synology IP addresses, but I get errors in the log.

        I would try assigning the port UltraLighting3 uses to Docker, but the port appears to change every time I restart UltraLighting3, so I can't even test if that will work.

        Plugin UltraLighting3 has connected. IP:127.0.0.1:33200

        Plugin UltraLighting3 has connected. IP:127.0.0.1:33791

        Plugin UltraLighting3 has connected. IP:127.0.0.1:34668

        Without assistance from the developer I may have to give up. The only thing left for me to try would be moving
        Homeseer off Linux or out of Docker, but that's a big task and change to my setup for no guarantee that it'll solve the issue.

        Comment


        • #5
          UltraLighting3 HSPI version 3.0.6158.37550 is the latest. From PLUG-INS > UltraLighting3 > UltraLighting3 > Status, does the bulb show up at all? Possibly under "LIFX Unknown"?

          Regards,
          Ultrajones
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            Originally posted by AEBogdan View Post
            Two weeks lift on my trial. Was hoping to have these working before Christmas. Any thoughts or ideas or assistance?
            I am sorry you are experiencing issues with my plugin. Please open a ticket with HomeSeer and ask them to extend the trial another 30 days.
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              No bulbs are detected at all, and now I think I know why...

              The UltraLighting3 HSPI communicates to the LIFX bulbs using UDP. The plug-in sends out a broadcast UDP query to find the bulbs on the network. Please check your router to make sure your not blocking broadcast UDP queries.
              This information gave me enough info to discover what's up. Looks like Docker does not handle UPD broadcasts outside of the device it is installed on. It's been in their issues list since April of 2015 and is still listed as OPEN.

              https://github.com/docker/docker/issues/11998

              My other Network devices worked because I hand entered the IP address. So, either I need to reinstall/move HomeSeer outside of Docker, or Docker needs to add external UPD broadcasting, or I need a way to add a bulb using a fixed IP address instead of UPD.

              Guess this will be on my decision list for 2017.

              Comment


              • #8
                Even though I bought LIFX bulbs specifically because this plug-in existed for HomeSeer, I'm going to give up on using this plug-in. I don't have time to reinstall HomeSeer just for these bulbs, and there's no way to add a bulb using the IP number instead of UDP.

                Comment

                Working...
                X